Profiling OpenMP program with vtune command line

Profiling OpenMP program with vtune command line

Hi all,

I understand that vtune supports openmp programs. But from the documents I read, I only see GUI based versions. I am wondering if I can use command line vtune on linux to get the similar reports (like showing how much time spent in openmp region xxx).

I tried it , the report I got was like this:

amplxe: Using result path `/home/lud/omp/lud_duplication/random_0.04_keep/r002ah'
amplxe: Executing actions 50 % Generating a report                             Function                  Module       CPU Time  Spin Time:Imbalance or Serial Spinning (OpenMP)  Spin Time:Lock Contention (OpenMP)  Spin Time:Communication (MPI)  Spin Time:Other  Overhead Time:Creation (OpenMP)  Overhead Time:Scheduling (OpenMP)  Overhead Time:Reduction (OpenMP)  Overhead Time:Other
------------------------  -----------  --------  -----------------------------------------------  ----------------------------------  -----------------------------  ---------------  -------------------------------  ---------------------------------  --------------------------------  -------------------
func@0x402280             lud_omp.exe    0.054s                                               0s                                  0s                             0s               0s                               0s                                 0s                                0s                   0s
func@0x40162d             lud_omp.exe    0.032s                                               0s                                  0s                             0s               0s                               0s                                 0s                                0s                   0s
func@0x401840             lud_omp.exe    0.032s                                               0s                                  0s                             0s               0s                               0s                                 0s                                0s                   0s
func@0x402730             lud_omp.exe    0.010s                                               0s                                  0s                             0s               0s                               0s                                 0s                                0s                   0s
[vmlinux]                 vmlinux        0.003s                                               0s                                  0s                             0s               0s                               0s                                 0s                                0s                   0s
__kmp_dispatch_init<int>  libiomp5.so    0.001s                                               0s                                  0s                             0s               0s                               0s                             0.001s                                0s                   0s
put_rpccred               sunrpc.ko      0.001s                                               0s                                  0s                             0s               0s                               0s                                 0s                                0s                   0s

But I have no way to figure out which func maps to which openmp region, or should they match?

Thanks!

Bo

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Bo:

The function names are not getting symbolically resolved.  Does your build process "strip" the binary after the link?  You need to include debug info in both the compile and link steps.

If the symbols are in a separate debug file, use the command line option -search-dir to point to where they are located.

Leave a Comment

Please sign in to add a comment. Not a member? Join today