Bad socperf2_0 Driver Signature

Bad socperf2_0 Driver Signature

I installed Intel Parallel Studio 2017 today. The installer gave me two pop-up windows during the entire install which I ignored. They both said that a signature was invalid for vtss and a sampling component. I forget the exact verbiage. I found something promising reading our Forums amplxe-sepreg -i -v, but I get:

C:\Program Files (x86)\IntelSWTools\VTune Amplifier XE 2017\bin32>amplxe-sepreg -i -v
Stopping service sepdrv4_0...NOT FOUND
Stopping service socperf2_0...Copying file C:\Program Files (x86)\IntelSWTools\VTune Amplifier XE 2017\bin64\sepdrv\win7\socperf2_0.sys to C:\WINDOWS\System32\Drivers\socperf2_0.sys...OK
Installing service socperf2_0...OK
Warning: service socperf2_0 already exists
Starting service socperf2_0...FAILED
Reason: The socperf2_0 driver may not be properly signed; error code: 577
VTSS++ driver found
Deleting system32/drivers/vtss.sys file...OK
Forming source path for vtss.sys...OK
Forming destination path for vtss.sys...OK
Copying file C:\Program Files (x86)\IntelSWTools\VTune Amplifier XE 2017\bin32\.\..\bin64\sepdrv\vtss.sys to C:\WINDOWS\system32\drivers\vtss.sys...OK
Installing and starting VTSS++ driver...FAILED.

I am running WIndows 10.

How can I resolve the signature issue?




Thread Topic: 

Help Me
12 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.


What is your platform and Windows 10 build and variant (Desktop, Mobile, Server) ?

Regards, Katya




Edition: Window 10 Pro

Version: 1607

OS Build:14393.187

Processor: Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz

RAM: 16.0GB

System type: 64-bit operating system, x64-based processor

Pen and touch: Touch support with 10 touch points


It's an HP laptop. I am not sure what you mean by platform. 



I have a similar issue when I was installing the intel parallel studio XE 2016 update 3 today.

There are two pop-up windows during the entire install and I ignored. I cannot remember the exact content in these two pop-ups but they are all about "a digitally signed driver is required".

I tried to fix this problem by reboot my PC and disable driver  signature requirement for once. I then use the installation media to repair " intel parallel studio XE 2016". There is one pop-up window this time, saying that A digitally signed driver is required for "PMU Arbitration Service".

I tried to update my VTune Amplifier XE to update 4 (which is available in the Intel software manager) and this time, two pop-ups windows appear saying that digitally signed driver is required for "sepdrv4_0.sys" and "socperf2_0.sys". This happened during the last step of installation (configuring visual studio...).

My Pc has Windows 10 pro 64 bites system and has visual studio2013 professional installed. I want to use visual fortran and I was wondering if it is OK for me to ignore all these errors. Do I need to uninstall  ​intel parallel studio XE 2016 and reinstall it ? Please help me. 






Can you please check if your laptops/PCs have "Secure Boot" feature set to ON in BIOS?  It's usually enabled by default on laptop and mobile platforms.

On Windows 10 1607 it now prevents loading kernel mode drivers if they were not signed by Miscrosoft Dev Portal:

VTune Amplifier team is now exploring on this enforcement for our software kernel drivers.

Without the loaded sepdrv*.sys and socperf*.sys drivers, VTune Amplifier is still able to perform software based analysis like Basic Hotspots, Concurrency and Locks&Waits.

To perform the Hardware event-based sampling analysis with VTune Amplifier 2016/2017 on the non-upgraded fresh installations of Windows 10, version 1607 - the Secure Boot needs to be set OFF.

Regards, Katya


I will check setting Secure Boot off later today and post back; that is a terrible compromise and not a solution . When will the drivers be properly signed?




We are currently exploring on a solution in future releases of 2017 version of VTune Amplifier.

Regards, Katya

Turning off Secure Boot and running "amplxe-sepreg -i -v" solved the problem. The trade it off is not worth it. I will use the 2016 version until Intel patches the 2017 version,

Thank you.


The VTune Amplifier 2016 initial release drivers can be loaded on Windows 10 version1607 due to MS exception:

  • Drivers signed with an end-entity certificate issued prior to July 29th, 2015 that chains to a supported cross-signed CA will continue to be allowed.

That's a temporary solution for a fresh installation of Windows 10.

Newly signed drivers will be provided in coming Update 1 of VTune Amplifier 2017 later this year. Also once we have patched drivers for the initial version of VTune Amplifier 2017 - we will post them here to unblock you with current installation.

Sorry for the inconveniences and thanks for your patience!

Regards, Katya


For those who are blocked by the driver signing issue on Windows 10 Secure Boot mode enabled system, please be informed that recently released VTune Amplifier XE 2017 Update 1 has the drivers updated and compatible with the mode.

Regards, Katya

Hi, I just installed the latest version of parallel_studio_xe_2017_update4_cluster_edition_online_setup.exe and got same unsigned errors with vtss.sys and Sampling Enabling Product. I'm using Windows 10 pro Version 1703 OS Build 15063.540

Hi Tomy,

Please download standalone VTune Amplifier XE 2017 Update 3 or Update 4 installers for Windows from Intel Registration Center . It has compatible Microsoft Dev signed drivers.

Regards, Katya

Leave a Comment

Please sign in to add a comment. Not a member? Join today