amplxe: Error: Amplifier cannot detect local machine configuration.

amplxe: Error: Amplifier cannot detect local machine configuration.

Hi All,

I'm attempting to profile some Fortran MPI code on a windows 10 home box.  I can run VTune from Visual Studio w/o problems, but as far as I can figure, this always runs MPI code on a single node/processor.  Consequently, I'm trying to run VTune under MPI from a command window.  However, when I execute a command, such as

mpiexec -n 2 amplxe-cl -collect hotspots -result-dir .\AmpResults ..\x64\Release\FrontiersMS-pCMA V1.1-3

I get the immediate error:

amplxe: Error: Amplifier cannot detect local machine configuration.

I'm running the "Intel Compiler 17.0  Update 4 Intel(R) 64 Visual Studio 2017" command shell under administrator, but the information  provided on the error above is not very helpful, so I have yet to figure out why the local machine configuration cannot be detected.  I have another Windows 10 Pro box that I have no problems running the above MPI profiling code on, so there is clearly some issues with the configuration on the other machine. The only difference in OS is one is Windows 10 Home (which fails) and the other is Windows 10 Professional (works OK).

Any suggestions?

9 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Joe,

please send us amplifier logs and failed result. You can gather logs using the command:

amplxe-feedback.exe -create-bug-report=<name_of_archive>

Also did you try to make any collection on some simple application without mpi? (for example: amplxe-cl -c hotspots notepad)




Hi Vlaidmir,

Thanks for replying.  I ran the feedback program and have the archive.  Should I post it here or to (I'm not sure if it contains any sensitive info)?

I have not had a chance to run code w/o MPI yet. I'll try to get to that soon.

Hi Joe,

You can post it here.

OK, here it is then.  Thanks!



Downloadapplication/zip amplxeBug.zip225.22 KB


I didn't see any logs about failed launch. I think this is possible in two cases: temp directory were cleaned after your experiments or you gathered logs for a different user.

AXE collects its logs into %TEMP%\amplxe-log-<user> . Please check what went wrong and resend the logs with failure.

Hi Vladimir,

Perhaps this is related to the problem.  When I look under %temp% I do see a directory "amplxe-tmp-jvallino", but it is from yesterday, even though I just ran amplxe and regenerated the error just now.  Also, when I run the command at the top of this tread (mpiexec....) it first asks me for a username and password, which I have not seen before.  It seems there could be some security access issue that is causing the problem? There are no other users on this machine.


Hi Joe,

In this case please try to make the following 3 things:

1. check that you can run standalone instance of amplifier and collect hotspots analysis with some simple application, for example notepad.exe.

2. check the output of the following command:

<path_to_amplifier>\amplxe-runss --context-value-list

( please send us its output )

3. in case the 1st and the 2nd steps are successful and you are sure that MPI launches jobs only on you host machine, you can try to launch it vice versa:

amplxe-cl -collect hotspots -result-dir .\AmpResults@@@ mpiexec -n 2 ..\x64\Release\FrontiersMS-pCMA V1.1-3



Hi Vladimir,

I had attempted to do an installation repair on PSXE2017, but this opened a pandora's box of problems, related to integration (or lack thereof) of Visual Studio 2017 as described partially by this sticky in the visual fortran forum:  

At this point I do not have a functioning install of PSXE2017 on the window's box that was first causing the problem described in this thread, as I PSXE2017 will not integrate into Visual Studio 2017 community, so nothing is working.  Consequently, getting VTune to work in the console is no longer a problem, as the whole install is now messed up.  Since I have a working Windows and Linux installs on other hardwares, I may just wait for the next update that is supposed to fix the problem (I'll already wasted a whole day trying to fix).

Thanks for your help here though!!


I am using Windows 10 Professionnel (system version 16299.98) and Intel Parallel Studio 18 update 1.

I had the same problem which looks related to an authentification issue.

Adding -localroot to the mpiexec options solved the problem.


Leave a Comment

Please sign in to add a comment. Not a member? Join today