VTune openmp regions/profile not available in attach mode

VTune openmp regions/profile not available in attach mode

Hi,

I have a requirement to run VTune to run in attach mode and i use the command 

"amplxe-cl --collect hotspots  -knob enable-user-tasks=true -knob analyze-openmp=true -source-search-dir
${workload_src}  -search-dir ${workload_bin} -target-pid 8542 "

But with the above command the vtune doesnt show any openmp info in the report. 

However if I run workload through VTune directly as below I do see openmp region.

"amplxe-cl --collect hotspots  -knob enable-user-tasks=true -knob analyze-openmp=true -source-search-dir
${workload_src}  -search-dir ${workload_bin} --  <command> "

Envrionment info:

           VTune: vtune_amplifier_xe_2017.4.0.518798

           OS: Ubuntu Server 16.04.3

Please let me know if there is a solution.

Thanks,

Sri

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Srinivas,

Did you set the INTEL_LIBITTNOTIFY64 variable in the environment of your application? (see the following instruction for details https://software.intel.com/en-us/vtune-amplifier-help-attaching-itt-apis... )

Hello Srinivas,

Could you please share more details on your use case why attach mode is preferable for you?

Thanks & Regards, Dmitry

Thank you VLADIMIR  Vladimir, that worked :).

@Dmitry: The current infrastructure we have already collects profiling data with other tools Perfmon, and others. And they all run in a single instance of workload one after the other for more near realistic data. We wanted to add VTune data collection without spawning a new run.

Thanks,

Srinivas 

Leave a Comment

Please sign in to add a comment. Not a member? Join today