debug module error 3rd party plugin

debug module error 3rd party plugin

When I'm trying to install the debug module to my device to run my project with the cordova-plugin-local-notifications as the 3rd party plugin, I'm getting the following error:

https://github.com/katzer/cordova-plugin-local-notifications

Debug Module Error
The App ID is "com.intel.appx.test8.xwalk15"
The App Name is "AP Debug x15 test8"
Application will be signed.
Plugin "cordova-plugin-statusbar" (2.0.0) installed.
Plugin "cordova-plugin-device" (1.1.0) installed.
Plugin "cordova-plugin-splashscreen" (2.1.0) installed.
Plugin "cordova-plugin-app-event" (1.2.0) installed.
Plugin "com.intel.xdk.ppfa" (1.0) installed.

What must i do?

I'm using XDK 2893

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Some of the plugins are not compatible with custom debug module build system. Our next release should fix most (not all) of these issues. If you can build the app using the Build tab (using CLI 5.1.1), but not the Debug tab, then that is the problem. As an alternative, you can leave out the problem plugin and debug everything but that part of the app with the Debug tab. Or, you can build the app with debuggable true and and debug a built app. See this article for help > https://software.intel.com/en-us/xdk/docs/intel-xdk-debug-and-test-overv...

Leave a Comment

Please sign in to add a comment. Not a member? Join today