I have created an App with Intel XDK and PhoneGap, I have tested this App with Intel App Preview in two mobile and it works perfect on Android 4.2 and Windows Phone 8, but I said to my friends to test the App in her phones and the Intel App Preview not working in a very high number of terminals: 
- Nexus 5 with Android 4.4 the Intel App Preview not shows the login with the user and pass, directly shows the menus but don't do anything without login. 
- Nexus 4 with Android 4.2 the Intel App Preview not shows the login with the user and pass, directly shows the menus but don't do anything without login. 
- Iphone 5 with the last SO the Intel App Preview works bad because shows my App with a black background (imposible to read the texts). 
- Samsung Galaxy Trend with Android 4.0.4 the Intel App Preview works bad because shows my App with a black background (imposible to read the texts). 
- Sony Xperia S with Android 4.1.2 shows a white page when you run the Intel App Preview, but is only shows this and not work. 

And I have a problems with my Windows Phone 8, but is a rare problem, when I use the hidden="true" property in my HTML code, works well in Android because is not visible in the App, but in Windows Phone 8 does not work because it still appears... 

Can you tell me anything for these problems? Thanks.

25 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

In this case it has nothing to do with the compiler or Intel processors, the problem is in your 'Intel App Preview' application.

Has anyone else had these problems?

Best regards.

There have been several issues fixed (not sure if these issues you cite are fixed) by a new release of App Preview (version 1.1.0 for all three platforms). Please check the respective stores and download the new App Preview to see how things work with the new version.

I am having a problem where i am not able to login to the app. i can login from the website but from the app it tells me "unknown user". im frustrated.

When you say you can't login "to the app" are you referring to the XDK or to App Preview? If you're logging into the XDK make sure you're using the correct userid and password. You can confirm your XDK userid and password by trying to log in here:

If you are having trouble logging into App Preview (the debug helper app that runs on your device) you may be having trouble with the SwiftKey keyboard. Some devices come preinstalled with SwiftKey which causes some problems when typing the password into App Preview. To get around this, change the keyboard (goto your Android settings) to a different keyboard and then log into App Preview. Once you've successfully logged in and saved your login, you can switch your Android keyboard back to the SwiftKey keyboard. On some Samsung devices it may not show up as a SwiftKey, but that is the keyboard.

Hi everybody.

I am having a problem when trying to login to App Preview in my Windows Phone since I've changed from Windows Phone 8.0 to Windows Phone 8.1... I've tried everything, and even change my phone (from Lumia 520 to Lumia 530) and it still doesn't works. Anyone can help me?

Did you confirm that you can log into App Center using the same userid and password? Go here using a desktop browser to confirm:

Not sure what to tell you if that doesn't work. We have several Nokia Lumia devices here and we are able to log into App Preview with all of them. The only time I've seen this issue is with some Android devices that have non-standard soft keyboards installed. Have you also confirmed that you have the latest version of App Preview installed?

Hi together,

I also have the same problem:

the "Intel XDK App Preview" does not let me in: it's still 'authenticating' - over an hour now. :-(

Hardware: Nokia Lumia 920
Hardware Revision:
Firmware Revision: 3051.50009.1424.0001
Chip-SOC-Version: 8960

Software: Windows Phone 8.1 Update (Using Windows Developer Preview Updates)
Version: 8.10.14192.280
Intel XDK App Preview Version: (by Intel Corp. released 31/03/2014)

Nothing! No animation while authenticating, no error message.

Since 23/10/2014 there is a second App in the Windows-Store: "Intel App Preview Legacy" in Version (also Intel Corp.)
It has the same size like the other App and the same behaviour: only authenticating, no error message. :-(
I tried each alone, also together no succsess.

Yes, I did successfully log in the Intel App Center. Yes, I'm sure that typing the correct PW in my phone.
Very Intressting: if the password is incorrect, the App responds withing a few seconds. Both Apps...
So the App does some kind of Authentification, obviously- if the password is wrong. *lol*

So, any hints what I should do?


P.S.: Hope I didn't make to many mistakes, but I'm german native.

Thanks for the detailed message. I have made a report to engineering and will provide them with these details.


any news or hints?

I'd like to start develop some apps, but without the possibility to test the xdk is useless for me.


I've pinged engineering again...

Same issue,   trying to login in through the "app preview" app on my android phone.

Response i get is "Invalid user or password"

And yes, I have already confirm by user / password work on



I have further escalated this issue. Sorry for no response, I will let you know of any news when it becomes available.

Engineering has not been able to reproduce this issue, so we're having trouble getting to the bottom of it. One suggestion was to uninstall and then reinstall App Preview from your device.


I'm also having issues with the Intel App Preview on HTC Windows 8.x
I can use the app, login and start an (demo) app but the app itself doesn't work.
For example, the Helloworld Beep app should simple give me a beep but nothing.. (can click the button etc)

Using it on an Iphone4 without any problems..

Is there a workaround or does somebody know where to look further (Cordova issue..?)

With kind regards,


It's possible the notification function being used to "beep" may not work on that device. I have a low-end Windows 8.1 phone and it does not support all the features you will see on your iOS device. The simpler APIs (like notification and vibrate) don't always provide an error, they simply act like the notification happened, but nothing does.

Try this test app, it might help give more feedback:

I also can not login to the App Preview. Clicking login seems to switch to some type of browser. The login form password field does not seem to function properly as a password field, weird things happen when toggling that "show password" box. Even when seeing the plain text password and knowing it is correct on submit usually nothing at all happens. If I am lucky enough to get a response it is cut off text saying "sername/Password does not exist".

Android 4.4.2 with Google Keyboard

Thanks for any insight.

By the way, in the past I had this the App Preview installed on an old Froyo device and was working just fine.

I am also having some serious issues with Intel App Preview on Windows 8.1 (Surface Pro 3), we have an external company developing an application for us, yet I'm unable to login on the device or my PC with the 3rd party accounts to test the application, or even create one of my own.    The 3rd party can login ok, having created a new account to test, I find I still cannot login on either device with new details.

We have seen the application run twice previously on the target device, so we have removed Intel App Preview and reinstalled (incidentally also tried using an external keyboard to avoid any issues although this issue seems to appear with some smartphones).  We still cannot login even to preview, as we cannot preview the app we are wondering if we can go down this route!  I would say it was our firewall or similar but we have logged on previously.      

Can anyone help?     
Kind Regards,




A bug has been filed. In the meantime, a workaround is to have your developer build the app and email a link to a built app that you can then download, install and run on your device, instead of using App Preview. 

There is (unfortunately) a bug in this process, as well, but there is a workaround. Tell your developer to follow these steps precisely and use the email that says "public link" in the email to download and install the app onto your device:

  • developer builds app
  • on final build screen, developer enters email address(es) for your test device(s) into email address field
  • below email address field, developer clears the "use a secure download link" box
  • developer pushes "send" button
  • developer clears the "use a secure download link" box
  • developer pushes "send" button

Note that you will receive two emails (the repetition in the instructions above is not a mistake). The email that says "public link" (not "secure link") in it will download without requiring that you log into an XDK account to get the app. See the image for a view of the build screen field that the developer needs to use to send you an app for install.

Note also that if you are doing this on an iOS app your developer will need to add the UDID of your device to his/her iOS mobile provision file (your developer should know what this is and be able to explain to you how to get it). For Android devices you will need to enable loading apps from non-Market stores (which your developer can also help you with). Finally, on a Windows8 device you will have to run a special script inside the downloaded ZIP that will request a developer license. Again, your developer should be able to help you with this process. Once you do it the first time the second time is much easier. Also, if you receive subsequent versions of installs using this process you may, from time-to-time, need to uninstall the existing version of an app to then install a new version provided by your developer. This is an issue with the devices and there is nothing we can do about it.


Hi I need help… I do not understand why in App Preview do not work
intel.xdk commands, works in Emulator but in App Preview nope…
look I have this code and even do not show the device id but in the
emulator works fine. I spent 2 days trying to create a simple app to scan a barcode
and do not work on App Preview, please help ASAP, by the way I have a question.
1. Where is intelxdk.js because I invoked in index.html but I don’t know where
is, and think that the problem is because intel is not defined.
Thanks in advance
function onDeviceReady() {

//alert('device ready');
//get a unique device_id
device_id = intel.xdk.device.uuid; alert(device_id);

//hide splash screen
if( window.Cordova && navigator.splashscreen ) { // Cordova API detected


document.addEventListener("deviceready", onDeviceReady, false) ;

//after splash page
//load scan page
$.mobile.changePage("#scan", {transition: "flip"});
}, 4000);

//scan page

/* Functions defined by user */

function beep(n){

//Scan QRCode
function scanQR(){
document.addEventListener("intel.xdk.device.barcode.scan", barcodeScanned, false);

function barcodeScanned(evt) {
if (evt.type == "intel.xdk.device.barcode.scan") {
if (evt.success == true) {
var url = evt.codedata;
if(url.indexOf('http') != -1 || url.indexOf('www') != -1){
if(url.indexOf('biipit') != -1){
//get biipit data by alias
aurl = url.split('/'); //alert(aurl[3]);
//add to history
}else{, '_blank', 'location=yes');
intel.xdk.notification.alert('Invalid QR Code');
//var n = noty({text:'Invalid QR Code', type:'error'});

Please help... can not see the same result in App Preview as Emulator, everything works fine in Emulator but nothing works in App Preview, only the design but functionality nothing.

In the emulator, open the console, are there an javascript alerts? What you are describing, sounds like this could be the case.

Did you select the all the plugins you try to use in the Project settings?

Have you tried building your app and installing it on device?

Whats the name of your app?

FYI, John H, there is a bit more information and elaboration in a separate thread Alex started:

Hello Dears,

Also, I have the same problem or similar.
Built the app through the Intel XDK without errors, but when installing the Lumia 435 with Windows Phone 8.1, using the Windows Phone Application Deployment 8.1 (for the generated file is .appx), the message: Error - incorrect parameter.

I tried with other apps provided by Intel XDK as a demonstration and was the same mistake.

On Android, it works perfect and tested on multiple devices, such as Motorola Moto G, Samsung Win Duos, Samsung Duos Gran, Alcatel, positive.

Could help me ??


Downloadimage/png deployer.png803.78 KB
Downloadimage/png no_error.png277.19 KB

@Francisco, this is a march 2014 thread. It also looks like your issue is not related to Windows App Preview. Could you please create a separate thread?

Leave a Comment

Please sign in to add a comment. Not a member? Join today