Intel XDK Release 3491, August 3, 2016

Intel XDK Release 3491, August 3, 2016

Hello Developers,

Today we released Intel XDK version 3491. This very important release merges the Intel XDK IoT Edition and the Intel XDK Early Access into a single release of the Intel XDK. We are moving in the direction of supporting Internet of Things (IoT) app development. Since mobile devices are part of that equation, we continue our support of the development of hybrid Cordova mobile HTML5 apps. For more details regarding this new direction, please read Joe's blog. a

We have made some significant improvements for both IoT and mobile Cordova app development with this release:

  • Replacing the Emulate tab with a new Simulate tab.
  • Added a new Cordova CLI 6.2.0 build option (CLI 5.1.1 has been deprecated).
  • Moved iOS mobile provisioning files, icons and splash screens to a new "package-assets" folder.
  • Stability improvements and many bug fixes.

In future releases we will be adding more functionality for IoT app development. We will also be fine-tuning our Cordova mobile app support to align with the needs of IoT app development. As a result, we are deprecating some mobile app development features that are not heavily used or are inconsistent with IoT app development needs.

Feature deprecations and removals with this release:

  • Profile tab has been removed. Please use the profiling features available in the Chrome Debug Tool (on the Debug tab).
  • Cordova CLI 5.1.1 has been deprecated and will be removed in our next release, likely in September 2016.
  • Legacy Windows 8.x build platforms have been deprecated. They are only available using CLI 5.1.1 and 5.4.1. Only Windows 10 UAP builds are supported with CLI 6.2.0. These older Windows 8.x platform builds will be removed in September 2016.
  • Game Asset Manager, samples and templates have been deprecated and will be removed in a future release.
  • Legacy Whitelist (Android only) was previously deprecated and is no longer available for new projects.

For detailed information about this release, and past releases, please see https://software.intel.com/en-us/xdk/docs/release-notes-information-intel-xdk. Our automatic updater will notify existing Intel XDK users when the update is available within the Intel XDK. Updates will be released to all users within 24 hours. If you would like the update sooner, you can download it directly from xdk.intel.com and install it manually.

Please let us know of any issues you encounter via the Intel XDK forum.

Important note about Intel XDK versions 2893 and older!

Versions of the Intel XDK released prior to March 2016 (2893 and older) can no longer use the Build tab, the Test tab or App Preview and can no longer be used to create custom debug modules for use with the Debug and Profile tabs. This change was necessary to improve the security and performance of our Intel XDK cloud-based build system. If you are currently running version 2893 or older, of the Intel XDK, you must upgrade to the latest version of the Intel XDK!!

------------------------------------------------

Summary of fixes in the 3400 release:

This Intel XDK release is a hot-fix that addresses several bugs and issues:

  • Crashes at startup due to a variety of timeout problems.
  • Long startup times due to slow or spotty network connections.

------------------------------------------------

Summary of fixes in the 3357 release:

  • The built-in Brackets editor now includes a new "tab view" making it easier to switch between all of your active source files.
  • The standard Brackets Extension Manager toolbar is now exposed at the right-hand side of the edit window, where you will find it in a stand-alone install of the Brackets editor.
  • The Brackets Git Extension is now more easily accessed, via the standard Brackets Extension Manager toolbar (see above).
  • To minimize crashes due to the Emulate tab, the CDT debug window will automatically close when switching away from the Emulate tab, if you have enabled the "auto-refresh" feature of the Emulate tab (this is the default condition).

------------------------------------------------

Summary of fixes in 3240 hotfix release:

  • When selecting Apache Cordova* CLI 5.4.1 you were not limited to the minimum target of iOS 8 which resulted in developers attempting to build for unsupported platforms and then building what appear to be non-working apps.
  • If the index.html project file was not contained in the "www" directory of the project, The Emulator would display a '404: Intel XDK can't find your app' error.
  • In some cases, if the Publisher Display Name was not populated for a Windows* build, the plugin add and subsequent build for Windows would fail. Validation for requiring the Publisher Display Name has been added.
  • Corrected an issue where sometimes the plugin manager would not allow a third-party/local plugin to be added to the project.

------------------------------------------------

Summary of new features in 3088/3042:

  • We no longer support CLI 4.1.2 builds. Projects that use CLI 4.1.2 MUST be updated.
  • Added Cordova CLI 5.4.1 to the Intel XDK build system. See this FAQ for details.
  • A new Certificate Management feature allows you to create or import Android certificate keystore files and iOS P12 distribution certificate files.
  • The Build tab allows you to build your app for multiple targets with a single mouse click.
  • Android and Android-Crosswalk options have been combined into a single target platform in the Build Settings section of the Projects tab.
  • Crosswalk support in the Intel XDK is now based on the Crosswalk Webview plugin (AKA "Cordova 4" in Crosswalk docs).
  • A new Publish tab has been added to assist you with creating and publishing application assets and information to a variety of Android stores.
  • The Windows and Windows Phone build options have been expanded and significantly updated to include Windows 10 Universal Apps. Please use the CLI 5.4.1 build option for your Windows and Windows Phone builds.
  • The built-in Brackets editor has been updated to version 1.6 and several new Brackets extensions have been added.
  • Whitelist settings in the Build Settings section of the Projects tab have been updated.
  • App Preview has been updated (to version 2.8.0). Check the respective stores to be sure you have the latest version.
  • Updates to our project file format will require that all projects be "updated" before you can use them with this release.

This release also addresses the Google App Store warning regarding the use of older versions of Cordova-Android. You must migrate your app to our CLI 5.1.1 or CLI 5.4.1 build system to eliminate this warning and to be able to publish apps in the Google App Store after May 9, 2016. Our CLI 5.1.1 build system has been updated to address this issue (see this FAQ for specific details).

89 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

After update from 3088 to 3240 i can't add no one plugin from core or featured list or third-purty plugin in my "old" project or if i create new project.

EDIT: After a reboot, a new project is created successfully and successfully add plugins, but not in old project.

EDIT2: But when i export from construct 2 in "www" folder, i again can't add or delete plugins. I do everything as usual and it's worked in v3088 and before.

How is the structure of your old project? Do you have index.html in www directory or at the project root? Can you send your old project and possibly the new one that you exported from construct2?

The build creation (upload) is always failing on 3240.
It was working fine before I update Intel XDK. Now it's always failing. Please see the logs below:

Node Webkit Error log:
[9320:0422/003548:INFO:CONSOLE(17)] ""xdk:client:[2016-04-22T04:35:48.162Z]: (1461299748162): Failed to load theme: xdk" {"code":"MODULE_NOT_FOUND"}", source: C:\Users\michel\AppData\Local\Intel\XDK\xdk\core-modules\private\logger.js (17)
[9320:0422/003603:INFO:CONSOLE(212)] ""NW proxy string: DIRECT"", source: /brackets.js (212)
[9320:0422/003603:INFO:CONSOLE(17)] ""client:build-tab:[2016-04-22T04:36:03.949Z]: (1461299763949): [refreshPage] Unable to generate project hash." {"message_":"Cannot generate app id without user identifiers","code_":null,"componentName_":null,"stack_":"Error\n    at Object.createXdkAppId (C:\\Users\\michel\\AppData\\Local\\Intel\\XDK\\xdk\\core-modules\\private\\service\\http-wrappers.js:17:543)\n    at Object.exports.generateProjectHash (file:///C:/Users/michel/AppData/Local/Intel/XDK/xdk/components/client/backend-service-utils/backend-service-utils.js:17:1574)\n    at _refreshPage (file:///C:/Users/michel/AppData/Local/Intel/XDK/xdk/components/client/build-tab/build-tab.js:17:6994)\n    at Object.start (file:///C:/Users/michel/AppData/Local/Intel/XDK/xdk/components/client/build-tab/build-tab.js:17:3869)\n    at resumeClientInit (C:\\Users\\michel\\AppData\\Local\\Intel\\XDK\\xdk\\core-modules\\private\\main.js:17:12040)\n    at C:\\Users\\michel\\AppData\\Local\\Intel\\XDK\\xdk\\core-modules\\private\\main.js:17:1734\n    at _fulfilled (C:\\Users\\michel\\AppData\\Local\\Intel\\XDK\\xdk\\node_modules\\q\\q.js:834:54)\n    at self.promiseDispatch.done (C:\\Users\\michel\\AppData\\Local\\Intel\\XDK\\xdk\\node_modules\\q\\q.js:863:30)\n    at Promise.promise.promiseDispatch (C:\\Users\\michel\\AppData\\Local\\Intel\\XDK\\xdk\\node_modules\\q\\q.js:796:13)\n    at C:\\Users\\michel\\AppData\\Local\\Intel\\XDK\\xdk\\node_modules\\q\\q.js:604:44","httpCode_":400}", source: C:\Users\michel\AppData\Local\Intel\XDK\xdk\core-modules\private\logger.js (17)
[9320:0422/003653:INFO:CONSOLE(17)] ""builds:[2016-04-22T04:36:53.550Z]: (1461299813550): Error building UI for: certificateId"", source: C:\Users\michel\AppData\Local\Intel\XDK\xdk\core-modules\private\logger.js (17)
[9320:0422/003733:INFO:CONSOLE(0)] "Refused to set unsafe header "Content-Length"", source: file:///C:/Users/michel/AppData/Local/Intel/XDK/xdk/public/index-node-webkit.html# (0)
[9320:0422/003736:INFO:CONSOLE(0)] "Refused to set unsafe header "Content-Length"", source: file:///C:/Users/michel/AppData/Local/Intel/XDK/xdk/public/index-node-webkit.html# (0)
[9320:0422/003737:ERROR:ipc_channel_reader.cc(65)] IPC message is too big
[9320:0422/003737:INFO:dispatcher_host.cc(157)] [NW.JS]RenderProcessGone
XDK exit code & signal: 258, null
Crash minidump not found in XDK data folder. Falling back to TEMP...

Crash minidump NOT FOUND.

NW Crash Detected.

v3240  install/setup fails   - solved -

 

just started the automatic download of v3240 within XDK. the download proceeded...but fails in installing ...each time i start now XDK..it ask me to install ( or remind me later )..i  press install...i see ultra short the install GUI...but its closing suddenly!...this now happen each time i start XDK....mmmh  this way the update fails on my machin ( win 8, 64 Bit, Intel i 7  endless ram and pwer.. )

if there is a specific LOG  please let me know...i will send u :-)

2. Try - I rebooted my machine....and tried again ( started XDK..that XDK my install it´s new update..)  This time the install GUI came UP and was working FINE...

so for the moment :  SOLVED....a bit bumpy  but solved...

regards

Kristina

 

@Michel, we have identified a problem with large files upload when trying to build. Just wanted to confirm you are facing the same issue. Are your files very large? If that's the case, we are working on the issue and a fix will be available soon.

@SWATI, some of the large files are between 3.0 MB to 6.2 MB. I have nothing larger than 6.2 MB in my project. Am I affected by the issue? Thanks for looking into it, it's very appreciated. Let me know if you need anything else. I can send a copy of my project via FTP for debugging purposes if needed.

Another user is having the exact same problem when trying to upload their rpg maker mv mobile game: https://software.intel.com/en-us/forums/intel-xdk/topic/622152#comment-1869554 Maybe the number of files are too important. My project has 1556 files and around 190MB in total.

Hi SWATI S.

I don't understant why, but when i export my project to another folder and open in xdk - all work fine again)

@Michel, it's the total size of the project and most likely the plugins directory that's causing the upload issue. Please send me your project via PM, although I don't see any workaround at this point and it will take some time to fix this upload issue as it is on the client side. For now, the best I can recommend is to use the older version 2893. 2893 downloads are available here : https://software.intel.com/en-us/forums/intel-xdk/topic/623387

@Konstantin, if you are able to reproduce the plugin issue consistently with your C2 export project, please send me your project via PM.

3240 build failure still persists! Well, that seems to be the case on my machine.

Yoohoo....

Error: Android asset file names may only contain ASCII characters.

Well, mine do just like before. How come build constantly fails on this new 3240 update? 

Ali -- the error message you've posted looks like something to do with the names of folders or files in your project. The newer versions of Cordova CLI have gotten stricter about the names of project components. This is not something we control, it is the Apache Cordova project that made those changes. What happens if you build with CLI 5.1.1 rather than CLI 5.4.1? Do you get the same errors?

Please I've been having this issue since i upgraded my XDK. The build is too large. Normally, the app is around 2-4mb but after building on the new version, the size is about 58mb and after extracting it, there are two apk file each about 26mb. The whole app folder is 5mb. What is happening please?

You are building with Crosswalk, that's why the apk is large. With the new release we have combined Android and iOS build settings. In the build settings, by default, the "optimize with Crosswalk" option is on. If you want to build plain Android, please uncheck the "Optimize with Crosswalk" checkbox under the Build Settings.

Edit:

Ah, no worries. I rebooted Windows and the problem is gone!

 

 

 

Hi

I'm getting an error:

 

Unexpected call to process.exit()

 

Whenever I try to add a plugin. Seems to be since I upgraded to 3400 this morning.

I've tried adding from Core list, Third Party Cordova ID & from git repo and I've tried importing from a local copy I downloaded. I'm getting the same error every time.

I'm trying to get cordova-plugin-network-information but I have tried others

Thanks for any help

Ric

 

Hello,

I’m a new user so please forgive any ignorance on my part.

I’ve installed Xdk v. 3357 on the following systems:

  1. Windows 7 / HP Pavilion core i7
  2. Linux – MX 15 ( Debian base) / HP Pavilion core i7

Both above installed ides were working without errors.

Yesterday (9/6/2016) the ide advised that there was an update to 3400 available. Naturally I accepted the update.   

On both systems the download process took in excess of 2 hours – I have a reasonably fast connection so network access was not the issue. In fact, the Windows xdk update is still running and has been for well over 2 hours now even after all network activity has stopped.

Can you please advise on the following:

  1. Is it normal for users to experience such long update times ?
  2. Where are the update images being downloaded to?
  3. Can I restart an incomplete download?
  4. Where are the update settings actually stored?

Your help with these will be very much appreciated.

Cheers

 

Such a long time to download is not normal, but when many users are updating simultaneously it could impact the time to download. You can always just download the installer directly from http://xdk.intel.com and install it manually. The project files are self-contained and there is really only one file that defines the project list in the XDK, which will not be overwritten or lost if you do the install manually. All the auto-updater does is download the install package and run the installer, so there's no difference when you do it manually.
 

Thankyou Paul. 

I'started to read through the many faqs and am finding some answers :)

Also wanted to thank the crew at Intel for making the Xdk available.  Nice job:)

Cheers

I CANT SUBMIT ON PLAYSTORE IF INTEL XDK GO UPDATE!!

before i build with version 2893 , then NOW i read release notes , that version , CANT BUILD ANYMORE .

and i update intel xdk, i got apk , BUT I CANT SUBMIT , because different certificate , 

WHAT SHOULD I DO ? STOP UPDATING MY APPS ?

 

SCREENSHOT DIFFERENT CERT :

http://prntscr.com/bg4doa

 

@Edo, please see my response on your other thread https://software.intel.com/en-us/forums/intel-xdk/topic/639821. if you had already converted the legacy certificate once and somehow lost it, send us an email to html5tools@intel.com with your account details to get it recovered.

 

Installed 3400 version. It crashes when my built file for Android is downloaded 100% and when I use emulator for Nexus 7 after several run/stop actions on it.

Also the IDE crashes when I switch from one device to another device in the emulator section or when I try to run debug console while the application loads inside the emulator.

This happens on Windows 7 and I have reported most of the bugs, but just to add some info here.

Ah and just to add, I imported my own project and the IDE created its own files inside my project folder. It is a Phaser 2.2.2 game but I haven't used Intel XDK Phaser template. Maybe this has something to do with the crashes, not sure?

Vladimir,

Do you have your source files inside a www directory, and your plugins in a plugin directory outside of www? We designed our directory structure to coincide with Cordova expectations. If you have a different structure, things may not work correctly. Take a look at some of the XDK samples and how they are structured.

Pamela

No, when I imported my project it had only basic web site structure, like intex.html, js folder, css folder etc... not www folder.

Still, the IDE should not crash so much like it did :)

I will make separate folder for XDK project and will copy files there.

Cordova now demands a www folder. Try rearranging and see if that helps.

Working on Windows 7 SP 1

Tried updating to build 3400 from build 3240. Could not start the program - program exited before and generated a crash report. This happen more times than I can count, despite reboots.

Uninstalled and tried to re-install. Install fails on component 2, repeatedly and despite reboots. Tried to re-install build 3240: same thing occurs. 

Message

Intel XDK ended premature because of an error(s).

failed to extract archive

A file error occurred (Unspecified error).

 

i am sorry to say that .day by day your update version of intel xdk getting hazard for the developer..i think. coz every update you add some additional feature and system crash some other feature ...or remove some other feature..now a day i never built any application .because  the core plug in like admob is absent ..although i  add admob from third party plugin but it show me build fail because of the plugin is old...please solve the issue

@Sharif - We do not control admob changes. They have many plugins, you will need to find the one that works best for your needs.

@Felicia - a few users have experienced this installation error (including myself). We are fixing it for the next release. Meanwhile, for 3400, users have reported success after several retries. I was able to install after going to xdk.intel.com to get a fresh installer download.

Pamela

please I have a book currently building on intel xdk but I am unable to scroll down the page one or two line will still remain

How can I fix this error?

CLI 6.2.0 is not currently supported. That is a bad error message. Choose CLI 5.4.1. Version 6.2.0 of the CLI will be supported in a future release, but attempting to use it now will either fail or produce undesirable results. If you've got it specified in your intelxdk.config.additions.xml file, remove it from that file.

Hello Intel,

I have just update the XDK IDE from 3400 to 3491 and I'm a little confused now...

No problems with the installation but after restarting the XDK IDE my active project showed me a message about missing Plug-Ins in the project file. I have tried several options, like use the directory information of using the project information, but all options ended up with an error. At the end I choose the option to remove the project, which is a little bit scary,  and added it again by opening the .xdk project file. That was the tric. Now the project has no plug-in errors any more.... I tried to open my other project and about 50% of all my projects gave a simular error, but could be solved by my previous 'solution'. Don't ask me why, but all projects are working now.

After reading the release notes I discover that the Profiling Tab is removed now! I'm in the middle of testing a crosswalk application with the Phaser Game Engine and have huge memory problems, help help. The profiles is, or better was, a good tool for profiling the crosswalk application. The remark "use the profiling features available in the Chrome Debug Tool" does not apply in this case because, as fas I know, I can't profile a crosswalk application in Chrome. Was is the reason to remove this option and is there any change that this option is coming back, or do I have to install XDK 3400 again to use the profile tab?

Reading the release notes and remarks and have a little bit the feeling that the Intel XDK is moving to IoT and is skipping more and more App related options (like the game assets and samples). As embedded engineer I'm very interesting in IoT and it is a very exiting development but I hope that Intel will keep focus on App developers too....

Happy programming from Holland

After upgrading to 3491 I can no longer use the Simulate (aka old Emulator).

It does "Cordova Prepare" and then gives error:

Pruning at selector "/widget/plugins" from "C:\Users\Mark\AppData\Local\XDK\xdk-scratchdir\00000000-0000-0000-000000000000\platforms\ios\HelloCordova\config.xml" went bad.

No matter what device I choose.

It managed to work the one time, but then simply froze on the first screen of the app.

I cannot even open the debug window, when I click the icon, nothing happens. So I cannot even check if this is due to some code it doesnt like.

Ad -- thanks for the feedback. We are continuing to support mobile apps, but our emphasis will be on mobile "companion" apps for IoT applications. The Game Asset Manager has been deprecated and will be removed, however, there is nothing in that action which prevents you from developing a gaming app, as long as it is a standard Cordova app it will continue to work with the XDK, since the core functionality required is the same.

Regarding the Chrome tools, Crosswalk is closely related to Chrome, and when you use the Debug tab you are running your app in Crosswalk. Notice that you are (and always have been) using standard Chrome DevTools (CDT) when you are using the Debug tab. You can also connect directly to a Crosswalk built Android app with remote CDT by following these instructions > https://software.intel.com/en-us/xdk/docs/intel-xdk-debug-and-test-overv... < so, in that sense, debugging a Crosswalk app is interchangeable with debugging a Chrome browser or a Chrome webview app (on Android).

If you want to continue using 3400, please see this post for access to the install files > https://software.intel.com/en-us/forums/intel-xdk/topic/672415#comment-1... <

Mark -- I sent you a private message. In addition, do you see this problem with the hello cordova sample app? Please try that and report.

Hello,

 

I'd like to report a possible issue with the newly released version of XDK 3491 (I'm using it with the Edison):

The project files are not deleted from the board (/home/root/.node_app_slot/   folder) after exiting the XDK, as I think they were in the previous version. This wouldn't be a problem, except that on the next startup of the Edison after running an app via the XDK this app seems to be automatically executed, even though I haven't added any startup services.

This automatic execution doesn't happen after manually deleting the files in /home/root/.node_app_slot/.

I'm not sure it's an issue with the XDK, but it didn't happen to me with the previous release.

Regards,
Tomasz

I don't think there was ever an automatic deletion of the files in the app slot folder on your IoT device. There is a configuration panel that makes it easy to delete those files, see the screen below.

the emulate isnt refreshing whenever i make new code saves.....this isnt nice aT ALL!!

 

For those of you who are losing your hair trying to work out why the new simulator gives javascript prompts about "gap:init2" and so on without working after that.....

Make sure you don't have "data-noxhrfix" in your index.html - this seems to break the new sim.

Mark -- thank you for that heads up. I've filed a bug regarding the Simulate tab. It appears to be a bug in that open-source tool and can be caused by adding any "data-*" attribute to the <head> tag, it's not unique to that specific data- attribute.

Ever since this new update i cant open any projects. I cant even open template projects - Template projects get stuck on "Finalizing project..." and any build i open from Construct 2 gets stuck on "Opening project"

 

Everything worked perfect in the previous version. I've uninstalled, restarted pc and searched for HOURS to find a download to the last version. Any ideas on whats goin on here?

Thanks, 

Peter

Hi  .. I upgraded from 3400 > 3491

And now when opening the Construct 2 > xdk file this error show
and the project in blank ( No content in the tab )

 

 

 

 

 

Attachments: 

AttachmentSize
Downloadimage/jpeg XDK-v3491-C.jpg20.42 KB

Peter and Flemming -- please see the "known issues" section of the release notes for details > https://software.intel.com/en-us/xdk/docs/release-notes-information-inte... <

real disapointment.

I installed version 3491 - I am running ubuntu on 64bit and cant install ANY plugins whatsoever.

Everything works fine as soon as I add a plug in either I get uknown errors or inconsistent plugins when reloading the project.

I have rebooted, re-installed it is this build - last build did not have this issue.

Please fix this.

 

 

Greg -- are you seeing these errors with an existing project or with a new project? For example, if you create a project based on the "hello cordova" sample, do you get these problems?

I am indeed - brand new project - add plug ins and get failure.

Also when creating a new project takes a really really long time to create base files.

When adding a simple plug in like the camera plug in I get Uknown error as well. this release for ubuntu is really buggy.

 

 

Greg -- which version of Ubuntu are you running?

16.04 LTS

Thanks, I'll alert engineering. May I give them your email address if they want to work with you directly?
 

sure- I also can see that it is only happening on ionic applications. it is not happening on native cordova apps. hope this helps.

Is there any way to have your previous data and settings saved in the new simulator tab? before all the localstorage data from earlier was saved and also the gps position. Now every time i refresh the simulator the localstorage is wiped and gps position is reset. Thanks

Pages

Leave a Comment

Please sign in to add a comment. Not a member? Join today