[RESOLVED] iOS successful build but "missing 64-bit support" error when uploading

76 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Thanks for the feedback, Yonas. We're still trying to figure this one out, so far no good clues.

Paul F

Same issue with new certificates :((((

Well like the others I have the same issue. Until 2016-07-05 I can submit to apple store. In the last week 2016-07-21 the error occurs when using the app loader.

I change to cordova 5.4.1 and the error occurs.

I try the 6.2.0 and the message comes 

  • Error: "6.2.0" is not a supported Cordova version. Please specify Cordova 5.1.1, 5.4.1, or 6.2.0.

We do not yet have our CLI 6.2.0 built system in place.

One thing that might help to understand what is going on -- if anyone can provide a copy of their IPA that was accepted along with a copy of the IPA that failed, we could do some comparisons to see if there is some key difference.

The 2 copies:

Tnx in advance Paul. 

Thank you, Ibanez -- I'll forward to engineering. Anyone else that can provide the same, it would be greatly appreciated.

Ibanez -- I see two key differences that might help in figuring out what is wrong:

  • "before" IPA is built with CLI 5.1.1 and targets iOS 7
  • "after" IPA is built with CLI 5.4.1 and targets iOS 9

Please try these two experiments.

First:

  • change "after" to build with iOS target 8
  • see if that build can be submitted

If above doesn't work:

  • change "after" to build with CLI 5.1.1
  • change "after" to build with iOR target 7
  • see if that build can be submitted

 

I made the 3 tests and the error was the same. 

...we've made no futher tests as all possible we imagine could be valid have already been done... still hope in a solution :)

Yonas,

I can not agree more .... this is causing problem

Maybe Intel roll back and send a past version which worked and restart from there !

 

Quote:

Yonas H. wrote:

Hi Intel

This problem i guess is for everyone. i have the same problem since tuesday, for and app that i managed to upload to app store a few days from that. I had to make some changes, now i can't seem to upload to for review or update. It failed again just now. May be some changes were made on the build server?

Thank You

Yonas

 

Hello!

Same problem here...

It is a very simple project loading with Application Loader with InAppBrowser and Splashscreen plugins only.

Thanks!

Sorry to note we're also stuck: we hope you could work it out as soon as possibile.

Hello

Any update or ETA to solve the issue ?

Intel asked the working file.ipa .... I just have into itunes and do not have iphone smartphone ... is there any option to download the file.ipa ??

thanks in advance
Marcos
www.conteudoanimal.com.br

We have found a similar problem with PhoneGap Build users, that started at the same time.

Those users are experiencing exactly the same problem. It appears, based on that thread, that the problem is likely being caused by the presence of Xcode 6 on your Mac from which you are performing the submission. We believe that the Application Loader app may be utilizing some checking mechanism in Xcode before the actual submission to the store.

Please try doing the following:

  • update your version of Xcode to version 7
  • reboot your Mac
  • try submitting your app using the Application Loader app

If that does not work, download and install Application Loader 3.1, which is extremely difficult to find, but is located here:

Please report back if this worked and, if it did work, which solution was the right solution for you.

p.s. Application Loader 3.1 requires "an Intel-based Macintosh with at least 512 MB RAM and Mac OS X version 10.9 or later installed."

Hi Paul

I don't have Xcode in my computer. But I will see if loader 3.1 will work, though I have only 10.8 (mountain lion).

Yonas

When reading the PhoneGap Build threads you may see references to Application Loader 3.5. That version of Application Loader cannot be downloaded separately (as far as we can tell). However, if you have Xcode 7.3.1 installed on your system (perhaps some older versions, as well), you can get to it from within the Xcode menu. See the screenshots below:

 

 

Hi Paul

The solution you provided didn't help. I had to download OS X 10.11.0  first, before i get Application Loader 3.1, which i didn't want to do. When i start looking for a solution somewhere else i found this 

https://www.scirra.com/forum/i-have-warning-quot-missing-64bit-support-q...

It seems this is not the first time this problem occurred. 

Thank You

Yonas

 

Yonas -- the thread you're pointing to on the Scirra forum is a different problem, that was resolved earlier in the year. The problem you are now having is being caused by the Apple Xcode and Application Loader software, it is not a problem with the XDK build system or the XDK itself. It appears that Xcode and Application Loader are now tightly linked and you MUST have Xcode 7 on your machine to get the Application Loader to work.

Please do the following:

  • insure you have OS X 10.9 or higher installed on your Mac
  • install the Xcode 7 development tools from the Apple store
  • reboot your Mac (after the installation of Xcode 7)
  • use the Application Loader that is built into Xcode 7 (see image below)

This appears to be the result of new restrictions placed on the store submission process by Apple. There is nothing the XDK can do to change these new requirements, they are dictated by Apple.

It works! I tested in a OS X 10.09 with a application loader 3.1. Thanks a lot Paul.

Ibanez -- thanks for the confirmation!!!

Installed XCode 7 and the problem was solved!

Thanks!

Hello,

Problem resolved to me ...

I had to install Oracle VM and a El capitan version .... against old mountain lion version i used before

And downloaded the application loader 3.1 ... and during the upload of .ipa file ... it asked to install XCode application

All set for now .... waiting for next issue cause by apple

Thanks for all help from Intel team specially Paul

Marcos
www.conteudoanimal.com.br

Having opened the thread I'd like to thank Intel's staff for the support and tell that we've SOLVED the problem reading all answers (also of other users): there is basically a kind of "bug" in the tools of the o.s. so that updating/upgrading everything has led to a working situation.

Thank, it really solved my problem

Pages

Leave a Comment

Please sign in to add a comment. Not a member? Join today