Internal error after updating to the new version

Internal error after updating to the new version

I was working with my project and everything was fine, and all of the sudden I was asked to update to the new version of XDK, so I did. Now when I open my project it says Internal Error (see the attached screenshot), on the build tab.

I have tried and restarted my computer and restart XDK but still the same. I have Windows 10. 

 

 

AttachmentSize
Downloadimage/jpeg error.jpg95.84 KB
39 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Are you able to create a blank project or a sample project (for example, the "hello, cordova" sample) and open the build tabs with those projects?

Yes that works in the sample project. 

I tried and removing my project completely, and removed all of the project files and exported again from Construct, and when I open the project in XDK i get another error, see attached error2.jpg.

Then I pressed close and I could open the build tab, but when I opened another tab the whole program froze and I had to turn it off via task manager. When I opened it again I got this third error, see attached error3.jpg, which I have never had before when working on this project! Everything has been working fine before with the plugins and all. Super strange!

 

 

 

Attachments: 

AttachmentSize
Downloadimage/jpeg error2.jpg54.87 KB
Downloadimage/jpeg error3.jpg353.56 KB

Anna,

Thank you for attaching the images - super helpful.

The Cordova plugins directory does not match the XDK plugin file. You've got to pick one or the other, then if you need the other plugins, add them through the Plugin Manager (just above Build Settings).

Pamela

Well ok, that has never come up before but..  I chose one and when I got in to the project, the first error (internal error etc..) came up again in the build tab. 

Is there some way to go back to the previous version of XDK? I really need to be able to work on my project. 

 

Anna -- You may have some plugins specified in your intelxdk.config.additions.xml file which is causing this problem. It is important that you add the plugins using the plugin manager, that Pamela referenced.

When you export from Construct2, are you using the "open a project" option with the XDK to open that exported project in the XDK? There is a "project-name.xdk" file in the export from C2 that you need to "open" (do not use "import"). This works the FIRST time you export and import. After that, depending on how you work with C2, you should either copy the exported source files into your existing XDK project, or, if you do ALL your editing and work in C2, it might be easier to delete the old project and then "open" the newly exported project (by opening the "project-name.xdk" file in the exported project).

But it worked just fine before the update! I always delete all of the files and export again when I make changes in construct. And i open the project in XDK just like you are describing.

<edit - I responded before I saw Paul's response. So ordering may not make sense.>

Hmm . . . well, if the build issue is coming up because of plugin mismatch, reverting may not help.

Try removing all the plugins and adding them back through the Plugin Manager. If that fails, we can get you the previous version. But really we need to find the root cause. I don't know of anyone else having this problem. So if XDK is the issue we want to work with you to find the cause, if your app is the issue, you will need to eventually find the cause. We only support 2 versions and we upgrade every 6-8 weeks, so you can't stick to one XDK version indefinitely.

Also, unless you saved a copy of your project before opening it in the new XDK version, it will may not work when you revert back. (Though you can get it from Construct 2 again.)

Anna -- I also sent you a private message asking for a copy of your exported project, so we can try it to see if we can reproduce what you are seeing. It might also help to ZIP your entire project AFTER you open it with the XDK, so we can see that, as well.

Goodnight. I am having a problem with any version of Intel XDK had had. Export my project Construct 2 as cordova and when added to Version 3491 Intel XDK, I get this error that keeps me going. (Unsupported Project Folder Structure.) I had never happened to me. What's going on ?

I'm feeling stupid now but how do I find the plugin manager if I cant use the build tab? I usually go through the build settings from there, and to the plugin manager, but since I can't see anything but the error message on the build tab, how do I get to the plugin manager? 

 

Javier -- please see this FAQ > https://software.intel.com/en-us/xdk/faqs/general#www-folder < for some help converting your project so that it does contain a www folder (which is what it's looking for with that error message).

Anna -- plugin manager is on the Projects tab. See this doc page > https://software.intel.com/en-us/xdk/docs/add-manage-project-plugins <

ty Paul. But. I'm not very good at developing and I can not come to understand the steps, it should be easier d elo seems. But not understanding. It would be so kind as to send a catch how to do? Thank you so much

Anna -- thank you for providing that C2 project. There is definitely something wacko with the new release that is not properly importing the project, like it did so well with the 3400 release. I'll will alert engineering regarding the issue. In the meantime, I've attached the download binaries for 3400 so you can go back to that.

Attachments: 

AttachmentSize
bytes
bytes
bytes
bytes

Thank you so much!

Ok next problem..  I can't uninstall XDK. I go to control panel and remove/add programs and choose uninstall XDK, I go through the uninstaller and in the end it says "Intel XDK is now installed. For any support you may need, please visit us at httpblababka".
And everything is still there like before! 

Yes I saw that, but since the first line was "From the Windows Control Panel, remove the Intel XDK, using the Windows uninstall tool.
Then:"
And I cant uninstall it with the uninstall tool, I thought that wouldnt work I can still open the program and everything after I do the uninstaller

Follow the steps after the bit about using the Windows uninstaller, it will get rid of everything.

Where do I write in those things? 

  • Then:
    > cd %LocalAppData%\Intel\XDK
    > del *.* /s/q

  • Then:
    > cd %LocalAppData%\XDK
    > copy global-settings.xdk %UserProfile%
    > del *.* /s/q
    > copy %UserProfile%\global-settings.xdk

​Is it in cmd? If I try and write that in cdm it says that it can't find the path or something like that. You have to be more specific please, I'm getting kind of desperate here! 

 

Ok I found a website explaining how to delete files manually in regedit and all that to remove it. It's insane though, you guys should have an uninstall tool that removes your files I think. 

Ok so I am having a very similar issue - updated to the latest version of XDK and things worked fine. After powering XDK up last night I was asked to select between the plugin data from the directory or the project file - I selected directory. Now when I open up my project the initial information screen is completely blank and if I go to the build tab I get: 

Internal error

An unexpected internal error has occurred.

If this problem reoccurs, please let us know at our support forum.

Suggestion: Close and reopen this project or the Intel XDK and try again. 

So I have tried closing the project, closing XDK, restarting the pc, deleting the plugins directory, re-exporting from Construct, and uninstalling + reinstalling XDK. None of which resolves the problem. 

I'm getting a bit desperate now, any suggestions? 

 

Andres -- please see the "known issues" section of the release notes > https://software.intel.com/en-us/xdk/docs/release-notes-information-inte... <

I was having the same issue as Anna - "TypeError: Cannot read property 'slice' of undefined" when importing Construct2 projects after updating XDK to version 3491.

I had to uninstall version 3491 and revert to version 3400, however now emulator doesn't work.
I'm getting "404: Intel XDK can't find your app" error for all my projects, even for old ones that were working fine before. My projects definitely contain www/index.html file.

Could anyone help?

Stan -- is this a problem with an existing XDK project that was exported from Construct2 before 3491? Or is this a newly exported Construct2 project that you imported with 3491? We've been having issues importing C2 projects with the 3491 release. If you could provide a copy of your problem project it might help us to understand the source of the problem. I'll send you a private message with details.

Stan -- I did not see any issues loading the project into the XDK, but I could not get the test app you supplied to run in the Simulate tab, or in the Debug tab. There were console messages in the debug window regarding timeouts (see image below). However, I'm not clear if that is the problem you are describing. (Read past image for more.)

If the image above IS the problem you are describing, then the solution is to add a plugin to the project. I recommend adding the Cordova Device plugin (see additional images below for an example of how to do that), which will resolve the issue that I ran into. If this is not the issue you were encountering, than please provide more information regarding the problem.

 

Hi Paul,

Thanks for looking into this issue.
No, I have a different error (see the screenshot below), however I believe it also may be related to the missing Cordova plugin.

When I import/open a project in XDK, there are no error messages, but when I try to run it in the Emulator I'm getting error 404.

I tried following your screenshots, but was unable to add Cordova plugin to my project. It shows "Fetching plugin" for a few seconds and then nothing happens - there is no message that the plugin was added successfully and it doesn't appear under the "Plugin management" tab.

I tried different versions of Cordova device plugin and other plugins, but none of them got added.

XDK.LOG contains this:

client:cordova:[2016-08-15T12:14:15.543Z]: (1471263255543): Cordova plugin change request:  { ADD: 
   [ { origin: 'cordova-plugin-device',
       variables: {},
       version: '1.1.1',
       id: 'cordova-plugin-device' } ] }
client:cordova:[2016-08-15T12:14:15.598Z]: (1471263255598): Cordova plugin add  [ 'cordova-plugin-device@1.1.1' ]
client:cordova:[2016-08-15T12:14:16.112Z]: (1471263256112): All Cordova plugin changes done successfully, now updating plugin references..

I also tried re-installing Construct2 and Intel XDK, created a new small test C2 project but no luck.

When I create a sample project in XDK itself - it works fine in the emulator, so the issue only happens with Construct2 projects.

Sorry, I thought you were using 3491. Is your "Source Directory" (on the Projects tab) set to "www"? The project you sent me was configured that way, if you don't have a www folder you need to reconfigure your project so your sources are contained within it, and make sure the "source directory" is set appropriately. See this FAQ for help > https://software.intel.com/en-us/xdk/faqs/general#www-folder <

Yes, the Source Directory is set to "www" and all my projects have "www" folder with index.html
Everything was working fine before on version 3357 until I installed/uninstalled version 3491.
Version 3491 must have changed something on my computer and now emulator doesn't work on older versions 3357 and 3400.

I think I'll have to install Intel XDK on some other machine.

 

As I have error with the latest version, I downgrade to 3400 version. But still got error as below when start to build the apps.
This error is exactly the same as later version.
Does anyone have solution for this issue?

Muhammad

 

ERROR (-9) from "client:upload-manager": Error in uploading project files: : Error in uploading project files: : Error in uploading project files: : certificate not trusted Error at new ComponentError (/Applications/Intel XDK.app/Contents/Resources/app.nw/core-modules/public/component-error.js:17:1122) at makeError (file:///Applications/Intel%20XDK.app/Contents/Resources/app.nw/components/client/upload-manager/upload-manager.js:17:170) at getComponentError (file:///Applications/Intel%20XDK.app/Contents/Resources/app.nw/components/client/upload-manager/upload-manager.js:17:265) at file:///Applications/Intel%20XDK.app/Contents/Resources/app.nw/components/client/upload-manager/upload-manager.js:17:11448 at _rejected (/Applications/Intel XDK.app/Contents/Resources/app.nw/node_modules/q/q.js:844:24) at /Applications/Intel XDK.app/Contents/Resources/app.nw/node_modules/q/q.js:870:30 at Promise.when (/Applications/Intel XDK.app/Contents/Resources/app.nw/node_modules/q/q.js:1122:31) at Promise.promise.promiseDispatch (/Applications/Intel XDK.app/Contents/Resources/app.nw/node_modules/q/q.js:788:41) at /Applications/Intel XDK.app/Contents/Resources/app.nw/node_modules/q/q.js:604:44 at runSingle (/Applications/Intel XDK.app/Contents/Resources/app.nw/node_modules/q/q.js:137:13)

Hi Paul.. how you doing.. here is my issue.. my project was working well good then i updated  intel XDk.. and when i try to import my project again for a test in the app preview.. i have inappbrowser plugin in intelxdk.config.additions.xml.. i added it via plugin management with the github link and comment the line on intelxdk.config.additions.xml and the console log kee telling me inappbrowser already define with all the console log above.. and i have to present this project next week.. so please help me with it.. tell me how can i solve it because i didnt call this plugin anywhere in the html file.. if you nedd screenshots of the project, please let me know.

Seraphin -- there is nothing wrong with your app when you see that "already defined" error message in the Simulate tab, it is a known issue with the Simulate tab. I thought it was fixed in the 3522 release, but I see it was not. You can safely ignore those error messages, they do not impact your app and they will not be present in a built app. See the Simulate tab limitations page for more info about the Simulate tab -- getting an app running in the Simulate tab does not mean it will run on a real device, so I highly recommend you build and install on a real device before you consider your testing complete.

 

when i try to launch it on app preview i get this message:

index.html

your built app behaviour may differ compared to what is displayed in intel app preview.

App preview uses a different CLI version than the following CLI verson in your project:

What does that really mean ?

And one more thing, everytime i finished configuring the debug tag and cretae the api extension file as it said it... the intel xdk app preview is deleted on my ipad and the debug tab sends this error : The intel xdk cannot detect a properly signed version of app preview on your testing device... really i'm lost.. please help

Quote:

Seraphin J. wrote:

when i try to launch it on app preview i get this message:

index.html

your built app behaviour may differ compared to what is displayed in intel app preview.

App preview uses a different CLI version than the following CLI verson in your project:

What does that really mean ?

It means exactly what it says -- the way your app behaves in App Preview may be different than the way it behaves when you build the app and install it on your device. In other words, App Preview is not a substitute for testing a fully built app on a device. App Preview is providing you with some information regarding some of the differences between your project build settings and how App Preview was built. Those differences may affect the behavior of your app when it runs in App Preview, compared to how it behaves when you build your app.

Quote:

Seraphin J. wrote:

And one more thing, everytime i finished configuring the debug tag and cretae the api extension file as it said it... the intel xdk app preview is deleted on my ipad and the debug tab sends this error : The intel xdk cannot detect a properly signed version of app preview on your testing device... really i'm lost.. please help

You need to provide a "dev" certificate to sign App Preview for use with the Debug tab, an adhoc or production cert will not work. However, you'll find that the Debug tab and iOS devices do not work that well at this time, and you are limited to the plugins that are built into App Preview. Unlike using an Android device, the Debug tab does not build a "custom debug module" that contains your project's plugin list, it simply re-signs App Preview so you can attach to it for JavaScript debugging.

As an alternative to using the Debug tab with a re-signed copy of App Preview, I recommend that you build your app with a developer certificate (you can add a dev cert to your account in the account settings section of the XDK, see the image below). Once you have an app that was built with a dev cert, you can install it on your iOS device and use GapDebug to debug it with Web Inspector remote, on a Windows or Mac machine. It works quite well for debugging a built iOS app from a Windows machine.

Another alternative is to use weinre to debug. You will only have a JavaScript console to work with, not a full JavaScript debugger, but it is a very useful tool and is very easy to setup. See these links for help:

Hi All,

Previous version allowed for debug the camera plugin using the a connected phone. But newer version has removed the debug tab and I am unable to accomplish debug through a data cable connected mobile phone

1. Any one has a clue on how to debug an app using a mobile phone or tablet connected to the PC using data cable? 

2 How to get a unique image name for captured image and save the image to  Photo Album (navigator.camera.getPicture) then retrieve the images using it's name on later time?

Thank you,
Sasanka
sasankaherath@gmail.com
+6584900166

 

Leave a Comment

Please sign in to add a comment. Not a member? Join today