After upgraded to a new version

After upgraded to a new version

 

After upgraded to a new version, my theme and plugin on intel XDK are gone.

I need to re install all my theme and plugin. Is it the right upgraded ?

 

11 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Are you talking about the Editor's (Brackets's) theme and plugins (as opposed to the project plugins)? Sometimes we update the version of the Brackets included with the XDK. I'm not sure if losing the theme and Brackets plugins is expected to happen when upgrading the XDK. If it's not too much of an inconvenience, please re-install them, otherwise I can try to find out if there is an easier way to get them back (there might not be though).

Also, what's your development system OS?

Hi Shahab,

Thanks for your answer. It is not about convenience or inconvenience, but my question was if that is as expected that
the new update will remove all themes and plugins or not.

When I tried to install the themes and plugins, I got the error as attachment files. 
So, I am not able to bring my themes and plugins back.
Any solution for this issue?

I am using Mac Book Pro, Sierra.
Intel XDK 3900

 

 

 

Attachments: 

The version of Brackets was updated, as was the underlying Node-Webkit, which resulted in directories moving around. This is probably why your themes and plugins disappeared. If you want to use a more customized version of Brackets, I recommend you install standard Brackets and edit your project files directly from within standalone Brackets. The XDK will still see the file changes and will work with an external editor. I use Sublime to edit my XDK project files directly, rather than using the built-in editor. Doing it that way insures that your customizations stay with you, regardless of changes to the XDK.

 

Hi Paul,

Thanks for your answer. I am still getting error when I tried to update or install the theme and plugins.
Any solution for this error? I put error attachment on my previous posting.

Can you tell us which extension you tried (that fails) and what operating system you have so we can investigate?

 

Hi Shahab,

Thanks you for your reply. All the plugin and theme are getting error.
I put additional attachment file, as example plugin which get error.
I use Mac book pro, Sierra.

Muhammad

Attachments: 

I was able to reproduce the problem. We'll have to ask one of our engineers to investigate and fix this. Thank you for letting us know.

Muhammad -- are you behind a proxy server? I know there is an unresolved problem with the current Brackets release that does not properly update extensions when it is run behind a proxy server, I've experienced this myself. The only way I can get extensions to update in the current version of Brackets is to use a non-proxied network (for example, a typical home network or using your phone as a hot-spot). Please let me know if that is the situation. You can test this by installing standard Brackets to see if you have the same issue with standard Brackets from your system.

Best Reply

Muhammad -- there is a manual workaround, if you are unable to get to a non-proxied network. You can manually install/update the extensions using the following steps:

  • exit the Intel XDK
  • open a terminal or command window
  • locate the XDK's "editor/extensions/user" folder (see below for details on where that is)
  • download a ZIP of the extension of interest from it's github repo (see below for details)
  • unzip that extension into the "editor/extensions/user" folder (identified below)
  • restart the XDK and those extensions will be installed/updated into the XDK Brackets editor

On a Mac:

  • cd ~/Library/Application Support/XDK/Default/editor/extensions/user
  • mv unzipped/extension/folder/ .

On a PC:

  • cd "%LocalAppData%\XDK\User Data\Default\editor\extensions\user"
  • move unzipped/extension/folder .

Select the "more info..." link for the extension of interest. In most cases this will take you directly to the GitHub repo for that extension. Then, click the "clone or download" and the "download ZIP" buttons on the github page for that extension (see image below). You must unzip that downloaded ZIP file before moving it to the "editer/extensions/user" folder (see above).

 

Hi Paul,

Yes, I am behind the proxy. I disabled a proxy setting, but still in the same issue.
I will try to install manually.

Thanks,

 

Leave a Comment

Please sign in to add a comment. Not a member? Join today