Trying to boot Galileo dev kit for this time - no serial comms

Trying to boot Galileo dev kit for this time - no serial comms

I'm trying to boot the Galileo dev kit for the first time with the serial-to-USB cable (supplied), but I'm unable to get any login prompt (nothing is displayed on the HyperTerminal, tried Putty (serial) too. baud rate set to 115200, no parity, etc.

Both "green" LEDs light and I see network leds flash.

Do I have a defective board, or is there a problem with the serial connection?


16 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Mike,

Have you selected the correct COM port. If you are using Windows, you can check the port in device manager, under Ports(COM&LPT). It would appear something like Prolific USB-to-Serial Comm Port (COMXX). In addition to speed 115200, no parity please confirm 8 bit and 1 stop. If all goes well, you will see a blank window, on clicking Enter key, login prompt will appear.


You likely have a serial cable with Pin2 & 3 flipped. I'd recommend getting a multimeter & soldering iron and flipping them around, or if you have jumpers & a USB->serial just flip them around on that connection with 3 jumpers (you only need ground (pin5) & 2+3 connected).

I have a few null-modem adapters left over from the MWC hackathon that swap pins 2 & 3 on the 9-pin D connector, I can send you one.  To check if you have this problem you can take three wires from the Sunfounder kit, and insert them between the USB converter and the Serial Cable, swapping pins 2 and 3, and connecting pin-5 to pin-5.  If you don't use Pin 5, (the ground), you will likely get a lot of garbage on the console instead of the expected EFI and Linux Boot messages.


I faced the same issue on Linux. Turning the Hardware Flow Control OFF worked for me.


Hi guys I have set up the dev kit, I had issues with finding the comms port I installed the driver by locating the drivers on the sd card and this shows fine now in device manager, ( as Intel IoT Dev Kit Serial )  but, there is nothing but a blank screen in Putty, clicking enter also does not work it just continues to be blank. I know the device WAS ok because I have been using it with the standard extended linux image for some time but pulling my hair out no connection what so ever and am worried the kit has broken the board. Does anyone have any advice please.

Adam, to test the h/w, you can remove the SD card, and power up the board using just the onboard SPI flash. Note that when you use the iotDevkit SD card you will actually have two USB ports show up, one is for arduino,via the USB cable (and uses Zmodem protocol), and the other is the hardware serial port, used with the USB to Serial cable.

The ultimate test/fix for this USB/serial issue is to restart the PC.  The Arduino IDE uses a Java USB driver and powering off the Galileo without closing the IDE first can cause similar issues that you are seeing, ie the USB driver hangs and locks the USB port.  You can test for this issue by removing the USB cable for the Galileo, and instead plug a USB Stick into the same port.  If this storage device is not recognized, then the port is indeed locked.


Hi thanks for the fast repply, I have tested with standard SPI and that is working ok, I don't have two USB ports showing only on the Intel IoT Dev Kit Serial I have also only one USB going from the USB client to my PC is there something I have missed. Again thanks for the quick response I am hoping toget this running straight away as I have a product waiting on it.

While I have the SD out I am just doing a firmware update I will then reboot and test the port with a pen stick. has a step by step guide for setting up the console,  check the pictures to make sure cables are connected right way round, Green is GRN, and Black is GND.

Hi I have tried all of the above an no difference. My steps were:

1. Take out the SD and reboot.

2. Uploaded the blink from the IDE which worked.

3. Updated firmware.

4.Put SD back in and  started the board up.

5. Opened putty and still nothing just blank screen even after hitting enter.

I still also only see the Intel IoT Dev Kit Serial on port 7 nothing more. Hope this can give you the clues to the issue,

Ok thank you again for your help will check the docs out now.

My board is Gen 1 I dont have those types of wires I followed the guide on the website to set up, USB wire from client to computer and ethernet to the router.

Well that's the issue... You are missing the serial cable.  So you won't be seeing anything on the Putty screen.   There are two variants of the USB connection, each with separate cables.  The standard USB cable used for the Arduino IDE, and a separate USB to Serial cable is needed for the serial console.  It plugs in to the board via the 3.5mm 3 pin "headphone" jack next to the Ethernet connector.

Strictly speaking you don't need that serial cable, as you have the Ethernet connection.  ie if you can determine the IP address of the board, eg from your router, or by running a system command in an Arduino sketch then you can SSH into the console, using Putty.

The following command will output the IP address on the Arduino IDE serial monitor.  (note that's strictly the USB monitor). Add a 2 second delay and loop forever.

  system("ifconfig > /dev/ttyGS0");




Ahha I think I have found it, ok this is something I wasn't aware of as not come across it before using the normal Linux image. There is a one additional wire that is required for the serial I am installing it all now hopefully this is the issue. Thank you for taking the time to help, I will message back once sorted.

Thank you yes just found that no, I have been using the extended Linux image for some while and successfully connect the board to my web api doing several tasks but up till now had used a serial cable running from the jack, it is also not very well documented about that part I assumed it would be the same as the previous set up. Thanks again for helping out I appreciate it.

Leave a Comment

Please sign in to add a comment. Not a member? Join today