Unable to upload arduino sketch witk iotdevkit image

Unable to upload arduino sketch witk iotdevkit image

Hi All,

I am facing issue while uploading the sketch in iotdevkit image.

It is working fine with "LINUX_IMAGE_FOR_SD_Intel_Galileo_v0.7.5 " but not with iotdevkit image.

Here is the logs:

Deleting existing sketch on target
C:\arduino-1.5.3/hardware/arduino/x86/tools/izmir/clupload_win.sh: line 28: /dev/ttyS9: No such file or directory

# Execute the target download command

#Download the file.
$fixed_path/lsz.exe --escape --binary --overwrite $host_file_name <> $tty_port_id 1>&0
C:\arduino-1.5.3/hardware/arduino/x86/tools/izmir/clupload_win.sh: line 34: /dev/ttyS9: No such file or directory

#mv the downloaded file to /sketch/sketch.elf 
echo "Moving downloaded file to /sketch/sketch.elf on target"
#$fixed_path/lsz.exe --escape -c "cp sketch /sketch/sketch.elf" <> $tty_port_id 1>&0
$fixed_path/lsz.exe --escape -c "mv $target_download_name /sketch/sketch.elf; chmod +x /sketch/sketch.elf" <> $tty_port_id 1>&0
Moving downloaded file to /sketch/sketch.elf on target
C:\arduino-1.5.3/hardware/arduino/x86/tools/izmir/clupload_win.sh: line 40: /dev/ttyS9: No such file or directory


I have tried multiple things  to resolve this issue but did't get expected result.

can any one please help me into this case!!

Thanks in advance!



4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Have you tried moving to a different USB port. I believe I've had this problem before and moving to a different USB port fixed it.

Best Reply

The IOT devkit Image version 1 does not support the Arduino Sketch capability, as it uses eglibc for the Linux libraries, while the Arduino tools build for uclibc.  So as you found out, you need to swap back to the Arduino SD card image if you want to use the Arduino IDE. We plan to fix that in our next public release of the Devkit image.


Hi Mike/Stewart,

Thanks Stewart for this information!

Mike ,I tried changing usb port couple of time but did't get success.

some time it is trying to connect and showing tume-out error.

All things are working fine with bigger  linux image and  I am facing this with only iotdevkit image.

were you able to upload sketch using iotdevkit image ?





Leave a Comment

Please sign in to add a comment. Not a member? Join today