Barcode and empty string in zero

Barcode and empty string in zero

I have a problem with the Intel.Healthcare lib using .NET ( 2.0 or 3.5 ) (C#) v2.0.1

Take the "BtnBarcodeDemoNet" project example coming with the SDK installation. After I used the shift+F1 shortcut, every label/textbox inside the forms shows '0' when string.empty was setting.

It's occurs in this example but also in my programs on my PC and on a tablet where MCA SDK is installed.

I tried using v1.11 but I got the same problem.

Thank's for your help

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi il.boni,

I am not sure I fully understand what you are doing. It sounds like you are using an MCA tabet and a development PC. If that is the case, the MCA SDK should only be installed on the development PC and not the MCA tablet. Also, the software demos included in the MCA SDK must be the exact same version as the MCA platofrm driver on the MCA tablet. For example, if the MCA tablet has MCA platform driver v1.11, the software demos must be from MCA SDK v1.11.

Please provide more details about your configuration and versions of MCA software used.


On my development pc I have installed 2.0.1 MCA SDK and Visual Studio 2008 and I tried compiling forframework 2.0 and 3.5 . I wrote about my Tablet just to say that my problem occurs not only on my development pc, using the same version off course.

Anyway if I use my app, or"BtnBarcodeDemoNet" example project, without the barcode reader emulation ( shift+F1 ) no zeros are displayed, but just after the first read all the empty label/textbox are setted with "0".

I didn't change any configuration in MCA, just like fresh installed.


Hi il.boni

We have found that the code fails to link in Visual Studio 2008 with the shipped .lib files due to difference in run-time libraries. We did some research on this previously and could not find switches or options to compile/link this with Visual Studio 2008. Our recommendation is to use the same compiler for linking with which the .lib are generated which in this case is Visual Studio 2005+SP1.


Thank you for your answer Steven.

I have something to add. I take another Tablet bought with the 1.0.0 version installed and I have no problem on this one ( compiling using the lib v.1.0.0). If I make a downgrade of another tablet bought with the v 1.11 to the v1.0 I got the problem, using the same program.

I can't understand what is going on.

I can't compile using vb2005 because my app is made for the 3.5 framework version.

I hope you will solve this issue quickly or it's going to be complicated for users like me.

Best regards

It seems the problem occurred when the SP1 of the .net Framework3.5 is installed.

Best regards

Thanks for the follow up.


Leave a Comment

Please sign in to add a comment. Not a member? Join today