Camera & RFiD & Barcode reader problem

Camera & RFiD & Barcode reader problem

Hello Everyone,

I have a Motion C5 and I am running Windows XP. the camera, READ, and Barcode reader all don't work and I re-installed MCA a few time, already. Right nowI have version installed. It was an update I found on Motion's website.

In Motion Dashboard, under Pen and Tablet, the camera, RFID reader and barcode scanner are enabled. They are also enabled in the BIOS.

This is the error that I get when I press the camera, RFID or Barcodebutton:

"The procedure entry point ?Motion_Get DriverGenVer@@YAKPAK@Z could not be located in the dynamic link library MCBttnEC.dll"

The error that I get in MCA.log is the following:

E [2009-02-26 11:54:12.108] {S0-P3036-T3244} [Type1_Connector] Error authenticating plugin - unable to load plugin [PIDeviceControlMtnC5.dll].
E [2009-02-26 11:54:12.139] {S0-P3036-T3244} [PCF] AuthenticatePlugin failed for device=Device Control
I [2009-02-26 11:54:12.139] {S0-P3036-T3244} [PCF] Leaving GetDeviceControlPlugin device=Device Control
D [2009-02-26 11:54:12.186] {S0-P3036-T3244} [Device] In SetError(Failed to initialize the device control plugin.).
E [2009-02-26 11:54:12.186] {S0-P3036-T3244} [HDF] Initialize() failed on device Camera Device.
D [2009-02-26 11:54:12.186] {S0-P3036-T3244} [HDF] HardwareDeviceFactory::DisposeDeviceByHandle(handle=0x00000485,pluginType=UNKNOWN) ENTERED
D [2009-02-26 11:54:12.201] {S0-P3036-T3244} [HDF] HardwareDeviceMonitor::RemoveMonitoredHandle(slot=0,handle=0x00000485) ENTERED
D [2009-02-26 11:54:12.201] {S0-P3036-T3244} [HDF] HardwareDeviceMonitor::RemoveMonitoredHandle() RETURNING
D [2009-02-26 11:54:12.201] {S0-P3036-T3244} [CameraDevice] Camera::DestroyDevice(isExiting={false}) ENTERED
D [2009-02-26 11:54:12.217] {S0-P3036-T3244} [CameraDevice] DestroyDevice: This device was already destroyed or was not created successfully.
D [2009-02-26 11:54:12.217] {S0-P3036-T3244} [CameraDevice] Camera::DestroyDevice() SUCCEEDED: HC_Success
D [2009-02-26 11:54:12.233] {S0-P3036-T3244} [HDF] HardwareDeviceFactory::DisposeDeviceByHandle() SUCCEEDED: HC_Success
D [2009-02-26 11:54:12.233] {S0-P3036-T3244} [CameraDefaultHandler.dll] error=-230 during Reserve
D [2009-02-26 11:54:12.233] {S0-P3036-T2172} [CameraDefaultHandler.dll] Error during Camera API calls. Camera initialization not active
D [2009-02-26 11:54:12.233] {S0-P3036-T3244} [CameraAPI] ::CA_GetLastError(camHandle={INVALID},sizeWChar=1024) ENTERED
D [2009-02-26 11:54:12.248] {S0-P3036-T3244} [HDF] HardwareDeviceFactory::ReserveDevice(handle={INVALID},resTimeoutMS=0,idleTimeout=0) ENTERED
W [2009-02-26 11:54:12.264] {S0-P3036-T3244} [HDF] HardwareDeviceFactory::ReserveDevice() FAILED: HC_InvalidHandle
W [2009-02-26 11:54:12.264] {S0-P3036-T3244} [CameraAPI] ::CA_GetLastError(sizeWChar=1024) FAILED: HC_InvalidHandle
D [2009-02-26 11:54:12.279] {S0-P3036-T3244} [CameraDefaultHandler.dll] releasing camera err=-300 *ppData=0
D [2009-02-26 11:54:12.279] {S0-P3036-T3244} [CameraDefaultHandler.dll] ppData=159fe44 ppData2=0
D [2009-02-26 11:54:12.279] {S0-P3036-T3244} [CameraDefaultHandler.dll] *ppData=0
D [2009-02-26 11:54:12.279] {S0-P3036-T3244} [CameraAPI] ::CA_Release(camHandle={INVALID}) ENTERED
D [2009-02-26 11:54:12.279] {S0-P3036-T3244} [HDF] HardwareDeviceFactory::DisposeDeviceByHandle(handle={INVALID},pluginType=CAMERA) ENTERED
W [2009-02-26 11:54:12.295] {S0-P3036-T3244} [HDF] HardwareDeviceFactory::DisposeDeviceByHandle() FAILED: HC_InvalidHandle
W [2009-02-26 11:54:12.295] {S0-P3036-T3244} [CameraAPI] ::CA_Release() FAILED: HC_InvalidHandle
D [2009-02-26 11:54:12.295] {S0-P3036-T3244} [CameraDefaultHandler.dll] CaptureData=-300
E [2009-02-26 11:54:12.311] {S0-P3036-T3244} [TTA] Error from DefaultHandler HandleButton:;DATA#-2
D [2009-02-26 11:54:12.311] {S0-P3036-T3244} [TTA] DLL being used: UnInitialize not called
D [2009-02-26 11:54:12.311] {S0-P3036-T3244} [TTA] Unloading library: ;DATA#C:\Program Files\Intel\MCA\Bin\CameraDefaultHandler.dll
E [2009-02-26 11:54:12.311] {S0-P3036-T3244} [TTA] Error from mBtnHandMgr.HandleButton: ;DATA#-44
D [2009-02-26 11:54:12.326] {S0-P3036-T3244} [TTA] Runable::RunThreadProc - back from DoRun, return value was: ;DATA#-44

I would be greatful if anyone has any ideas on how to fix this. Thank you.

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

The motion C5 is running Windows XP - Tablet PC Edition 2005 Version 2002, Service Pack 3

Hi mbieltz,

It looks like you have the wrong MCA software installed with all the failure messages, or something else catastrophic has failed. When you say you reinstalled the MCA software, can you be more specific if you have installed the MCA SDK or the MCA platform driver from Motion?

My advice would be to do the following:

1. Remove all the MCA software installed on the system. You can do this via control panel, add/remove applications
2. Once all the MCA software has been removed, reboot the Motion C5.
3. Using the C5, go to the Motion web site at the URL below:

4. Scroll down the list of software until you get to the section titled Medical Clinical Assistant Software
5. Download the file called C5_MCA_v2.0. This is the Motion C5 MCA Platform Driver v2.0
6. Once the file is downloaded, go ahead and run it. This will reinstall the correct MCA software for your system.
7. After the installation is complete, reboot the system and it should be fine.


Hi Steve,

Thank you for your reply. That's exactly what I did. Motion provides 3 different versions of the file and I tried all 3 of them.

One thing that I didn't do is to reboot after I un-installed MCA from Ad/Remove Programs. I will give that a shot and see what happens. I will re-post the log messages if it fails again.

Thank you.


I tried what you suggested but same error. This is what I have in the log:

E [2009-02-27 07:52:15.593] {S0-P4052-T3380} [Type1_Connector] Error authenticating plugin - unable to load plugin [PIDeviceControlMtnC5.dll].
E [2009-02-27 07:52:15.655] {S0-P4052-T3380} [PCF] AuthenticatePlugin failed for device=Device Control
E [2009-02-27 07:52:15.671] {S0-P4052-T3380} [HDF] Initialize() failed on device Camera Device.
E [2009-02-27 07:52:15.702] {S0-P4052-T3380} [TTA] Error from DefaultHandler HandleButton:;DATA#-2
E [2009-02-27 07:52:15.718] {S0-P4052-T3380} [TTA] Error from mBtnHandMgr.HandleButton: ;DATA#-44

Hi mbieltz,

We eliminated the issue as an MCA software issue with the reinstallation. So we are confident the problem is not with the MCA software. However, I asked our developers to take a look at the messages to see if they had feedback.

Our developersbelieve PIDeviceControlMtnC5.dll is dependent on the MCBttnEC.dll, and this DLL is either corrupted or an older version. Since the dependant DLL MCBttnEC.dll is not loaded properly, it causes the failure of PIDeviceControlMtnC5.dll as well. So, replacing the MCBttnEC.dll with proper version should resolve the problem. However, this may just lead to the next piece in a chain with a number of broken links.

These DLLs are all provided by Motion Computing as part of their C5 system image. These are not files that Intel can provide. If you have another C5 that is working, you could try to copy the DLL files from the working system to the failed system. If not, then you will need to contact Motion Computing to get them. If this is just a test system, it may be just reinstalling the C5 OS image will save you the effort of trying to fix multiple problems if simply replacing the DLLs does not work.


Hi Steve,

Thank you for your help. I will ask Motion to send me the dll's that are missing or corrupt. We did install our own image on the C5 and probably don't have the correct dll files. I will provide an update once I get the new files.

Thank you

Leave a Comment

Please sign in to add a comment. Not a member? Join today