Problem with example (SDK 2.0)

Problem with example (SDK 2.0)


I have a problem with the example BarcodeDemoNet when I press the button populate supported Types. I have an exception :barcode reader device named "was not found (unalbe to get last error)

The problem is here :

foreach (BarcodeType type in bcReader.SupportedTypes)


Sorry for my horrible english!!! :)

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi seb1000

A couple of questions for you:

1. Which tablet are you using?

2. Did you install the MCA SDK onto you tablet, or did you manually copy the sample project to your tablet?




I 'm using a Motion Computing C5.

I installed the SDK onto my PC (not onto the tablet). Then I tried to use the sample on my PC and on the tablet. There is the same error: barcode reader device named "was not found (unalbe to get last error)

I use the sample in the folder CSharp andi copy manually the sample to my tablet.

But when I installed the MCA SDK 1.11.0c, I can use the sample on my PC, there is no error....

Hi, seb1000

What you are describing usually is caused by using different versions of the SDK and together. Like having the Platform Driver on your C5 being 2.0 and your SDK being 1.1 or a different version of a sample application then the PD.

Please try using that same version for all software that you are using, SDK, PD and sample apps.

If you are unsure of what version of applications you have on your C5 please follow these instructions to uninstall and reinstall the correct version.

You can do this via Control Panel, AddRemove programs. Once you have uninstalled both the MCA SDK and MCA PD, reboot the C5.

You will have to download theMCA Platform Driver from the Motion Computing web site at the URL below. Theycall it "Medical Clinical Assistant Software " on their web site, but it is what we refer to as the MCA Platform Driver.

Once you have the MCA PD installed, you can then copy the demo applications over from the SDK onto the C5 if you want to experiment. But don't install the MCA SDK on the C5, just copy the files you want to move over.

Please make sure that all of the software is of the same version.


John C

Hi seb1000

Just to make sure you understand, you cannot run and demo application from MCA SDK 2.0 on and Motion C5 running v 1.x of the MCA platform driver. If you have developed you application for MCA SDK 2.0, then please make sure you install v2.0 of the MCA platform driver on your Motion C5. I do not beleive Motion Computing has released the v2.0 of the MCA platform driver on their web site yet, but you may be able to pre-release version if you contact them directly.



Hi, and thanks for your help

I'm going to do a summary.

*I already use the Intel MCA 1.11.2

*With the sdk 2.0:

When I use the sample (CameraDemoNet, RfidDemoNET, BarcodeDemoNet) i have the same error on the motion C5 and on the PC: RFID Reader (or Camera or barcode reader) device named " was not found (unable to get last error). To use the sample on the motion C5, I have to copy IntelHealthcareSDK.dll on the Motion C5 else I have an windows error (programm crash).

When I install the skd 2.0, i have an error: unable to find the file c:/program files/intel/mca/bin/xml/imcaSystem-Fr.xml. ButI think that it is not important.

*With the skd 1.11.0c

I canuseall the sample on my PC but on the the motion C5I can't. It's very strange!. Ican use RfidDemoNET, CameraDemoNet on the Motion C5. This sample work well. But I have the same error with BarcodeDemoNet: Barcode reader device named " was not found (unable to get last error). But I don't need to copy IntelHealthcareSDK.dll on the Motion C5, the sample don't crash without this dll.


Hi seb1000,

It sounds like you have might havemiss-matched versions of the files.

Please do the following

1. On the development machine go toControl Panel Add or Remove Programs, uuninstall the MCA SDK software, andreboot

2. Download and install on the development machine the MCA SDK version 1.11 from here:*+XP+Professional&lang=eng&strOSs=44&submit=Go%21

3. On the C5 go toControl Panel Add or Remove Programs, uninstall the MCA Platform Driver, and reboot

4. Download and reinstall the MCA Platform Driver. This is available from the Motion Computing web site. They call it the "Medical Clinical Assistant Software". I would recommend installing v1.11.2.

Copy over the appropriate files from the Development machine to the C5.

This should resolve your issues


John C

Leave a Comment

Please sign in to add a comment. Not a member? Join today