Application failed to initialize

Application failed to initialize

I've got an application developed with the MCA SDK that runs fine on the development machine,. (I have used the camera API to capture images.) When I move my application to a Motion C5 tablet, and try to launch it, I get an error: "The application failed to initialize properly (0xC0000005). Click on OK to terminate the application."

I did not copy any of the SDK files over to the C5; I did supply all other dependent DLLs.

After much trial-and-error, I copied the IntelHealthcareSDK.DLL to my application's directory, just for fun. (I copied ONLY that DLL.) The application then started OK, but of course it didn't run as it should.

This indicates to me that there's something drastically different in one of the unnamed functions (ordinal 1-10) exported by the DLL.

Any ideas?


6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi gsosebee,

Can you send us the MCA event log showing the failure? Here are the steps:

1. In the MCA configuration file (C:Program FilesIntelMCABinIntelHealthcare.cfg), set the logging level to debug:

/Intel/HealthcareSDK/Logging/DefaultLevel = DEBUG

2. Delete the existing log file (c: empMCA.log) so we only capture relevant information of the failure.

3. Reload the MCA service by selecting the "Update Configuration" option from the MCA tool tray icon (right-click on it).

4. Perform the steps necessary to duplicate the issue.

5. Save the MCA.log file and send or postitforus to look at.



Hi gsosebee,

One other thing to consider is the version of the MCA SDK you used for development versus the version of the MCA Platform Driver installed on the Motion C5 you have.

The current release version of the MCA Platform Driver that Motion includes with the C5 is version 1.0. If you have developed your application using MCA SDK v1.11, then you may have some problems trying to run it on the Motion C5 if it still has the MCA Platform Driver v1.0.

When you develop a program using the MCA SDK, you want to make sure the MCA Platform Driver on the Motion C5 is the same version or a later versions. For example, an application developed with MCA SDK v1.0 will work fine on the Motion C5 using the MCA Platform Driver V1.0 or v1.11. But the reverse is not true - an application developed using MCA SDK v1.11 may not run correctly with the MCA Platform Driver v1.0.

If you did develop your application using MCA SDK v1.11, then contact Motion Computingand they may be willing to give you a pre-release version of the MCA Platform Driver v1.11. Motion is validating that version of the MCA Platform Driver now and it should be available soon.

However, if none of this applies to your scenario, please do send me the MCA log file showing the failure and we will investigate.


Hi, Steve.

Sorry to be so long in responding -- my initial tests were on a borrowed Motion C5 and I didn't get it back until now.

I'm using version 1.0 of the SDK, so there should be no problem there.

I initially suspected the dependency that IntelHealthcareSDK.DLL had on WFAPI.DLL might have been causing the problem, since one of our DLLs has this same name. (I suspect the WFAPI.DLL that your DLL is looking for is the one by Citrix.) I went through some pain to rename our DLL and relink everything, but the problem still happens.

I tried turning on debugging as you first suggested, but nothing additional appears in the log file when I start my program other than the startup info after reloading the configuration. In other words, starting my application causes nothing to appear in the log.

The error indicates to me that the program that the program isn't even getting started, which I confirmed by putting in some MessageBox display lines in the CWinApp::InitInstance method: they weren't displayed.

Is there any problem using MFC with the SDK?

---- Followup after some time has passed ----

I decided to try the sample program that came with the SDK and it worked OK, so I wrote a new program that is a very bare-bones version of my program. It works. So there must be something in my application that isn't right. I'll keep adding stuff until the problem occurs and let you know what I find.

Finally, a resolution.

My application had a bunch of libraries linked with it, and I had tacked on IntelHealthcareSDK.lib at the tail end of the "additional dependencies." The problem was obviously related to the SDK DLL loading, so (after much pulling of hair and gnashing of teeth) I moved the SDK lib to the front of the list of dependencies. Problem solved!

Apparently the name of some entry point referenced by the SDK DLL is duplicated in one of the many other libraries. If I ever figure out which one, I'll post that info here.

Thanks gsosebee for the update! I am glad you were able to work through it. I hope you have some hair left after all of that work.


Leave a Comment

Please sign in to add a comment. Not a member? Join today