Deployment of the SDK on Windows Mobile 5.0

Deployment of the SDK on Windows Mobile 5.0

I am just starting to look at the SDK, so applogies if this is covered else where under the 'RTFM' section.

I have built a small test app to see how the SDK works, just looking at the mobile device battery, and I can build a version that works under Windows Mobile 2003 ( Symbol MC50 ), which works OK.

When I build a version for Windows Mobile 5 ( Symbol MC70 ) I get an Error raised when I run the app on the device - Can't find PInvoke.dll IntelMobileWrapper_CE12.dll

I have followed all the instructions I can find, placing the SDK dll's in the app directoryand some in the Windows directory, but I must be missing something somewhere - either in the files I am using as references in the build or the versions I am copying onto the device.

I have downloaded the which is the SDK 1.2

The samples do not run on the device either so what ever I am not doing/have not done is pretty fundamental !

My apps and all C#/.Net 2 and I have the v2 of the framework installed on the device. I want to use the SDK so that I can have some common access to the underlying hadware in another application that will be build for both platforms ( so that I do not have to use Windows Mobile 5 specific references -Microsoft.WindowsMobile.etc - as this is not supported under WM 2003)

Pointers or advice appreciated !

Forgot to add - Projects all on MS VS2005

5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

As an update, I have just rebuilt the samples from the MPSDK zip from scratch, deployed them to my device, copied the IntelMobileWrapper_CE12.dll to the sample exe's directory, then to the Windows directory, and each time I run any of the samples they throw a MissingMethodException

Hi Andy, thanx for your question. We are trying to reproduce the senarior that you descripted and will keep you updated.


Hi Andy, Are you having problem with the sample code that provides or your own applications? If it is the latter, could you send us your code for investigation?


Hi Andrew, we have tested your code on our device and it works pretty well. We can retrieve the battery information successfully by your app. The development environment are almost the same but the device. We don't have Symbol MC70, so we tested on our own WM 5.0 PDA device.

Since you can run your app smoothly on 2003 platform, we don't think there is any problem with the version of CLR and the locations they are being deployed to. As far as we can tell, your process is correct.

Now we think the problem you encountered was caused by DEVICE CERTIFICATION, Did you get your device signed with certification? If not, it might be the main reason of the problem. For debugging, you can try to use c++ infobrowser, Java infobrowser & sample applications and see if it works. if it doesn't, there is very high opportunity that the problem was caused by certification signature. If they all work well, let's dig deeper to find out the reason.


Leave a Comment

Please sign in to add a comment. Not a member? Join today