Connectivity issue with Mobile SDK 1.1

Connectivity issue with Mobile SDK 1.1

I've got the Mobile SDK 1.1 installed on Windows XP Tablet Edition and can't get the Connectivity instance to work with C# 2005. I had an application that worked fine under 1.0 but under 1.1 it locks up when trying to access any property of the ConnectivityInstance object. If I Break All in the debugger, it just shows it waiting on native code for the property retrieval (IsConnected, etc.).

Just for a sanity check, I opened the MS.NET sample application included with the SDK and the same thing happens. Everything compiles fine, no errors at runtime, it just freezes when trying to retrieving any value from the object. I can subscribe to the Connected event and it even fires, but I just can't access property values. The IsAvailable method (to determine if if API methods are available) returns false.

I'm tearing my hair out here! Anything I can do to fix this?

-Arian Kulp

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Visual Studio 2005 is not supported for the Intel Mobile Platform SDK v1.1 release. Can you see if your system has the same problem with Visual Studio 2003?

Lester Memmott

I can look into it, but I don't even have 2003 installed. This exact application ran without issues in VS 2005 with the Mobile SDK 1.0. There were only slight changes to a few class/method names. Is there a specific incompatibility with VS 2005? This would be a big blow if it simply can't be made to work, considering ConnectivityInstance 1.0 worked fine.


There are no known incompatibilities when using the C# interface in conjunction with VS2005. It has not, however, been tested extensively which is why we don't claim compatibility. At this point, VS2005 support is targeted for our next point release.

I asked our testing team to try to reproduce the issue you describe.They tried butwere not able to reproduce it. I also tried it on my own system running VS2005 and the IMPSDK v1.1 and the following sample apps ran fine:

It appears that your system may be misconfigured somehow. Does the "MS.Net Info Viewer", provided with the SDK, run correctly on your system? Neither of these sample projects listed above use the IsAvaiable() method. Can you send sample code demonstrating your use of it?

Leave a Comment

Please sign in to add a comment. Not a member? Join today