Problem with SDK 2012 32bit windows install - missing IntelOpenCL32.dll

Problem with SDK 2012 32bit windows install - missing IntelOpenCL32.dll

I installed OpenCL SDK 2012 (2.0) in my win7 box (64bit) (previously I had 1.5) in 32 bit mode in order to link with pyopencl. It seems thatIntelOpenCL32.dll is missing and onlyIntelOpenCL64.dll is found and registered in registry - and I can't get Intel platform to work(only nvida). Worked fine before with SDK 1.5, not sure how to get the missing file, perhpas install went wrong? Also tried runtime only package install with same results. Any ideas what is happening?Thanks

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Honestly, I have never tried installing 32-bit package on a 64-bit machine. Can you uninstall the SDK and try re-installing?


Well, it seems that you right, installing 32 bit sdk on 64 bit machine is not working, I installed 64 bit sdk and then build pyopencl for 32 python - all seems working fine now ...


It seems that installing 32-bit SDK on 64-bit machine SHOULD work. We tried to reproduce the issue and were not successful. Maybe your previous uninstall didnt remove all components?

If you still need 32-bit SDK on 64-bit machine, please uninstall the previous version(s) and re-install.


Leave a Comment

Please sign in to add a comment. Not a member? Join today