Unable to install OpenCL SDK Linux

Unable to install OpenCL SDK Linux

Upon running , "sudo rpm -i intel_ocl_sdk_2012_x64.rpm", I get the error "file /usr/lib64/libOpenCL.so from install of intel-ocl-sdk-2.0-31360.x86_64 conflicts with file from package nvidia-computeG02-295.40-15.1.x86_64".

I have Nvidia's drivers installed for using Nvidia's OpenCL capability. I have previously had Intel OpenCL SDK 1.5 installed and it worked fine but I uninstalled before attempting this upgrade. Any ideas on how to resolve this?

OpenSuSE 12.1 64bit

uname -a: 3.1.10-1.9-desktop #1 SMP PREEMPT Thu Apr 5 18:48:38 UTC 2012 (4a97ec8) x86_64 x86_64 x86_64 GNU/Linux



3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Best Reply

Hello Ken,

libOpenCL.so (OpenCL ICD) is a common library (part of the OpenCL standard) that being distributed by any OpenCL vendor, including Intel and NVIDIA.

Since the library is already installed on the system, the RMP fails to overwrite the file and shows this error message.

In order to solve the problem, our recommendation is to un-install NVIDIAs OpenCL driver and re-install Intel package.

If you would like to use both NVIDIA and Intel SDKs on the same target machine, try to use the --force or --replacefiles flags when installing the RPM package this allows you to install the package even if it replaces another package's files.



Thanks, the --force flag solved the issue.

Leave a Comment

Please sign in to add a comment. Not a member? Join today