Crash in OpenCL beta Installer

Crash in OpenCL beta Installer

I am having problems installing the 2013 beta version of the OpenCL SDK, on Windows 7 with VS 2012. I have a sandy bridge core 17 processor. When I tried to install the SDK, it reported a crash, then backed out changes, but OpenCL no longer works. I have tried to reinstall the 2012 version, but it says there is a more advanced version installed, and I must uninstall that version. However, neither version shows up in the Control Panel uninstall programs list. When I try running the 2013 installer again, it says "The installer identified that the installed version of the CPU only runtime package is broken. Try removing it, or contact the product support at" this forum.  I uninstalled the CPU only runtime, but it still gives me that message.

Is there a manual procedure for uninstalling the SDK?

16 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I found an older post in this forum suggesting removing a couple of registry keys. I found one of those keys, and deleted it. I was then able to install SDK 2012. However, when I try to compile using Visual Studio 2012, I get this error;

1>LINK : fatal error LNK1104: cannot open file 'C:\Program Files (x86)\Intel\OpenCL SDK\3.0\bin\x64\clbltfny8.rtl'

That is because OpenCL SDK\3.0 does not exist. Somehow, VS has gotten pointed at the beta version. Any suggestions?

Hi Jerome! I run into the same problem here. Have you found any solution yet? Would you mind show me where are the registry key that you deleted? Thanks!

Hi Jerome,

VS2012 is not supported yet. The support will be in later versions of SDK. For now you'd have to use VS2010 or VS2008.


The keys you want to delete are any references to Intel* under HKLM\Software\Khronos\OpenCL\Vendors and HKLM\Software\Wow6432Node\Khronos\OpenCL\Vendors (assuming you have 64-bit OS).



I uninstalled VS 2012, and installed VS 2010 Express, but the SDK installer still failed;

Intel SDK for OpenCL* Applications Beta Setup Wizard ended prematurely because of an error. Your system has not been modified. To install this program at a later time, run Setup Wizard again.

My processor is a core i7 2600K, which is HD 3000, sandy bridge. Could that be the problem? If not, are there any install logs or other files which might help to diagnose the problem?

I re-installed the 2012 version of the SDK. However, when I try to build an OpenCL app, I get a linker error;

4>C:\Program Files (x86)\Intel\OpenCL SDK\3.0\bin\x64\clbltfny8.rtl : fatal error LNK1136: invalid or corrupt file

I haven't tried the Express edition but most likely the installer failed because of it. You should be able to install the SDK on Sandbridge. Keep in mind that on SNB OpenCL on GPU is not supported.


I have now installed the full VS 2010, but the 2013 SDK still does not install. I received the following error;

There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.

Did you make sure you have uninstalled the SDK and made sure the registry keys are removed?


I will try again now.
The only Intel item in my uninstall program list is Intel HD Driver. everything else is uninstalled.
I have deleted both Khronos Vendor entries from the registry.
I have downloaded a fresh copy of the SDK 2013 beta setup. I will now run it.
It worked! At least, it said it worked.
But I am still getting this message from the linker;

2>C:\Program Files (x86)\Intel\OpenCL SDK\3.0\bin\x64\clbltfny8.rtl : fatal error LNK1136: invalid or corrupt file

the file is present, is 3,138 KB in size, and was created 3/22/2012.

Hmm! Something's not right. I have clbltfnh8.rtl but not clbltfny8.rtl. Are you installing the 64-bit or 32-bit version?


But maybe VS is trying to read the wrong file.

Do you have an OpenCL project in your VS? What is the opencl library in Additional Dependencies under Linker Inputs in the project Linker Properties?

I have opencl.lib;%(AdditionalDependencies). And %(AdditionalDependencies) has kernel32.lib;user32.lib etc...but not the one you are having problem with.

I have a number of libraries like that, which are listed simply as file names. But I also have
C:\Program Files (x86)\Intel\OpenCL SDK\3.0\bin\x64\clbltfny8.rtl.
If I remove that line, I no longer get the error message about a bad file. Instead, I get this;

2>coreLib.lib(OclContext.obj) : error LNK2001: unresolved external symbol clSetKernelArg

and a lot more like it. Can you tell which of your libraries is supplying the OpenCL functions?


I realized that my problem was that the linker should have been pointed at ...3.0\lib\x64\OpenCL.lib. That is where the static linking versions of the cl functions are located (I discovered this using Dumpbin).

This has solved my problem. Thank you very much for your help.


Yeah. You need to link to OpenCL.lib for any OpenCL application. I am glad you are able to move forward.


My open CL SDK  Installation is showing the same error, but the problem with me is that I am a nube and don't know anything about Software developement. So I am not able to completely follow the discussion. Can anyone please help me with my SDK installation issues... I am working on Win 7 with Core I3 processor, I have Visual Express 2012 Express installed on my PC. along with the Code Blocks IDE...

Leave a Comment

Please sign in to add a comment. Not a member? Join today