OpenCL app stalls when another GPU app closes/monitor switched off

OpenCL app stalls when another GPU app closes/monitor switched off

I got report that my app stalls (GPU usage drops to zero and app restart required to continue calculations) if user closes some another GPU-using app like FireFox or VLC. Also, he sees stalls when monitor switched OFF.

Here is his original report on this issue:

Does anyone see same behavior on Intel's GPUs ?

10 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Looks like that site is down for maintenance. Can you provide your system configuration? Do you know if the system may be throttling into a power savings mode?


I'm the one who left the report on the other site and here is some more info on my system and the situation.

I've got a i7 3770K where I've raised the CPU multiplier to over clock to 4.2 GHz and set the CPU core voltage to 1.11V, otherwise the system runs at auto settings. I've also got a Nvidia GTX 660Ti in this computer and is using the Lucid Virtu MVP software, the monitor is connected to the onboard HD Graphics 4000. Intel graphics driver version is and I've not installed the SDK just the graphics driver.

When I close Firefox or start VLC so a video starts to play or close it before stopping video playback Raistmers OpenCL app stalls and will not continue running unless it's closed and restarted. Same thing also goes for turning the monitor of.

I've turned of all energy saving features concerning graphics that I know of: Screensaver set to none, turn of screen after set to never and sleep or hibernate also set to never. I do however suspect some energy saving on the HD Graphics as my monitor is a 40 inch TV running at 1920x1080 resolution and when I turn it on it seems to adjust the resolution from something far smaller (800x600?) up to the right resolution.

I run Raistmers app under the Boinc platform and are at the same time running one other project (with different apps) on the CPU and on the Nvidia card and there is no problem with that project and the computer is not going into sleep mode or trying to hibernate.

We've had another post last week where the person was having issues with his opencl app (on Intel HD Graphics) and he had an Nvidia card in his system too. After unplugging the Nvidia card he said everything worked fine. Can you try removing the Nvidia card and repeat the steps to see if the app hangs.

I know this is not the solution but that will give us some data to chase this issue on our end.



Hi Raghu

I'll try to remove the Nvidia card when I can get some more work from Seti@home, the app is written to help in their search for ET. The project will be down over the weekend for some power repairs. Hopefully I can get a chance to test your suggestion before that but it might have to wait until next week. 

Hi again and sorry that it has taken a while to get back to you.

I've now had the chance to test Raistmer's app one more time without having the Nvidia GTX 660Ti in my computer, it's on the table next to me. The computer is connected to a TV via HDMI. Sad to say once I turn my TV of the app stalls, if I check the process in Task Manager it doesn't consume any CPU time and when I check the GPU load with GPU-Z the load is howering about 0-3%. When the task is operating normally the CPU load is 100% of one core and GPU load is  mostly >95%.

I'm willing to test this further so a solution can be found, just ask me what to try.

Does this happen only with the OpenCL app? Can you try a non-ocl app that uses the gpu and see if that hangs too? If so you may have to post here.


I haven't had any problems using the computer for daily work, surfing the web, watching videos or playing games using the Intel GPU. I've also tried some video conversions with a program called MediaCoder that uses Intel Quick Sync and that has work fine although it's been awhile now. Have updated the graphics driver since i last tried to convert a video or played a game. Playing games using Lucid Virtu MVP has mostly worked as it should although some games don't seem to like it. Dragon Age 2 worked as it should.

System specs:

  • Intel i7 3770K @ 4.2 GHz (I've set the CPU ratio to x42 and CPU Core Voltage to 1.11V)
  • Motherboard is MSI Z77A-GD65 (MSI-7751)
  • RAM is 16 GB DDR3 (2x8GB) Corsair CMZ8GX3M1A1600C10 @ 800 MHz
  • Graphics card is a Gigabyte GeForce GTX660Ti, factory overclocked.
  • System HDD is a Samsung 830-series SSD 128 GB.

During the latest test I just removed the Nvida card from the computer leaving the driver installed, should I have uninstalled the driver to? Anything else I might try to get this working? Is this problem most likely because of Intels implementation of OpenCL or could it be the way the app works?

(Edited to correct a typo one the amount of RAM installed)

Also, does the same thing happen when you try to run another OpenCl app (i.e. one of the samples from the SDK)?

To start with just to make things clear, I'm not a developer and I have no experience in programming or building/compiling programs. I've had some interest for a while but never gotten around to learning. The closest I've come is some really simple HTML. But enough about that.

After installing the Intel OpenCL SDK, a test version of Microsoft Visual Studio 2010 and the DirectX SDK I've now managed to build the NbodyMultiDevice sample and the results are:

With my Nvidia card in the computer and the TV connected to the motherboard HDMI connector.

When starting the Nbody program is only uses the CPU and all looks good. Turning the TV off/on doesn't change anything, the program continues working as it should. In the program window one can choose what device to run the program on CPU, GPU or both. Changing to CPU+GPU and turning the TV off/on has the effect that the program almost comes to a stop, the fps value displayed in the top left corner is 0.5 fps and both CPU and GPU load is almost zero. Changing the device option to anything, even the one already chosen gets it going again. When GPU only is chosen and I turn the TV off/on the program window goes all black, nothing is displayed. CPU and GPU load is zero and I have to exit and restart the program to get it going again.

Redoing the tests with the Nvidia card removed from the computer the results are the same as above.

Is there some energy saving feature in the drivers that can make OpenCL unavailable when the monitor is turned off? If there is how can I disable it? Can't find any options in the Intel graphics settings and the Windows energy settings is set to never turn off the computer or the display. GPU-Z shows that the graphics downclocks to it's lowest energy state, but that can also be because there isn't any load anymore.

Leave a Comment

Please sign in to add a comment. Not a member? Join today