Installing Intel(R) SDK for OpenCL* Applications XE 2013 R2 on OpenSUSE13.1 produced errors!

Installing Intel(R) SDK for OpenCL* Applications XE 2013 R2 on OpenSUSE13.1 produced errors!

Hi,

I just upgrade my system to OpenSUSE 13.1 which is a very fast and stable new release. However, there are errors produced when  Installing Intel(R) SDK for OpenCL* Applications XE 2013 R2. It seems that the config scripts have some problems.

In case of failure please consult README file
warning: opencl-1.2-base-3.1.1.11385-1.x86_64.rpm: Header V3 RSA/SHA1 Signature, key ID f789186f: NOKEY
Preparing...                          ################################# [100%]
Updating / installing...
   1:opencl-1.2-base-1:3.1.1.11385-1  ################################# [ 25%]
update-alternatives: error: alternative path /intel/opencl-1.2-3.1.1.11385/lib64/libOpenCL.so doesn't exist
warning: %post(opencl-1.2-base-1:3.1.1.11385-1.x86_64) scriptlet failed, exit status 2
   2:opencl-1.2-intel-cpu-1:3.1.1.1138################################# [ 50%]
/var/tmp/rpm-tmp.W3ySqm: line 4: /intel/opencl-1.2-3.1.1.11385/etc/intel64.icd.rpmnew: No such file or directory
warning: %post(opencl-1.2-intel-cpu-1:3.1.1.11385-1.x86_64) scriptlet failed, exit status 1
   3:opencl-1.2-intel-devel-1:3.1.1.11################################# [ 75%]
/var/tmp/rpm-tmp.vhVv6u: line 6: /intel/opencl-1.2-3.1.1.11385/bin/ioc64.rpmnew: No such file or directory
warning: %post(opencl-1.2-intel-devel-1:3.1.1.11385-1.x86_64) scriptlet failed, exit status 1
   4:opencl-1.2-devel-1:3.1.1.11385-1 ################################# [100%]
update-alternatives: error: alternative path /intel/opencl-1.2-3.1.1.11385/include/CL doesn't exist
warning: %post(opencl-1.2-devel-1:3.1.1.11385-1.x86_64) scriptlet failed, exit status 2

It is wired to try to find /intel/opencl-1.2-3.1.1.11385/ instead of /opt/intel/opencl-1.2-3.1.1.11385/include/CL. So I add the ICD file to /etc/OpenCL/vendors and add /opt/intel/opencl-1.2-3.1.1.11385/lib64 to LD_LIBRARY_PATH manually and it just works.  I hope that it can be fixed in the next release. Thanks!

 

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hello.

Thank you for you report!

Could you provide reproducer for the issue?

1) Exact command line for installing RPMs and full output.

2) Do you have previous version of OpenCL installed on the machine?

 

Best regards,

Mike Smirnov.

HI,

Thanks for your reply.

There is no previous Intel OpenCL SDK installed in this machine. I just run the install script in the installer packages with commands "sh install-cpu.sh". This works fine on OpenSUSE 12.3. I don't know why the scripts try to find the files in " /intel/opencl-1.2-3.1.1.11385/"?  

Thanks!

ZHAO Peng

P { margin-bottom: 0.21cm; }

Hello,

I have used a fresh installation of OpenSUSE 13.1 and the zypper installation method.

My errors are the same. There was no previous OpenCL installed on this machine.

Even the latest version (SDK R3) I've tried unsuccessfully.

How can I fix it?

 

Best regards,

 

Stefan

 


# zypper install opencl-1.2-base-3.2.1.16712-1.x86_64.rpm 
Daten des Repositories laden ...
Installierte Pakete lesen ...
Paketabhängigkeiten auflösen ...

Das folgende NEUE Paket wird installiert:
  opencl-1.2-base 

1 neues Paket zu installieren.
Gesamtgröße des Downloads: 13,3 KiB. Nach der Operation werden zusätzlich 26,4 KiB belegt.
Fortfahren? [j/n/? zeigt alle Optionen] (j): 
Paket opencl-1.2-base-1:3.2.1.16712-1.x86_64 wird abgerufen                                   (1/1),  13,3 KiB ( 26,4 KiB entpackt)
Paket opencl-1.2-base-1:3.2.1.16712-1.x86_64 wird abgerufen                                   (1/1),  13,3 KiB ( 26,4 KiB entpackt)
(1/1) Installation von: opencl-1.2-base-1:3.2.1.16712-1 ...................................................................[fertig]
Zusätzliche rpm-Ausgabe:
update-alternatives: error: alternative path /intel/opencl-1.2-3.2.1.16712/lib64/libOpenCL.so doesn't exist
warning: %post(opencl-1.2-base-1:3.2.1.16712-1.x86_64) scriptlet failed, exit status 2

 

Leave a Comment

Please sign in to add a comment. Not a member? Join today