OpenCL Kernel Fails only on 4th Generation Processors

OpenCL Kernel Fails only on 4th Generation Processors


I am working on creating a N-Body gravitational simulation using Intel OpenCL SDK. I have attached our Kernel. This kernel fails to execute only on the systems with Haswell (4th Generation) Intel processors. This has been highly frustrating issue blocking release of our infrastructure product. It highly relies on Intel CPU only OpenCL. Are you aware of this issue?

Following are the configurations we have tried to root cause the issue but no success

1) Intel core i7-4700 MQ + Nvidia GPU + OpenCL SDK 2013 = Fails

2) Intel core i7-4700 MQ + OpenCL SDK 2013 = Fails

3) Intel core i5(Third Generation + OpenCL SDK 2013 = Pass

4) Intel core i7-4770   + OpenCL SDK 2013 = Fails

5) Intel core i5(2nd Generation) + Nvidia GPU + OpenCL SDK 2013 = Pass

6) Intel core i5(3nd Generation) (notebook)+ no GPU + OpenCL SDK 2013 = Pass

We have tried all three OSes Windows 7, Windows 8, Windows 8.1. Still the Kernel seems to fails only on systems with Haswell processors. Please help resolve this issue.

Another note: We are using only CPU for execution(not Intel HD Graphics)

Downloadtext/plain NBody_EC.txt7.14 KB
5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Have you tried OpenCL 2014 beta ? Perhaps this is fixed with the newer release.

What error are you getting? Is there a way you can attach the whole source code for us to reproduce? Also as suggested above, can you reproduce the issue with the latest SDK?



Thanks for the quick reply. I have tried Open CL 2014 Beta on all systems but still same results. It seems to still use 2013 R3 runtime.



I cannot share with you the infrastructure code. But certainly I will be happy to prepare a stripped down version to help on this issue. I do not want to post the project on the forum, but share it with Intel Engineers. Please provide your email if where I can mail you a copy of my source code to repro this issue. My email ID is

As requested the source code has been mailed along with contact information. Please let me know if you need any more help to reproduce this issue

Leave a Comment

Please sign in to add a comment. Not a member? Join today