Installation problem (Intel SDK for OpenCL 2014 Beta)

Installation problem (Intel SDK for OpenCL 2014 Beta)

I'm trying to install the new SDK on Windows 8.1 but in the middle of installation I receive the an error message (screenshot attached to this post) which says "There is a problem with Windows Installer package...".

I have Visual Studio 2013 Premium installed as well as Intel Composer XE 2013 SP1.

Anyone else having the same problem? Any ideas what is causing the error message?

Thanks in advance :)

Intel SDK for OpenCL 2014 Beta Error

 

9 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I had no problem installing SKD 2013 R3 on my Haswell system. It runs the matmul example fine:

Running gemm_nn kernel with matrix size: 3968x3968
Memory row stride to ensure necessary alignment: 15872 bytes
Size of memory region for one matrix: 62980096 bytes
Using alpha = 0.57599 and beta = 0.872412
Host time: 1.30447 sec.
Host perf: 95.8123 GFLOPS

 

I understand that the 2013 R3 version do not support running OpenCL on the GPU part of the processor. Maybe I'm mistaken and need t install a special GPU driver ?

The 2014 SDK is Debian based and does not install on a Centos 6.5 system. Any date for a RPM based installation ? I would very much like to test the Haswell processor to see if there is any benefit from using the GPU as a processing element.

 

System:

=====  Processor composition  =====
Processor name    : Intel(R) Xeon(R)  E3-1285 v3
Packages(sockets) : 1
Cores             : 4
Processors(CPUs)  : 8
Cores per package : 4
Threads per core  : 2

CentOS release 6.5 (Final)

Linux hpc-eten.uio.no 2.6.32-431.el6.x86_64 #1 SMP Fri Nov 22 03:15:09 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

 

 

As mentioned here, can you generate the log and attach. That will give us clues on what went wrong.

Raghu

Hi,

Thanks for your reply. I have attached the log file to this post, unfortunately it is around 6000 lines.

Thanks in advance for your help, I appreciate it :)

Downloadtext/plain log.txt

Hi,

I reviewed the threads and looked for msiexec. However, there is no such file in the rpms:

rpm -qpl *rpm| grep msi

showed nothing, maybe this is a windows application ?

I asked about the RedHat/Centos version of the OpenCL intel_sdk_for_ocl_applications_2014_beta_sdk_4.0.1.17537_x64, the one I downloaded works only for debian based installations. It is impossible to generate any logs as the packages cannot be installed. 

I want to try to run OpenCL on the GPU part of the E3-1285 v3 processor and what I understand I need to install the above SDK, this is not possible without a RedHat rpm (or configure/make) distribution.

I works very well in CPU only mode with the intel_sdk_for_ocl_applications_xe_2013_r3_sdk_3.2.1.16712_x64 SDK:

[olews@hpc-eten CapsBasic]$ ./capsbasic
Number of available platforms: 1
Platform names:
    [0] Intel(R) OpenCL [Selected]
Number of devices available for each type:
    CL_DEVICE_TYPE_CPU: 1
    CL_DEVICE_TYPE_GPU: 0
    CL_DEVICE_TYPE_ACCELERATOR: 0

*** Detailed information for each device ***

CL_DEVICE_TYPE_CPU[0]
    CL_DEVICE_NAME: Intel(R) Xeon(R) CPU E3-1285 v3 @ 3.60GHz
    CL_DEVICE_AVAILABLE: 1
    CL_DEVICE_VENDOR: Intel(R) Corporation
    CL_DEVICE_PROFILE: FULL_PROFILE
    CL_DEVICE_VERSION: OpenCL 1.2 (Build 82248)
    CL_DRIVER_VERSION: 1.2.0.82248
    CL_DEVICE_OPENCL_C_VERSION: OpenCL C 1.2
    CL_DEVICE_MAX_COMPUTE_UNITS: 8
    CL_DEVICE_MAX_CLOCK_FREQUENCY: 3600
    CL_DEVICE_MAX_WORK_GROUP_SIZE: 8192
    CL_DEVICE_ADDRESS_BITS: 64
    CL_DEVICE_MEM_BASE_ADDR_ALIGN: 1024
    CL_DEVICE_MAX_MEM_ALLOC_SIZE: 8400896000
    CL_DEVICE_GLOBAL_MEM_SIZE: 33603584000
    CL_DEVICE_MAX_CONSTANT_BUFFER_SIZE: 131072
    CL_DEVICE_GLOBAL_MEM_CACHE_SIZE: 262144
    CL_DEVICE_GLOBAL_MEM_CACHELINE_SIZE: 64
    CL_DEVICE_LOCAL_MEM_SIZE: 32768
    CL_DEVICE_PROFILING_TIMER_RESOLUTION: 1
    CL_DEVICE_IMAGE_SUPPORT: 1
    CL_DEVICE_ERROR_CORRECTION_SUPPORT: 0
    CL_DEVICE_HOST_UNIFIED_MEMORY: 1
    CL_DEVICE_EXTENSIONS: cl_khr_icd cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_byte_addressable_store cl_khr_spir cl_intel_exec_by_local_thread cl_khr_fp64
    CL_DEVICE_PREFERRED_VECTOR_WIDTH_INT: 1
    CL_DEVICE_PREFERRED_VECTOR_WIDTH_LONG: 1
    CL_DEVICE_PREFERRED_VECTOR_WIDTH_FLOAT: 1
    CL_DEVICE_PREFERRED_VECTOR_WIDTH_DOUBLE: 1
    CL_DEVICE_NATIVE_VECTOR_WIDTH_INT: 8
    CL_DEVICE_NATIVE_VECTOR_WIDTH_LONG: 4
    CL_DEVICE_NATIVE_VECTOR_WIDTH_FLOAT: 8
    CL_DEVICE_NATIVE_VECTOR_WIDTH_DOUBLE: 4

 

 

Hi Ole,

Currently there is no GPU support on Linux. Moreover my response was to the OP who is having problems on Windows.

Thanks,
Raghu

Hi Raghu,

I was wondering if you have any comments regarding the log.txt file I attached to my previous post.

I did notice some errors which seem to say something about GUI; doesn't make much sense about not being able to install the SDK...

Thanks again for your time.

Hi Ali,

I forwarded the log file to the dev team. Meanwhile, if you have an older version of the SDK, can you uninstall (making sure all registry entries have been removed) and install the new SDK again?

Thanks,
Raghu

Hi Raghu,

Thanks for your help, I will wait for dev team's feedback. I don't have any other version of the SDK installed, I'm trying to install this on a brand new laptop. I have Visual Studio 2013 Premium and Intel C++ Studio XE for Windows installed.

Regards

Leave a Comment

Please sign in to add a comment. Not a member? Join today