Problems with CL / GL interop

Problems with CL / GL interop

I am using the 2014 version of Intel SDK for OpenCL Apps.

I am developing an application that shares a buffer between openGL and openCL.  When I run my application from the debugger (VS2013), it fails in clCreateContext() -- i get the error code CL_INVALID_PLATFORM.  If I run outside the debugger, then the call to clCreateContext() works fine.

I observe the exact same problem when I run the Intel sample application: I downloaded intel_ocl_ogl_interop.zip, I build it, and I get exactly the same issue: fails in the debugger, works when I start the app from the command line.

I am running on a Core i7-3667 CPU with HD4000 GPU.  My OS is Windows 8.1.

Any suggested work-arounds?

-Alec

 

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Alec,

Thank you for reporting this issue. It is reproducible on our side and I will create a ticket for it.
Meanwhile, as a workaround, you may disable API debugger in 'TOOLS'->'Code Builder - Options'->'API Debugger Tab'->untick 'Enable OpenCL API Debugger'.

Thanks,
Yuri

 

Thanks, that fixed my problem.

 

-Alec

 

Leave a Comment

Please sign in to add a comment. Not a member? Join today