intel inspector causes an opencl application to crash on clbuildprogram

intel inspector causes an opencl application to crash on clbuildprogram

The title says it all; the application works fine otherwise if the Inspector is not attached. We are using II integrated with Visual Studio 2017. Linker set to a Full debug info output.

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi RafalS,

Thanks for the sharing the sighting.

Can you supply this system information here.

Also what version of Intel® Inspector is in use? What version of Intel® Graphics Driver or Which version of Intel® CPU Runtime for OpenCL™ Applications is in use?? What version of Visual Studio 2017?

The easiest way to determine graphics driver is by looking at device manager->display adapters, right click, properties, driver, driver version to get a version.

Can you supply a minimally representative source code reproducer? if so, please only share source code that is privileged to share. What device is clBuildProgram(...) targeting? Did the same behavior occur if targeting both CPU and iGFX (assuming the system has both available). Was clBuildProgram(...) targeting something non-intel?

To make it easy, if you can share the project we can take a look at the build parameters...  This could be shared via private message if necessary. If I can reproduce, we can file it to the inspector team.

 

Thanks,

-MichaelC

Leave a Comment

Please sign in to add a comment. Not a member? Join today