Intel SDK for openCL Applications installing problem

Intel SDK for openCL Applications installing problem


Hey,

I'm sorry for repoening the issue again; but I couldn't find any solution in the previous Topics concerning this issue.
I've got an i7-8750H CPU in my Laptop and the Intel® UHD Graphics 630 with Driver Version 26.20.100.7000 installed.
Like other people described the installer just closes after showing the Software Development Startup Screen.
I would be very happy if any one could help me with this issue.

Trying the the Intel OpenCL Tools I get the following warning:

Intel® CPU Runtime for OpenCL™ Applications cannot be installed
Intel® CPU Runtime for OpenCL™ Applications is already installed as part of Intel® Graphics Driver. However, to update OpenCL™ for CPU support, a manual installation of the package can be performed

Kind Regards

Jonas Sorgenfrei

6 posts / 0 new

Hi Jonas:

Intel support never provided any constructive guidance how to fix this problem. Since we would be dependent on Intel to provide an environment in which we can create applications that would run on their hardware, that informed us that we can't rely on Intel to do that and it would create too much risk putting investment behind building OpenCL software for the Intel platform. The logical conclusion was to not build this application for Intel products. 

Hope that explains why we haven't been active on this forum trying to help solve the OpenCL SDK installer problem.


Hi JonasS,

Hopefully some collateral can be passed to the dev team.

The warning is typically fine... What happened after the warning?

 

Approach:

In the first case are you using the Intel System Studio 2019 Update 4 installer or the standalone installer?

What version of Windows is this on?

From where did you obtain your driver?

 

Collateral for followup:

Can we get any install logs from the system? Can they be attached to this thread? Here are their locations. If the logs can't be shared here we can solicit them otherwise. Please let me know.

SDK/OCL tools installer logs: %TEMP%/pset_<characters>_<username> directory.

VS logs: %APPDATA%\Microsoft\VisualStudio\<Version_of_vs>

 

Thank you,

-MichaelC


Hey Michael,

sorry for my belayed response. The error still occurs with version 2019.5.345 of the Intel SDK for opencl applications.

 

Quote:

MICHAEL C. (Intel) wrote:

In the first case are you using the Intel System Studio 2019 Update 4 installer or the standalone installer?

I tried both, the error message above is occuring during the installation of the System Studio 2019 Installation.

 

Quote:

MICHAEL C. (Intel) wrote:

What version of Windows is this on?

From where did you obtain your driver?

Windows 10 Build 18362, my drivers are from the intel software website and I'm currently using the GraphicsDriver:
26.20.100.7463 26.21.14.4128*.
I've got an additional dedicated graphics card. Does this could be a problem for the installer?

 

Quote:

MICHAEL C. (Intel) wrote:

Collateral for followup:

Can we get any install logs from the system? Can they be attached to this thread? Here are their locations. If the logs can't be shared here we can solicit them otherwise. Please let me know.

SDK/OCL tools installer logs: %TEMP%/pset_<characters>_<username> directory.

I've attached the LOG of the SDK/OCL tools; it doesn't look like there an error occuring; it just closes.

 

I hope this gives you a little more information on the problem.

Thanks for your help.

 

Kind Regards
Jonas Sorgenfrei

Attachments: 

AttachmentSize
Downloadapplication/octet-stream pid_20940.log24.36 KB

Hi JonasS,

Thanks for the feedback.

Can you try the install.exe --net35 toogle  indicated here:

https://software.intel.com/en-us/forums/opencl/topic/832430

Does this unblock your install?

-MichaelC


Hey MichaelC,

it helped using the flag but i had to modify it to --net3.5 since while using only 35 the installer still used the 4.0 net plugin.

Thanks for your help.

Kind Regards
Jonas

Leave a Comment

Please sign in to add a comment. Not a member? Join today