Camera is detected, but call to PXCMSenseManager.Init never returns

Camera is detected, but call to PXCMSenseManager.Init never returns

The first time I installed the SDK it all worked fine, but after the first reboot it doesn't work anymore.

I have 3 3.0 USBs on my notebook and the behavior is the same on 3.

The camera is detected (its shown on device manager):

Most calls to PXCMSenseManager.Init (including all demos and the "Camera" tab) will result in a freeze where I can have to kill the app via task manager.

Sometimes it takes 30s to 1 minute to return from the init call and it returns as "item unavailable".

Attached I have the SDK Information dump.

Any help would be really appreciated.

Cheers,

André

 

AttachmentSize
Downloadapplication/zip realsense_log.zip933.71 KB
8 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi guys,

I noted that the SDK info tells me that there is an update available for the RealSense Runtime, but I couldn't it at the Intel RealSense portal.

Is the version of the this runtime correct? It seems older than the one I have installed.

 

You are correct, you have the latest version. It is a bug that the old beta is being picked up as an update. Please ignore it.
The forum will have a notice when a new update is actually available.

Hi Colleen,

Thanks for that.

Any idea why the camera is not working on my machine?

Are there any other logs/screenshots I can provide to solve that?

I've seen many people in the forum with problems with the camera, even though they are using 3.0 USBs like me. Do you think you (Intel) could provide a troubleshooting guide for us? 

 

Hi Andre,

Did you update the firmware software inside the camera (which is a separate thing from the SDK software on the computer) once you received the camera?

The latest firmware and drivers for the RealSense camera can be downloaded from the website of Creative, the camera's manufacturer:

http://bit.ly/1yMsQWI

Hi, I have the same trouble, even after updating with the Creative drivers/firmware. I have a i7-3820QM and a i7-4790 clevo laptops, win8.1 32GB RAM etc Intel USB3.0, like the original post. I have not been able to get the depth data from the f200 working on either of these computer despite them working fine with the Kinect v2 which similarly uses a lot of USB bandwidth and has well known issues with USB3.0 chipsets. Colour comes back fine but as soon as depth is tried to be accessed from the raw streams sample for example, the application hangs, and the camera reboots.

The only success I have had getting depth data from the f200 is using an i5-4300U 256GB Surface Pro 3. I would like to be able to get the device working on the other machines since the GPU on the SP3 is not really powerful enough for my work.

Thanks in advance,

Phil

Hi Marty,

I tried that, no success too :(

I had a defected model probably.

Thanks anyway.

 

 

Hi all, 

I had the same problem, RealSense camera was unresponsive.

What worked for me was pluggin the USB 3.0 cable to a different port, this "refreshed" the camera driver and when I ran my application the green led lighted up after the Sense Manager Init function. 

Cheers. 

Leave a Comment

Please sign in to add a comment. Not a member? Join today