Power limit registers in Sandy bridge

Power limit registers in Sandy bridge


I am trying to play around with the power limit register (MSR_PP0_POWER_LIMIT) available in sandy bridge architecture. The machine is equipped with i5-2500K processors. But after modifying the register, I don't see any impact on the power consumption. I use the energy status register (MSR_PP0_ENERGY_STATUS) to measure the energy consumption and divide it by time spent to get the average power consumption. I get the same power measurement before and after I modify the power limit register.

I tried the same process with one of the Xeon processor and it seemed to work. I can notice the change in the power consumption of the cpu cores. 

Does it mean that these registers work only in server class processors and not in desktop processors ?

- Sankar

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.


did you try Intel(r) Power Governor for changing the PP0 limits?

best regards,


Thanks for the response. I tried changing the register manually through msr registers.

I came across the power governor and it seems to be able to do what I needed, but the download link in the page does not work.

- Sankar


I will report the issue with the link and let you know.


I manually try to change the msr (power limit registers) which I think is what power_gov also does. I see that the lock bit is not set in any of the power limit registers (MSR_PKG or MSR_PP0 or MSR_PP1). I modify the values in the register and made sure that changes are reflected (by reading back the register) but still I do not see any impact on the system after modifying the registers.

I came across this in another thread (http://software.intel.com/en-us/forums/topic/282122) - I am not sure if the root cause is the same. If the 28th bit is set to 0 in MSR_PLATFORM_INFO (0xCE) register, I cannot write to MSR 0x1AD to change the turbo ratio. But in my case, I can write to the power limit registers.

Are there any other possibilities like motherboard vendors blocking the usage of these registers? If so, is there any way to test it?

the links should work now. Let us know if it works for you

I was able to download the tool but I was not able to resolve the original issue.

Leave a Comment

Please sign in to add a comment. Not a member? Join today