codebind: license checker internal error

codebind: license checker internal error

Hello all,

I have just finished installing the beta trial of Tamper Protection and OpenCV for INDE, I appreciate the offer very much, however, there is an issue.

I installed Started Edition, as I don't have a license to use the Ultimate Edition, I am but a hobbyist, I hope that is not what is prohibiting me from using the beta software.

I created a pair of DSA keys as instructed in the documentation. And I was going to test the codebind.exe on beaengine.dll, to see if it works, but I get this error:

 

C:\Intel\INDE\TamperProtection_0.1.22363\bin\win-x86_64>codebind.exe -i beaengine.dll -o beaengine.dll.sb -k %userprofile%\ssl\itp_keys\privkey.pem
codebind: license checker internal error

C:\Intel\INDE\TamperProtection_0.1.22363\bin\win-x86_64>codebind --help
codebind: license checker internal error

C:\Intel\INDE\TamperProtection_0.1.22363\bin\win-x86_64>codebind -h
codebind: license checker internal error

C:\Intel\INDE\TamperProtection_0.1.22363\bin\win-x86_64>codebind
codebind: license checker internal error

Are there any other steps I must perform before using the software, such as registering a license?

Thank you in advance.

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Todd, I looked at your previous post and you have some issue to  install TRS and did a  lot of installation/uninstallation. I think this may be caused this issue. I will work with my colleague and I will keep you post if I get anything from them. Thanks!

Best Reply

Hello Todd,

There is a troubleshooting section in Intel® Software License Manager Users Guide available at https://software.intel.com/en-us/articles/license-manager-for-flexlm-use...

I would start verifying that the INTEL_LICENSE_FILE environment variable existst and pointing to *.lic files. Then try running the failing command line again while INTEL_LMD_DEBUG environment variable set to 1 - it will give you more details on failure.

Thanks for the replies, David and Andrey.

Andrey, yes the INTEL_LICENSE_FILE variable is null / not set.

I tried to register the key that I was emailed, but it took me to page to download the installer. I am not sure what to do, should I try reinstalling everything from scratch, one last time? I suppose I could write my own polymorphic code, but I'd rather not reinvent the wheel.

I found the license file in "C:\Program Files (x86)\Common Files\Intel\Licenses\", the only one there is "w_Z28WG3LS.lic". I set the variables, but I get this output:

 

C:\Users\Todd>set INTEL_LICENSE_FILE="C:\Program Files (x86)\Common Files\Intel\Licenses\w_Z28WG3LS.lic;"

C:\Users\Todd>codebind --help
    INTEL_LMD: checkout: entered at start_time: 1433962334  (UTC) Wed Jun 10 18:52:14 2015
    INTEL_LMD: checkout: build options:
    INTEL_LMD: checkout:     build date:                2015.0401
    INTEL_LMD: checkout:     build platform:            Intel(R) 64 architecture; Microsoft Windows*
    INTEL_LMD: checkout:     checkout platform:         (same)
    INTEL_LMD: checkout:         *Other brands and names are the property of their respective owners.
    INTEL_LMD: checkout:     FLEXlm version:            11.12
    INTEL_LMD: checkout:     source version:            1.132  $ Intel(R) Software Licensing release 2.3 | FlexNet Publisher* version 11.12.0 $
    INTEL_LMD: checkout:     FLEX_MAX_LICENSE_TRIES:    0
    INTEL_LMD: checkout:     FLEX_USE_NOWAIT_AND_SPIN:  enabled
    INTEL_LMD: checkout:     FLEX_SPIN_SLEEP_SECONDS:   30
    INTEL_LMD: checkout:     heartbeats:                disabled (manual)
    INTEL_LMD: checkout:     server retry:              60 seconds
    INTEL_LMD: checkout:     FLEX_CHECKOUT_FILTER:      enabled
    INTEL_LMD: checkout:     FLEX_CLEAN_PATHS:          disabled
    INTEL_LMD: checkout:     FLEX_CLOCK_ROLLBACK_CHECK: enabled
    INTEL_LMD: checkout:     FLEX_APP_SPECIFIC:         disabled
    INTEL_LMD: checkout:     FLEX_CACHE_LICENSE_STATUS: disabled
    INTEL_LMD: checkout: user options:
    INTEL_LMD: checkout:     feature name:              BetaTRS-W
    INTEL_LMD: checkout:     opts:                      { FLEX_OPT_QUIET }
    INTEL_LMD: checkout:     try_count:                 0
    INTEL_LMD: checkout:     retry_interval:            30
    INTEL_LMD: checkout:     linger_time:               0
    INTEL_LMD: checkout: environment:
    INTEL_LMD: checkout:     INTEL_LICENSE_FILE         <"C:\Program Files (x86)\Common Files\Intel\Licenses\w_Z28WG3LS.lic;">
    INTEL_LMD: checkout:     LM_LICENSE_FILE            <NULL>
    INTEL_LMD: checkout:     INTEL_LMD_DEBUG            <1>
    INTEL_LMD: checkout: license file(s) used were (in this order):
    INTEL_LMD:     1.  "C:\Program Files (x86)\Common Files\Intel\Licenses\w_Z28WG3LS.lic
    INTEL_LMD:     2.  "
    INTEL_LMD: checkout: linger_time set to 0 by default
    INTEL_LMD: checkout: begin attempt(s) to checkout
    INTEL_LMD: checkout: about to do checkout call
    INTEL_LMD: checkout: checkout call returns rc -1

Error: A license for BetaTRS-W could not be obtained (-1,359,2).

BetaTRS-W: Cannot find license file.
 The license files (or license server system network addresses) attempted are
listed below.  Use LM_LICENSE_FILE to use a different license file,
 or contact your software provider for a license file.
Feature:       BetaTRS-W
Filename:
License path:  "C:\Program Files (x86)\Common Files\Intel\Licenses\w_Z28WG3LS.lic;"; ;
FlexNet Licensing error:-1,359.  System Error: 2 "No such file or directory"
For further information, refer to the FlexNet Licensing documentation,
available at "www.flexerasoftware.com".

Is your license file in the right location and readable?
The location of your license file should be specified via
the $INTEL_LICENSE_FILE environment variable.

License file(s) used were (in this order):
    1.  "C:\Program Files (x86)\Common Files\Intel\Licenses\w_Z28WG3LS.lic
    2.  "

Please visit http://software.intel.com/sites/support/ if you require technical assistance.

    INTEL_LMD: checkout: returns NOT GRANTED / ERROR
    INTEL_LMD: flex_return_license: called
    INTEL_LMD: flex_return_license: considering feature name: BetaTRS-W
    INTEL_LMD: flex_free_job: called
    INTEL_LMD: flex_free_job: lc_new_job was called
    INTEL_LMD: flex_return_license: done
codebind: license checker internal error

 

I looked at the license file, this is what the components variable is set to:
 

COMPONENTS="BetaOCV \
BetaTRS-A BetaTRS-W"

 

I hope that helps. The question still stands, would reinstalling everything from scratch be the best bet? I am not sure what BetaTRS-{A,W} stands for, "Tamper Resistant Software"?. Perhaps the Tamper Protection component is not listed in the license? I don't know, its all a black box to me.

Thanks for your help.

Ah ha!

Silly me, I had to set the variable for the whole system, not just the terminal I was using (I then restarted the software manager just in case, not sure if it was needed).
Then I opened a new terminal and tried again, it worked.

 

C:\Users\Todd>codebind
codebind: error parsing options: the option '--input-file' is required but missing
Usage:codebind[options]
Options:
  -i [ --input-file ] FILE  Get the input from FILE
  -k [ --key-file ] FILE    Get signer key from FILE
  -o [ --output-file ] FILE Place the output into FILE
  --seed arg                Seed value in a format: 0x<hex>, x<hex> or
                            <decimal>. The value can have any size.
  -v [ --verbose ] arg (=0) verbosity level
  -h [ --help ]             Display this help and exit
  -V [ --version ]          Output version information and exit

 

Thank you very much!

Leave a Comment

Please sign in to add a comment. Not a member? Join today