Composer Update 4 OMP warnings

Composer Update 4 OMP warnings

After upgrade to Composer_update4 I started to obtain warning messagesfrom Win32-compiled program running under Windows XP SP3 Russian (compiled at Windows 7 English):

=============================
OMP: Warning #2: Cannot open message catalog "1049\libiomp5ui.dll":
OMP: System error #126: = v .
OMP: Info #3: Default messages will be used.
=============================
It looks like there are some problem with default code pages in the new version of Composer OMP support.

Is there a workaround?

It caused me to downgrade to SP1 release of parallel studio.

Regards,
Michael

16 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Please following the instructions to change the regional language to English - http://software.intel.com/en-us/articles/changing-language-setting-to-see-english-on-a-japanese-os-environment-or-vice-versa-on-windows/

Then run the program again. It should then display the correct msg.

Please let us know if this works and thanks,
Jennifer

Quoting - Jennifer Jiang (Intel)
Please following the instructions to change the regional language to English - http://software.intel.com/en-us/articles/changing-language-setting-to-see-english-on-a-japanese-os-environment-or-vice-versa-on-windows/

Then run the program again. It should then display the correct msg.

Please let us know if this works and thanks,
Jennifer

Dear Jennifer,

My problem is different: my development computer already uses English, so I have no problem running and debuggingcompiled application at this machine.

But if I deploy compiled application to a different computer (for example, Windows XP SP3 Russian), it raises OMP warning message very disturbing to my users.

This disturbingwarning messageappeared only in Composer Update #4.

Regards,
Michael

Quoting - Miket

Dear Jennifer,

My problem is different: my development computer already uses English, so I have no problem running and debuggingcompiled application at this machine.

But if I deploy compiled application to a different computer (for example, Windows XP SP3 Russian), it raises OMP warning message very disturbing to my users.

This disturbingwarning messageappeared only in Composer Update #4.

Regards,
Michael

Ok, I understand the problem now, thanks!

This msg should be only printed when there're run-time msgs being printed.

As for this issue only appears in the Parallel Composer update4, it's not the case. This msg will only be displayed when you turn on the OMP msg.
e.g. SET KMP_SETTINGS=1 will turn on this msg.

There's no flag to turn this msg off as of now. But you can safely ignore this msg.

Do you really need a flag to control this msg?

Jennifer

Quoting - Jennifer Jiang (Intel)

Ok, I understand the problem now, thanks!

This msg should be only printed when there're run-time msgs being printed.

As for this issue only appears in the Parallel Composer update4, it's not the case. This msg will only be displayed when you turn on the OMP msg.
e.g. SET KMP_SETTINGS=1 will turn on this msg.

There's no flag to turn this msg off as of now. But you can safely ignore this msg.

Do you really need a flag to control this msg?

Jennifer

Sorry for a large screenshot, but I would like to furtherclarify my problem. This is compiled application (with Intel-compiled dlls using OpenMP) running at a clean WinXP SP3 Russian. I don't use environment variables to control OpenMP, there is nothing specialwith this system.

Black window with messages is really annouing, isn't it?

Regards,
Michael

Yes, it's pretty bad.
I tested with a cmd line program and did not get this msg if no omp msg.
It's strange that you got this msg all the time.

Could you verify that you are using the same omp dll under the run-time environment and under the development environment?

btw. we have redistributable libraries posted here: http://software.intel.com/en-us/articles/redistributable-libraries-of-the-intelr-parallel-composer/

Jennifer

Quoting - Jennifer Jiang (Intel)
Yes, it's pretty bad.
I tested with a cmd line program and did not get this msg if no omp msg.
It's strange that you got this msg all the time.

Could you verify that you are using the same omp dll under the run-time environment and under the development environment?

btw. we have redistributable libraries posted here: http://software.intel.com/en-us/articles/redistributable-libraries-of-the-intelr-parallel-composer/

Jennifer

Jennifer,

Did you test at a "foreign" system? It is important, since at Windows English everything works nicely.

I checked run-time dlls, no problems with them, they are correct.

For your convenience I created a test case. This is Delphi GUI calling Intel-compiled DLL with OpenMP (simple Pi example).Exe file and allrun-time dlls are in the subfolder OMP_dllRelease

This example demonstrates similar annoying window at "foreign" Windows (WinXP SP3 Russ in my case).

See attachment.

Regards,
Michael

Attachments: 

AttachmentSize
Download Tru_Intel.zip1.19 MB

Quoting - Miket
For your convenience I created a test case. This is Delphi GUI calling Intel-compiled DLL with OpenMP (simple Pi example).Exe file and allrun-time dlls are in the subfolder OMP_dllRelease

This example demonstrates similar annoying window at "foreign" Windows (WinXP SP3 Russ in my case).

See attachment.

Regards,
Michael

Thank you very much Michael.

I'm able to duplicate your issue and has reported it to the compiler engineer to fix. Once I got any news about it, I'll let you.

In my case I copied the old libiomp5md.dll to my test.exe folder and it worked.
Another work-around is to change the Language Setting to use English for non-Unicode program.

But if I found a better work-around, I'll let you know.

Regards,
Jennifer

Quoting - Jennifer Jiang (Intel)

Thank you very much Michael.

I'm able to duplicate your issue and has reported it to the compiler engineer to fix. Once I got any news about it, I'll let you.

In my case I copied the old libiomp5md.dll to my test.exe folder and it worked.
Another work-around is to change the Language Setting to use English for non-Unicode program.

But if I found a better work-around, I'll let you know.

Regards,
Jennifer

Dear Jennifer,

Thank you for the information. It looks like I will need to stay with the previous release since:
(a) it is not clear what additional problems may cause using of libiomp5md.dll from the previous version. It is more logical simplyto stay with the previous version.
(b) changing Language settings at "foreign" systems to English will cause all other non-Unicode programs to display garbage in most cases, so it is unacceptible to my users.

Waiting for news from development team,
Michael

Quoting - Miket

Dear Jennifer,

Thank you for the information. It looks like I will need to stay with the previous release since:
(a) it is not clear what additional problems may cause using of libiomp5md.dll from the previous version. It is more logical simplyto stay with the previous version.
(b) changing Language settings at "foreign" systems to English will cause all other non-Unicode programs to display garbage in most cases, so it is unacceptible to my users.

Waiting for news from development team,
Michael

Yes, agree.

We have a better work-around for this from our engineer.
Set "KMP_WARNINGS=0" should get rid of the warning.
Also about the unreadable msg, it's caused by the "KMP_CODEPAGE" env-var. If you set "KMP_CODEPAGE=OEM", it should solve it.

Hope this work-around can help for now.

thanks,
Jennifer

Quoting - Jennifer Jiang (Intel)

Yes, agree.

We have a better work-around for this from our engineer.
Set "KMP_WARNINGS=0" should get rid of the warning.
Also about the unreadable msg, it's caused by the "KMP_CODEPAGE" env-var. If you set "KMP_CODEPAGE=OEM", it should solve it.

Hope this work-around can help for now.

thanks,
Jennifer

Dear Jennifer,

This information helped a lot: I added a call to

kmp_set_warnings_off();

in the initialization part of my DLLs and now everything works fine.

Regards,
Michael

Hi Jennifer,

I can confirm the same error on my developer environment:

OMP: Warning #2: Cannot open message catalog "1031\libiomp5ui.dll":

OMP: System error #126: Das angegebene Modul wurde nicht gefunden.

OMP: Info #3: Default messages will be used.

I hope I can fix it as Micheal did.

regards heinz

Hi all,

this issue is fixed and the fix should be in our coming 11.1 compiler update-5 and Parallel Composer update-5 that should be out around early to mid Feb.

Please check the email from Intel Premier Support. I'll try to respond here as well but may be not as quick.

Thanks,
Jennifer

Hallo, Jennifer,

I update with the new version, this issue is still there when I use a 64bit computer and then compile and get 64bit code or 32bit. both of them present the above issue

Regards,

Lei

Hi Lei,

Thanks for letting me know. The fix didn't catch the update 5 schedule. It will be in the update 6 instead. I should have posted a note here. Sorry about that.

Jennifer

Michael,

please see here - you can find there several workarounds regarding the similar problem.

--Gennady

Leave a Comment

Please sign in to add a comment. Not a member? Join today