Setting environment variables for Intel Composer XE 2011 (Linux)

Setting environment variables for Intel Composer XE 2011 (Linux)

Hej

I am student and trying to parallelize some of my programs using both Intel TBB and Intel Cilk Plus. I got individual free version of "Intel Parallel Studio XE 2011" for linux and have installed it with all defaults components. Now to set environment variable for "Intel Composer XE 2011", I tried the suggested command;

[x_akhal@neolith1 ~]$ source intel_parallel_studio_xe/bin/compilervars.sh
ERROR: Unknown switch 'PROD_DIR=/home/x_akhal/intel_parallel_studio_xe/composerxe-2011.4.191'. Accepted values: ia32, intel64

[x_akhal@neolith1 ~]$ source intel_parallel_studio_xe/bin/compilervars.csh
-bash: intel_parallel_studio_xe/bin/compilervars.csh: line 36: syntax error: unexpected end of file

I tried commands both for compilervars.sh as well as compilervars.csh since I dont know which one I have to run. I dont know how to use accepted values ia32/intel64 as first command error says. What I need to do?

PS: I also dont know if intel composer is the right place to use TBB and Cilk Plus in my programs. I tried simple commands such as "$icpc my_program.cc -ltbb" but it seems not working for tbb since it gives error like "catastrophic error: can not open tbb/parallel_for.h". Please suggest how should I go. Thanks

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Best Reply

Akhal,

The compilervars.sh script accepts a parameter pointing to architecture. If your machine is IA-32, use ia32:
source intel_parallel_studio_xe/bin/compilervars.sh ia32

Your shell is bash, so use .sh, not .csh. The following command can show your system architecture:
file /usr/bin/file

For setting up environment please go through getting started documentation of interested products:
http://software.intel.com/en-us/articles/intel-software-product-tutorials/
http://software.intel.com/en-us/articles/intel-threading-building-blocks-documentation/

Regards,
Kirill

Oh Thank you so much, I found it out; it was intel64...

Leave a Comment

Please sign in to add a comment. Not a member? Join today