Run-time error with parallel amplifier

Run-time error with parallel amplifier

When I run the sample program matrix (by following the Getting Started document) in profile mode (after hitting the profile button) I receive a C++ Runtime Error. In the command window, I receive the following string:

can't get CPU frequency

If I just debug the sample program, it run just fine. (Intel Inspector seems to work fine also).

Here is my machine specs:

------------------
System Information
------------------
Time of this report: 1/27/2009, 14:30:23
Machine name: SUN-ULTRA20-4
Operating System: Windows XP Professional x64 Edition (5.2, Build 3790) Service Pack 2 (3790.srv03_sp2_gdr.080813-1204)
Language: English (Regional Setting: English)
System Manufacturer: Sun Microsystems
System Model: Sun Ultra 20 Workstation
BIOS: Default System BIOS
Processor: Dual Core AMD Opteron Processor 180 (2 CPUs), ~2.4GHz
Memory: 4094MB RAM
Page File: 1328MB used, 10683MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: Not found
DxDiag Version: 5.03.3790.3959 64bit Unicode

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
MrAnderson (Intel)'s picture

I'm sorry for the delay in responding to your post, but hope you saw my response in the other thread.

This appears to be a limitation in the current beta software. We did not intentionally limit usage to genuine Intel processors, but it appears we did something that is not supported on non-genuine Intel processors. We are exploring our options and will update this thread when we have new information to share.

Regards, MrAnderson
MrAnderson (Intel)'s picture

Update: This problem should be resolved in the latest beta update. Please download and install Intel Parallel Studio Beta Update 2 and let us know if it works!

Thanks

Regards, MrAnderson

Hi, I have still this Problem with Parallel Amplifier Beta Update 4, (build 49409).

Processor: AMD Athlon 64 X2 Dual Core Processor 3800+, 2GHz

Any suggestions?

MrAnderson (Intel)'s picture

Quoting - MaWe
Hi, I have still this Problem with Parallel Amplifier Beta Update 4, (build 49409).

Processor: AMD Athlon 64 X2 Dual Core Processor 3800+, 2GHz

Any suggestions?

Sorry. Egg on my face! Evidently, it still fails on *some* non-Intel processors. :-(

I was told it was fixed. I am beating the development team with a wet noodle. I will update when I know more...

Regards, MrAnderson

Quoting - MrAnderson (Intel)

Sorry. Egg on my face! Evidently, it still fails on *some* non-Intel processors. :-(

I was told it was fixed. I am beating the development team with a wet noodle. I will update when I know more...

hi,I came across the same problem .
cpu: AMD sp 2500+ .
parallel studio beta updated 2

BTW:where to download the beta updated 4?

MrAnderson (Intel)'s picture

Quoting - joyeru

hi,I came across the same problem .
cpu: AMD sp 2500+ .
parallel studio beta updated 2

BTW:where to download the beta updated 4?

Sorry for the confusion. Intel Parallel Studio Beta Update 2 includes Intel Parallel Amplifier Beta Update 4. That is the most current release available.

Regards, MrAnderson

Login to leave a comment.