another boring question to install intel fortran compiler in linux?

another boring question to install intel fortran compiler in linux?

I download intel fortran compiler of "l_fc_p_8.0.034.tar.gz" and the licence file of "l_for_97501171.lic", thenuntar the "l_fc_p_8.0.034.tar.gz' in the directory of "/home/peng/src". After doing so,I performed the following command

cd /home/peng/src/l_fc_p_8.0.034
mkdir /opt/intel
mkdir /opt/intel/licenses
cp/home/peng/src/l_for_97501171.lic /opt/intel/licenses/
./install.sh

then, I got the following messages.

[root@localhost l_fc_p_8.0.034]# ./install.sh
A valid FLEXlm license is required to install this product, but none were found
in $INTEL_LICENSE_FILE (.:/opt/intel/licenses).
Where is a valid FLEXlm license for this product?
Enter directory or file, or just 'Enter' to exit.
/opt/intel/licenses
A valid FLEXlm license is required to install this product, but none were found
in $INTEL_LICENSE_FILE (/opt/intel/licenses:.:/opt/intel/licenses).
Where is a valid FLEXlm license for this product?
Enter directory or file, or just 'Enter' to exit.
A valid FLEXlm license key for this product is needed before installation. Exiting...
[root@localhost l_fc_p_8.0.034]# ls -la /opt/intel/licenses
total 12
drwxr-xr-x 2 root root 4096 1? 14 21:27 .
drwxr-xr-x 3 root root 4096 1? 14 21:27 ..
-rw-r--r-- 1 root root 2277 1? 14 21:27 l_for_97501171.lic
What can I do to install the intel fortran compiler sucessfully???

5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Please send install-type questions to Intel Premier Support. They can get you going again.

Steve - Intel Developer Support

We have done SuSE 9 installations on a wide variety of machines, and I don't know of any behavior out of the ordinary. The install scriptnormally asks you to specify the directory which contains the valid license, and asks for confirmation whether you want the ia32 or ia64 installation (choose ia32).

Definitely wrong. "IA64", if it is even called that, is for Itanium. Use IA-32 unless you're using an Itanium box.

Steve - Intel Developer Support

For an x86-64 architecture, you need the ia32compiler, regardless of whether you have the 32-bit linux or the x86-64. The Intel compiler scripts aren't aware of the x86-64 OS. You will need to assure that you have installed the 32-bit development options, and that the compiler uses those options rather than the default 64-bit.

Leave a Comment

Please sign in to add a comment. Not a member? Join today