Installation issues ifort 11.0.074

Installation issues ifort 11.0.074

Hi,

I try to install the Intel fortran compiler via the install.sh script from the package l_cprof_p_11.0.074_intel64.tgz

on a machine with a Q9450 processor and a slamd64-12.1 installation.

The installer misses some 32-bit compatibility libraries (libstdc++, libstdc++5, glibc, libgcc in:

Step no: 4 of 7 | Installation configuration - Missing Critical Pre-requisite), which I think I should have:

$ ls -l /usr/lib*/libstdc++.so* /usr/lib*/libc.so* /usr/lib*/libgcc*

-rw-r--r-- 1 root root 238 2008-05-04 18:38 /usr/lib/libc.so
lrwxrwxrwx 1 root root 13 2008-10-06 16:43 /usr/lib/libgcc_s.so -> libgcc_s.so.1
-rw-r--r-- 1 root root 239894 2008-03-22 23:24 /usr/lib/libgcc_s.so.1
lrwxrwxrwx 1 root root 18 2008-10-06 16:43 /usr/lib/libstdc++.so -> libstdc++.so.6.0.9*
lrwxrwxrwx 1 root root 18 2008-10-06 16:43 /usr/lib/libstdc++.so.5 -> libstdc++.so.5.0.7*
-rwxr-xr-x 1 root root 748800 2008-04-06 17:08 /usr/lib/libstdc++.so.5.0.7*
lrwxrwxrwx 1 root root 18 2008-10-06 16:43 /usr/lib/libstdc++.so.6 -> libstdc++.so.6.0.9*
-rwxr-xr-x 1 root root 1183952 2008-03-22 23:24 /usr/lib/libstdc++.so.6.0.9*
-rw-r--r-- 1 root root 253 2008-05-04 18:52 /usr/lib64/libc.so
lrwxrwxrwx 1 root root 13 2008-10-06 16:44 /usr/lib64/libgcc_s.so -> libgcc_s.so.1*
-rwxr-xr-x 1 root root 54864 2008-03-22 23:36 /usr/lib64/libgcc_s.so.1*
lrwxrwxrwx 1 root root 18 2008-10-06 16:45 /usr/lib64/libstdc++.so -> libstdc++.so.6.0.9*
lrwxrwxrwx 1 root root 18 2008-10-06 16:41 /usr/lib64/libstdc++.so.5 -> libstdc++.so.5.0.7*
-rwxr-xr-x 1 root root 830536 2007-05-31 21:37 /usr/lib64/libstdc++.so.5.0.7*
lrwxrwxrwx 1 root root 18 2008-10-06 16:45 /usr/lib64/libstdc++.so.6 -> libstdc++.so.6.0.9*
-rwxr-xr-x 1 root root 979416 2008-03-22 23:36 /usr/lib64/libstdc++.so.6.0.9*

I also do not get the possibility to do an "unsupported installation"? Former installations of the ifort

were more or less flawlessly.

Can you give me some advice?

Thanks in advance,

rokali

25 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

The Intel64 compiler is native 64-bit, so has no use for 32-bit libraries, beyond the libstdc++ for 32-bit gcc-3.4. It does require an installation of 64-bit g++, as its predecessors did. It should still be using g++ to find out which gnu libraries to use. The 32-bit compiler would require an installation of 32-bit g++ (invoked as g++ -m32), possibly including the compat-libstdc++, as before.

The 11.0 install menu doesn't use the same words as 10.1 for unsupported installation, and the selection for missing prerequisites is buggy. Assuming that you have the corresponding g++ active, you simply accept the default, to ignore missing prerequisites. idb installation is fully automatic only on a very limited selection of distros, so you would likely need some of the work-arounds discussed on this forum.

If you don't like to fiddle with obsolete installer issues, an effort has been made to fix them in current releases.

Quoting - tim18

The 11.0 install menu doesn't use the same words as 10.1 for unsupported installation, and the selection for missing prerequisites is buggy. Assuming that you have the corresponding g++ active, you simply accept the default, to ignore missing prerequisites. idb installation is fully automatic only on a very limited selection of distros, so you would likely need some of the work-arounds discussed on this forum.

OK, thank you for your answer.

The problem is, that the installer (pset/32e/install.32e ?) does not allow to ignore the

prerequisites. It is a loop at step 4 from 7.

This is the last part of the terminal output of the installer:

ESC[2JESC[1;1HStep no: 4 of 7 | Installation Type
--------------------------------------------------------------------------------
Congratulations! Your software has been activated. Please continue the
installation by choosing Typical Install (using all default) or Custom Install
to change the default install options.
--------------------------------------------------------------------------------
1. Typical Install (Recommended) [default]
2. Custom Install (For Advanced Users)

h. Help
b. Back to the previous menu
q. Quit
--------------------------------------------------------------------------------
Please type a selection or press "Enter" to accept default choice [1]:
--------------------------------------------------------------------------------
Checking the prerequisites. It can take several minutes. Please wait...
--------------------------------------------------------------------------------
which: no java in (/usr/local/sbin:/usr/local/bin:/sbin:/usr/sbin:/bin:/usr/bin)
ESC[2JESC[1;1HStep no: 4 of 7 | Installation configuration - Missing Critical Pr
e-requisite
--------------------------------------------------------------------------------
There is one or more critical unresolved issue which prevents installation to
continue. You can fix it without exiting from the installation and re-check. Or
you can quit from the installation, fix it and run the installation again.
--------------------------------------------------------------------------------
Missing critical pre-requisite
-- 32-bit libraries not found
------------------------------------------------------------
1. Show the detailed info about issue(s) [default]
2. Re-check the pre-requisites

h. Help
b. Back to the previous menu
q. Quit
--------------------------------------------------------------------------------
Please type a selection or press "Enter" to accept default choice [1]:
ESC[2JESC[1;1HStep no: 4 of 7 | Installation configuration - Missing Critical Pr
e-requisite
--------------------------------------------------------------------------------
32-bit libraries not found on this system.
This product release requires the presence of 32-bit compatibility libraries
when running on Intel 64 architecture systems. One or more of these libraries
could not be found:
libstdc++
libstdc++5
glibc
libgcc
Without these libraries, the compiler will not function properly. These
libraries,
if not installed, can be installed from the OS discs after finishing the
compiler
installation.
Please refer to Release Notes for more information.
--------------------------------------------------------------------------------
1. See next issue [default]
2. Back to Pre-requisite summary dialog

h. Help
b. Back to the previous menu
q. Quit
--------------------------------------------------------------------------------
Please type a selection or press "Enter" to accept default choice [1]:
ESC[2JESC[1;1HStep no: 4 of 7 | Installation configuration - Missing Critical Pr
e-requisite
--------------------------------------------------------------------------------
There is one or more critical unresolved issue which prevents installation to
continue. You can fix it without exiting from the installation and re-check. Or
you can quit from the installation, fix it and run the installation again.
--------------------------------------------------------------------------------
Missing critical pre-requisite
-- 32-bit libraries not found
------------------------------------------------------------
1. Show the detailed info about issue(s) [default]
2. Re-check the pre-requisites

h. Help
b. Back to the previous menu
q. Quit
--------------------------------------------------------------------------------
Please type a selection or press "Enter" to accept default choice [1]: q

It is the same issue, if I choose custom install.

Perhaps I simply missed the possibility to force the installation to continue?

Thanks,

rokali

Steve Lionel (Intel)'s picture

You're installing the 32-bit compiler and therefore the 32-bit development libraries component is required. Please read the System Requirements section of the Release Notes for further information.

Or, do not install the 32-bit compiler and get the Intel 64 compiler instead.

Steve

Quoting - Steve Lionel (Intel)

You're installing the 32-bit compiler and therefore the 32-bit development libraries component is required. Please read the System Requirements section of the Release Notes for further information.

Or, do not install the 32-bit compiler and get the Intel 64 compiler instead.

OK, now I'm puzzled.

I downloaded and extracted this file: l_cprof_p_11.0.074_intel64.tgz

It contains - among other files - the file intel-cprof110074e-11.0-1.x86_64.rpm

So I'm sure, that I have the 64-bit compiler, appropriate for my system:

$ uname -m
x86_64

I think I have the required packages, as well 64-bit binaries and libraries

as 32-bit compatibility libs, as stated in my first post.:

$which gcc
/usr/bin/gcc

$which g++
/usr/bin/g++

$/sbin/ldconfig -p|egrep "libstdc|libgcc|libc.so"
libstdc++.so.6 (libc6,x86-64) => /usr/lib64/libstdc++.so.6
libstdc++.so.6 (libc6) => /usr/lib/libstdc++.so.6
libstdc++.so.5 (libc6,x86-64) => /usr/lib64/libstdc++.so.5
libstdc++.so.5 (libc6) => /usr/lib/libstdc++.so.5
libstdc++.so (libc6,x86-64) => /usr/lib64/libstdc++.so
libstdc++.so (libc6) => /usr/lib/libstdc++.so
libgcc_s.so.1 (libc6,x86-64) => /usr/lib64/libgcc_s.so.1
libgcc_s.so.1 (libc6) => /usr/lib/libgcc_s.so.1
libgcc_s.so (libc6,x86-64) => /usr/lib64/libgcc_s.so
libgcc_s.so (libc6) => /usr/lib/libgcc_s.so
libc.so.6 (libc6,x86-64, OS ABI: Linux 2.6.16) => /lib64/libc.so.6
libc.so.6 (libc6, OS ABI: Linux 2.6.16) => /lib/libc.so.6

Correct me if I'm wrong, but I think I match the "Requirements to Develop Intel 64 Architecture Applications"

from the System Requirements.

Your help would be much appreciated.

Thanks

rokali

Steve Lionel (Intel)'s picture

Ok, I see now. Unfortunately, the Linux install is not my area of expertise. This may need to wait for Monday when Intel US returns from the holiday.

Steve

Hello.

I have the same problem. All required libraries are installed. Nevertheless installer didn't see them( libstdc++, glibc, libgcc, libstdc++5).

Are there any ways to resolve this problem?

Quoting - shlendr

Hello.

I have the same problem. All required libraries are installed. Nevertheless installer didn't see them( libstdc++, glibc, libgcc, libstdc++5).

Are there any ways to resolve this problem?

It seems I've just solved this problem =) in Kubuntu: sudo apt-get install ia32-libs

Rafael Barreto's picture

Quoting - shlendr

It seems I've just solved this problem =) in Kubuntu: sudo apt-get install ia32-libs

I am experiencing the same problem in Slamd64.
http://www.slamd64.com/

The compatibility libraries (related to Debian ia32-libs) are installed, so I think it is a bug in the intel install script, which does not find the libraries in the Slamd64 directories (in this case, /usr/lib to 32 bits and /usr/lib64 to 64 bits).

# locate libstdc++.a
/usr/lib64/libstdc++.a
/usr/lib/libstdc++.a

This bug does not occur in 10.1.012, so I still using this version in these Slamd64 machines.

On my laptop, I use Ubuntu 8.10, and I have not this problem.

Usa e serás mestre.
Ronald W Green (Intel)'s picture

I have just posted the Linux silent installation procedure here:

http://software.intel.com/en-us/forums/showthread.php?t=63038

Try this procedure. I assume that slamd64 is Debian based and thus does not have RPM. For this case, modify the invocation of install_fc.sh thusly:

install_fc.sh -n --run --silent FILENAME

using the -n to get a non-rpm install.

For the FILENAME configuration file (copied from SilentInstallConfigFile.ini) you'll want something like this:

# IA32

[ifort11-ia32]
INSTALLDIR=/opt/intel/Compiler/11.0/074
OPTIONS=-U --replacefiles --force --nodeps
EULA=accept
ECL_DISCLAIMER=accept
NON_SUPPORTED_OS_INSTALL=Yes
REPLACE_EXISTING_INSTALLATION=Yes

[iidb11-ia32]
INSTALLDIR=/opt/intel/Compiler/11.0/074
OPTIONS=-U --replacefiles --force --nodeps
EULA=accept
NON_SUPPORTED_OS_INSTALL=Yes
REPLACE_EXISTING_INSTALLATION=Yes

[mkl11-ia32]
INSTALLDIR=/opt/intel/Compiler/11.0/074
OPTIONS=-U --replacefiles --force --nodeps
EULA=accept
NON_SUPPORTED_OS_INSTALL=Yes
REPLACE_EXISTING_INSTALLATION=Yes

and similarly for the configs for Intel 64.

Keep in mind, this does not guarantee your compiler will work after installation. You are using a non-supported Linux distribution. We are bypassing the prerequisite checks so all bets are off as to whether this will work or not.

ron

Thank you alot Ronald !!!
thank you !!!

I had the same issue with the 11.0.081 version of the Intel Fortran compiler.
(with the l_cprof_p_11.0.081.tgz or the l_cprof_p_11.0.081_intel64.tgz on a (recent) x86_64 Linux):
"
Missing critical pre-requisite
-- 32-bit libraries not found
"

detail:
32-bit libraries not found on this system.
This product release requires the presence of 32-bit compatibility libraries
when running on Intel 64 architecture systems. One or more of these libraries
could not be found:
libstdc++
libstdc++5
glibc
libgcc

But I checked and all req. libs are in /lin64 /lib /usr/lib64 and /lib (And when I check the type "file /lib64/libc.so.6" or "file /lib64/libc-2.7.so" is well a "ELF 64-bit LSB shared object, x86-64..." or a 32bits if in /lib/...

I have this problem on a Linux Mandriva 2008.1 x86_64 (2008.1.0 0.11 cambria, kernel 2.6.24.4-server-1mnb)
as well as on a Mandriva 2009.1 x86_64, (2009.1.0 1 pauillac, kernel 2.6.29.1-desktop-4mnb)
but the same install does not fait (works well) on a RHEL (RedHat) 5.3 install (kernel 2.6.18-128.el5)...

With you tip (install_fc.sh -n --run --silent FILENAME) it's working fine !
(but you have to modify the aleady existent file in ./l_cprof_p_11.0.081_intel64/l_cprof_p_11.0.081/
( ./l_cprof_p_11.0.081_intel64/l_cprof_p_11.0.081/SilentInstallConfigFile.ini) !)

The fortran programs compile well and run well.

ps: I also added into the .bash_profile :
PATH=$PATH:/opt/intel/Compiler/11.0/081/bin/intel64
export PATH
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/intel/Compiler/11.0/074/lib/intel64
export LD_LIBRARY_PATH

Thanks for the tip,

Michel.P@Lpgp (ups-cnrs)

I am facing the same problem in mandriva.Please see my post
http://software.intel.com/en-us/forums/showthread.php?t=69071

I am not abkle to implement the silent procedure in mandriva 64 bit.
I run
./install.sh -n -run --silent sil.txt
Where sil.txt is a text file containing
------------------------------------------------------------
[ifort11-intel64]
INSTALLDIR=/opt/intel/Compiler/11.1/056
OPTIONS=-U --replacefiles --force --nodeps
EULA=accept
ECL_DISCLAIMER=accept
NON_SUPPORTED_OS_INSTALL=Yes
REPLACE_EXISTING_INSTALLATION=Yes
-------------------------------------------------------------
I have libstdc++5- 32 bit installed.
I am trying to install from l_cprof_p_11.1.056_intel64 version.

Can you suggest how the silent file can be modified in my case?
Thanks
dhiraj

Ronald W Green (Intel)'s picture

Quoting - dhirajhazra
I am facing the same problem in mandriva.Please see my post
http://software.intel.com/en-us/forums/showthread.php?t=69071

I am not abkle to implement the silent procedure in mandriva 64 bit.
I run
./install.sh -n -run --silent sil.txt
Where sil.txt is a text file containing
------------------------------------------------------------
[ifort11-intel64]
INSTALLDIR=/opt/intel/Compiler/11.1/056
OPTIONS=-U --replacefiles --force --nodeps
EULA=accept
ECL_DISCLAIMER=accept
NON_SUPPORTED_OS_INSTALL=Yes
REPLACE_EXISTING_INSTALLATION=Yes
-------------------------------------------------------------
I have libstdc++5- 32 bit installed.
I am trying to install from l_cprof_p_11.1.056_intel64 version.

Can you suggest how the silent file can be modified in my case?
Thanks
dhiraj

remove the first line "[ifort11-intel64]"

and try non-rpm, add this

INSTALL_MODE=NONRPM

And you are using a root window to do this. Do not use sudo unless you do

sudo bash

to get a full root shell.

ron

Quoting - Ronald W. Green (Intel)

remove the first line "[ifort11-intel64]"

and try non-rpm, add this

INSTALL_MODE=NONRPM

And you are using a root window to do this. Do not use sudo unless you do

sudo bash

to get a full root shell.

ron

Thanks for the reply.I thought -n takes care of the non-rpm installation.Anyway after running ./install.sh -n -run --silent sil.ini
I am having
Name "INSTALLDIR" is not valid
Name "OPTIONS" is not valid
Name "EULA" is not valid
Name "ECL_DISCLAIMER" is not valid
Name "NON_SUPPORTED_OS_INSTALL" is not valid
Name "REPLACE_EXISTING_INSTALLATION" is not valid

I have sil.ini containing
INSTALLDIR=/opt/intel/Compiler/11.1/056
OPTIONS=-U --replacefiles --force --nodeps
EULA=accept
ECL_DISCLAIMER=accept
NON_SUPPORTED_OS_INSTALL=Yes
REPLACE_EXISTING_INSTALLATION=Yes
INSTALL_MODE=NONRPM
Thanks
dhiraj

Quoting - Ronald W. Green (Intel)

remove the first line "[ifort11-intel64]"

and try non-rpm, add this

INSTALL_MODE=NONRPM

And you are using a root window to do this. Do not use sudo unless you do

sudo bash

to get a full root shell.

ron

Sorry.I finally got it.I could at least install the compiler.With rpm it could install.In ~/.bashrc what should I give as source?
source /opt/intel/Compiler/11.1/056/bin/intel64/ifortvars_intel64.sh
or
source /opt/intel/Compiler/11.1/056/bin/ifortvars.sh

I am alittle confused about that.
Thanks
dhiraj

Quoting - Ronald W. Green (Intel)

remove the first line "[ifort11-intel64]"

and try non-rpm, add this

INSTALL_MODE=NONRPM

And you are using a root window to do this. Do not use sudo unless you do

sudo bash

to get a full root shell.

ron

Thanks Ronald
your post http://software.intel.com/en-us/articles/intel-compilers-for-linux-versi...
really woks for me.
I have used in bashrc source /opt/intel/Compiler/11.1/056/bin/intel64/ifortvars_intel64.sh
It works
Only one question.
For 64 bit ifort at the time of compilation it is printed on screen that the loops (used in the program) are vectorized but now I am not getting that.It silently compiles.Should I worry about that?
Thanks
dhiraj

Quoting - dhirajhazra

For 64 bit ifort at the time of compilation it is printed on screen that the loops (used in the program) are vectorized but now I am not getting that.It silently compiles.Should I worry about that?

The default setting for -vec-report was changed, so you must set -vec-report in order to get the previous behavior.

Quoting - tim18

The default setting for -vec-report was changed, so you must set -vec-report in order to get the previous behavior.

Thanks,I got it.It works.
Thank you for giving attention to my post in the mandriva forum too.
dhiraj

Quoting - dhirajhazra
Thanks,I got it.It works.
Thank you for giving attention to my post in the mandriva forum too.
dhiraj

I also face the same proble.
I run "./install.sh -s sil.txt"

The sil.txt is a text file containing :
------------------------------------------------------------
INSTALLDIR=/opt/intel/Compiler/11.1/056
OPTIONS=-U --replacefiles --force --nodeps
EULA=accept
ECL_DISCLAIMER=accept
NON_SUPPORTED_OS_INSTALL=Yes
REPLACE_EXISTING_INSTALLATION=Yes
INSTALL_MODE=NONRPM
------------------------------------------------------------
A new error existed:
"You should accept license for installing the product. Please correct accept-EULA variable in silent configuration file."

My linux system is Fedora 11.0; My question is wheather the content of sil.txt is different with the system.
What can I do to install ifort continually?

Thank you very much!

I also meetthese problems which are similar to what you said!You can change anothe version which are suit for your system.And I think Ifort11 is so new that I cannot recognize its library Our cluster use ifort8 since 2005,it is a perfect complier and give us lots of useful data !

Quoting - zhangwei818800

I also meetthese problems which are similar to what you said!You can change anothe version which are suit for your system.And I think Ifort11 is so new that I cannot recognize its library Our cluster use ifort8 since 2005,it is a perfect complier and give us lots of useful data !

I try to install ifort8.0, but there are still many libraries missing. My system is fedora 11.0

Steve Lionel (Intel)'s picture

Quoting - lele1026

I try to install ifort8.0, but there are still many libraries missing. My system is fedora 11.0

Your post here is not relevant to the topic. I'll respond to your other post.

Steve

Quoting - dhirajhazra
I am facing the same problem in mandriva.Please see my post
http://software.intel.com/en-us/forums/showthread.php?t=69071

I am not abkle to implement the silent procedure in mandriva 64 bit.
I run
./install.sh -n -run --silent sil.txt
Where sil.txt is a text file containing
------------------------------------------------------------
[ifort11-intel64]
INSTALLDIR=/opt/intel/Compiler/11.1/056
OPTIONS=-U --replacefiles --force --nodeps
EULA=accept
ECL_DISCLAIMER=accept
NON_SUPPORTED_OS_INSTALL=Yes
REPLACE_EXISTING_INSTALLATION=Yes
-------------------------------------------------------------
I have libstdc++5- 32 bit installed.
I am trying to install from l_cprof_p_11.1.056_intel64 version.

Can you suggest how the silent file can be modified in my case?
Thanks
dhiraj

Quoting - Ronald W. Green (Intel)

Quoting - dhirajhazra
I am facing the same problem in mandriva.Please see my post
http://software.intel.com/en-us/forums/showthread.php?t=69071

I am not abkle to implement the silent procedure in mandriva 64 bit.
I run
./install.sh -n -run --silent sil.txt
Where sil.txt is a text file containing
------------------------------------------------------------
[ifort11-intel64]
INSTALLDIR=/opt/intel/Compiler/11.1/056
OPTIONS=-U --replacefiles --force --nodeps
EULA=accept
ECL_DISCLAIMER=accept
NON_SUPPORTED_OS_INSTALL=Yes
REPLACE_EXISTING_INSTALLATION=Yes
-------------------------------------------------------------
I have libstdc++5- 32 bit installed.
I am trying to install from l_cprof_p_11.1.056_intel64 version.

Can you suggest how the silent file can be modified in my case?
Thanks
dhiraj

remove the first line "[ifort11-intel64]"

and try non-rpm, add this

INSTALL_MODE=NONRPM

And you are using a root window to do this. Do not use sudo unless you do

sudo bash

to get a full root shell.

ron

Hi Ronald

What do you suggest me to change in the silent ini script to accept an activation code instead of an existing license...?

I am trying to install icc, ifort and mkl on Slackware64 13...

BRGDS

Alex

Ronald W Green (Intel)'s picture

As you probably read in the silent installation guide:

http://software.intel.com/en-us/articles/intel-compilers-for-linux-version-111-silent-installation-guide/

There is no other option on ACTIVATION other than ACTIVATION=exist_lic. So you must register your product and get your license. Go to https://registrationcenter.intel.com and register that serial number to your name/account and then you can get your license file.

I haven't used Slackware in a very long time. But like the other Linux distributions, you need gcc, g++, and the older compatibility library libstdc++.so.5 - and if you have a 64bit version of Slackware, you need this in BOTH 32bit and 64bit versions - both on your system, and then you should be able to install.

ron

Login to leave a comment.