WRFV3 compile fails with Composer XE on Ubuntu linux 10.04

WRFV3 compile fails with Composer XE on Ubuntu linux 10.04

Hello-

I hope this is the correct forum. The problem seems to be with establishing the correct environment prior to compiling wrf.

system is ubuntu linux 2.6.32-33-server x86_64 (10.04 LTS)
Composer XE 12.0.5.220
installed prereqs per intel notes for 10.04 (except no libstdc++5) also installed m4
gcc and g++ compile simple code
intel composer XE (ifort,icc,icpc)installed per install notes
netcdf 3.6.3 compiled from source using intel compilers (static) "make check" good. Installed in /usr/local/netcdf via symlink from /usr/local/netcdf_3.6.3 with links frrom there to /usr/local/lib /usr/local/bin /usr/local/include.
environment variables for CC, FC, etc. set per intel notes at terminal (bash)
also set $JASPERLIB and edited $CPATH to include INSTALL_DIR/compiler/include

Configure WRF serial ifort and icc.
configure does not recognize $JASPERLIB.

compile em_real
initially I got an error for no target to make io_int.F90 this is because files in $(WRF_ROOT)/external/io_int have .f90 suffixes.
I edited the makefile in io_int to target .f90 files.

I then started to get the "diffwrf" warnings and errors compiling field_routines.f. (I noticed that cpp is being used instead of "icc -E")
Which leads to a failure to create libwrfio_nf.a and ultimately compile fails.

I know Ubuntu is a little squirrely about setting LD_LIBRARY_PATH when opening a terminal via .profile or .bashrc but I set all the environment variables by running compilervars.sh and "export VAR=value" after logging in.

I have searched the boards found the CPATH thing when searching include path. Any thoughts?

thank you

-
Karl

There should be 3 files attached.

or see these links
env.txt http://software.intel.com/file/38265
configure.wrfhttp://software.intel.com/file/38266
em_real.log http://software.intel.com/file/38264

AttachmentSize
Download em_real.log354.14 KB
Download env.txt8.62 KB
Download configure.wrf0 bytes
3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Steve Lionel (Intel)'s picture
Steve

I made four changes and it worked

Added -xT to CFLAGS, CXXFLAGS and FFLAGS
Added /usr/local/include to INCLUDE
Added JASPERINC=/usr/inlcude
changed LD_LIBRARY_PATH to include /usr/local/lib

compiles.

Login to leave a comment.