[HELP] MPICH with windows XP??

[HELP] MPICH with windows XP??

Hello there,
I would like to run my program from DOS console (windows xp).
I'm facing some trouble, cos MPIRUN is not recognized by the system,
so i have to move into the MPI directory C:program_filesMPICHmpdinmpirun.exe
However, my own program and datas are located in a different folder :
C:documents and settingsmdiarra2mathsTestsNew_project.exe

Can someone help?? (if you are in habit of using mpich with ms-dos :-) )

i tried the folowing commands without any success: (it's for single cpu machine)
==> C:program_filesMPICHmpdinmpirun.exe -np 2 -localonly C:documents and settingsmdiarra2mathsTestsNew_project.exe

==> C:program_filesMPICHmpdinmpirun.exe -np 2 -localonly -dir C:documents and settingsmdiarra2mathsTestsNew_project.exe

==> C:program_filesMPICHmpdinmpirun.exe -np 2 -localonly -dir drive:C:documents and settingsmdiarra2mathsTestsNew_project.exe

==> C:program_filesMPICHmpdinmpirun.exe -np 2 C:documents and settingsmdiarra2mathsTestsNew_project.exe

Thanks in advance
Regards

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Looks like you need to add C:program_filesMPICHmpdin to the PATH environment variable

Start | Control Panel | Performance and Maintenence | System | Advanced | Environment Variables

In the System variables window scroll until you see "Path", click on it then Edit.

Click in the edit window, then Press "End" key to go to end of line. Add a semicolon ";" (no quotes) then add "C:Program FilesMPICHmpdin" (wherever mpirun.exe is located).

Then OK out of edit session.

Note, the new PATH will be active the Next time you open a command window.

Now you will not have to copy the files to this directory.

Jim Dempsey

www.quickthreadprogramming.com

Than you Jim, it works well...

just another question, if you have some knowledge about ports

i'm facing trouble when i ran my program:

mpirun -np 2 -localonly test.exe
(then i get the following messages:)
Error 10061, process 0, host PCWINNT:
Unable to connect to PCWINNT on port 3425
Error 10061, process 1, host PCWINNT:
Unable to connect to PCWINNT on port 3425

Port number is different from two successive commands.....
with or without -localonly option, the result remains the same: (unable to connect......)

PS: The program is to be executed on my laptop (One CPU only)

Thanks

Hi there,
i fixed my problem after turning off all firewall settings in both Norton and Windows
(my ethernet cable is now unplugged when running my progs)

Leave a Comment

Please sign in to add a comment. Not a member? Join today