lightweight hotspots launching problem

lightweight hotspots launching problem

Pavel Mezentsev's picture

I need to measure the amount of AVX instructions my application executes. I modified the lightweight hotspots profile and added the necessary counters in it. However I experience several problems: 1. When I try to launch the profiling process from vtune gui I get the error "error collection failed the data cannot be displayed". Other types of analysis work from gui. If I attempt to launch the process again I get the message that "Sampling session is already in progress" which I can solve only by reloading the kernel modules. I'm able to complete the lighweight hotspots analysis successfully if I launch the process from the cli with the command that I copy from gui. And what's more interesting after that successful attempt from cli the gui starts to work properly, so I can perform other sessions from it. These problems are inconvenient but more or less solvable. 2. Another problem is that I am able get the data form a launch with small configuration which takes about 10 minutes to finish. But when I change the application's parameters to perform a 50 minutes run then at the end I get "error collection failed the data cannot be displayed" both from gui and cli. My configuration: CentOS 6.2 kernel 2.6.32-220.4.1 vTune amplifier XE 2013(build 230230) 2 e5-2690 processors + 128 GB RAM. I'll try to provide any additional information which may be needed.

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Peter Wang (Intel)'s picture

1. That was very strange - lightweight-hotspots worked on CLI, but not work from GUI. Was it possible that some GUI components didnit exitfrom previousrunning? I guess that you may kill some processes or reboot the system.

2. You may select item "Between 15 minutes and 3 hours" for "Duration time estimate", 500 for"Collection data limit, MB"from GUI - project properties, or add these options in CLI
"-target-duration-type=medium -data-limit=500"
If your met error again, please run "amplxe-feedback -create-bug-report " and attach log-file for further investigating. Thank you!

Regards, Peter

Login to leave a comment.