problem C++ with netcdf and openmpi

problem C++ with netcdf and openmpi

Dear all,

my computer: Fedora 17, intel compiler: l_fcompxe_intel64_2011.10.319 and l_ccompxe_intel64_2011.10.319. however when i start to install intel compiler i have skipped an error: unsupported OS. But, everything is okei for installing hdf5 library, or zlib with command line: CC=icc, CXX=icpc....

For installing of Netcdf1.4.3 i have trouble when i carry out "./configure" as follow:

checking whether the C compiler works... no
configure: error: in `/home/thanhnt/netcdf-4.1.3':
configure: error: C compiler cannot create executables
See `config.log' for more details

for OpenMPI: error when i "make check",

openmpi [predefined_gap_test] Error 1

but ./configure CC=icc, CXX=icpc.... are okei,

can you tell me why, please?

thanks a lot
thanhwru83@gmail.com

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

You'd have to show us the compile failure referred to in config.log. If your gcc is 4.7 or higher, you'd need Intel C++ 2013 (currently a beta test) in order for icpc to work. A netcdf build with ifort and gcc/g++ ought to work.
Your message is confusing. After reading it 3 times, I think you may be saying you were able to build hdf5 and netcdf, but not OpenMPI. That would take us back to the questions about OpenMPI, and the impossibility of supporting mpiCC with an older version of icpc when the latest g++ is active.

but ./configure CC=icc, CXX=icpc.... are okei,

can you tell me why, please?

Hi,
So when we want to build any application/source using Intel compiler "icc" then we need to set the compiler (Using source) and also if the build system of that application use "configure" we can check how to set the compiler by using "./configure --help" and if we have "CC and CXX" env variables to be set to use other compilers than the default(may be gcc), then we need to set it as you have done "./configure CC=icc CXX=icpc" or "export CC=icc" and export CXX=icpc. This is the reason you can see,"./configure" is working fine after setting "CC and CXX". Also as Timsaid, the F17 uses the gcc 4.7 version which iscompatible in the next release of Intel compiler.

Hope i have answered your question. If not please do let me know and i would be happy to help you further.

Thanks & Regards,
Sukruth H.V

Dear all,

it is maybe so difficult to explain while i have to write short section.now i summanize as follow (maybe longer):

my desktop configure: Intel core i7-2600; CPU@3.4GHz, speed: 1.6MHz; core: 8, Ram: 16GiB; 2 hard disks: 2TiB and 235Gib

step 1: i need to install any fedora version on the whole hard disk of 2TiB.
step 2: i need to install intel compiler (any version)
step 3: i need to install zlib library, hdf5, netcdf, openMPI on this hard disk
step 4: .....

but now i have to stop in step 3. But i solved step by step as follow:

to solve step 1, i have to install fedora 17 X86_64, because i tried many diffirent versions of fedora (10, 11, 12, 13, 14, 15, 16) but not successful.

however, when i move step 2, and to do it. I used l_ccompxe_intel64_2011.10.319 and l_fcompxe_intel64_2011.10.319, but i have to skip the first option:

Missing optional pre-requisites
-- unsupported OS
--------------------------------------------------------------------------------
1. Skip missing optional pre-requisites [default]
2. Show the detailed info about issue(s)
3. Re-check the pre-requisites

h. Help
b. Back to the previous menu
q. Quit

With hoping to succeed.and everything is okei.

To move step 3: i have succeeded with installation of zlib library, hdf5 with command line: ./configure CC=icc, CXX=icpc, FC=ifort (that meaning, the system still recognize icc and icpc replace for GCC and G++)

however, when i install netcdf, i have trouble as follow:

checking whether the C compiler works... no
configure: error: in `/home/thanhnt/netcdf-4.1.3':
configure: error: C compiler cannot create executables
See `config.log' for more details

For OpenMPI: if i use older version of 1.5, i have also trouble some errors. But if i use version 1.5 or 1.6 i can configure with the command line ./configure CC=icc, CXX=icpc, FC=ifort and only stop this step, because when i use: "make check" command line i will have troube as i mention as above.

i reall need to advance from you, because it is neccessary for me to do some other things in this month.

if you have any other advances, please tell me.

thanks a lot from your feedback.

thanhwru83@gmail.com

i attached file config.log of NetCDF.

dear all,

i have just succeeded with the instalation of netcdf, but for openMpi, i have still trouble some errors when i carry out "make check" as follow:

libtool: link: cannot find the library `../../ompi/libmpi.la' or unhandled argument `../../ompi/libmpi.la'
make[3]: *** [predefined_gap_test] Error 1
make[3]: Leaving directory `/home/thanhnt/openmpi-1.6/ompi/debuggers'
make[2]: *** [check-am] Error 2
make[2]: Leaving directory `/home/thanhnt/openmpi-1.6/ompi/debuggers'
make[1]: *** [check-recursive] Error 1
make[1]: Leaving directory `/home/thanhnt/openmpi-1.6/ompi'
make: *** [check-recursive] Error 1
[thanhnt@hywa178 openmpi-1.6]$

thanks a lot

Posting here will not save you the time you need to spend studying FAQs on the OpenMPI site and looking for the first failure point in your build.

Leave a Comment

Please sign in to add a comment. Not a member? Join today