Unable to collect hotspot result, vtune quit profiling too quick

Unable to collect hotspot result, vtune quit profiling too quick

Hi Guys,
I am trying to use Vtune to profile the hotspot of my application, by using the following command:

lscse23339:fxbuild% /home/fxdev/apps/intel/c_studio_xe_2011_sp1_update2/vtune_amplifier_xe_2011/bin64/amplxe-cl -collect hotspots -duration 360 -r /tmp/gw_hotspot_1 /export/work/fxbuild/panther/banafix_dev/install/bin/bana_fix_gateway --identifier=DEV-BANAFIX0 --daemon=yes

and getting the messages below :

Target process's profiling finished but the following processes are still being profiled:
PPID PID STATE NAME
007311 007374 RESUME bana_fix_gateway

You may stop collection manually. The processes listed above will be terminated.
Warning: Symbol file is not found. The call stack passing through the module /home/fxdev/apps/Sybase15.0.2/OCS-15_0/lib/libsybcomn_r.so may be incorrect
Warning: Symbol file is not found. The call stack passing through the module /home/fxdev/apps/Sybase15.0.2/OCS-15_0/lib/libsybcs_r.so may be incorrect
Warning: Symbol file is not found. The call stack passing through the module /home/fxdev/apps/Sybase15.0.2/OCS-15_0/lib/libsybtcl_r.so may be incorrect
Warning: Symbol file is not found. The call stack passing through the module /home/fxdev/apps/Sybase15.0.2/OCS-15_0/lib/libsybct_r.so may be incorrect
Warning: Symbol file is not found. The call stack passing through the module /home/fxdev/apps/tibrv8.3.1-hf1/lib/libtibrv.so may be incorrect
Warning: Symbol file is not found. The call stack passing through the module /lib/libnss_vas3.so.2 may be incorrect
Warning: Symbol file is not found. The call stack passing through the module /lib/libdl-2.5.so may be incorrect
Target process's profiling finished but the following processes are still being profiled:
PPID PID STATE NAME
007374 007380 RESUME bana_fix_gateway

You may stop collection manually. The processes listed above will be terminated.
Warning: Symbol file is not found. The call stack passing through the module [stack] may be incorrect

It seems the Vtune quit profiling after 10 seconds, as you can see, I specified the duration as 360 secs, do you have any ideas?

By the way, here is the Vtune info :
(build 206420) Copyright 2009-2011 Intel Corporation. All rights reserved.

and I am running it in redhat linux:

Linux lscse23339 2.6.18-194.3.1.el5 #1 SMP Sun May 2 04:17:42 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux

Thanks
Drooy

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Drooy,

Here are my tips:
1.Use "source vtune_amplifier_xe_2013/amplxe-vars.sh", you don't need to have long path to run amplxe-cl

2. Your process ran shortly, may fork other process(es) named "bana_fix_gateway". However hotspots collecter found that launched process was terminated, so stop the data collection. My suggestion is to manually launch your application, then use attach-to-process to monitor your interest of process.
For example:

amplxe-cl -collecthotspots -duration360 -target-pid pid

3. If your target process is running on system mode, please use:
amplxe-cl -collectlightweight-hotspots -duration360 -target-pid pid

Hope it helps.

Regards, Peter

Login to leave a comment.