getting to the Source Code pane

getting to the Source Code pane

On page 26 of the Intel VTUNE AMPLIFIER Tutorial it talks about getting to view the source code.
It says to enable the source pane "make sure to build the target properly".

I am unsure as to what thta means. I built my source and I only got the assembly. The options I used when compiling were

-pg -g

.

These options are what I use when I want touse the gprof debugger. What do I have to do to build the target properly in Intel VTUNE AMPLIFIER.

Any help appreciated. Thanks in advance.

Newport_j

5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Assume that you collected data smoothly...
If you moved result directory to other place, orchanged source/binary directories, use amplxe-gui to open result. Then click on "Analysis Type" tab -> click on "Project Properties" button to pop up a dialog -> click on "Search Directories" to add paths for source files and binary files -> close the dialog -> click on "Re-resolve" button to do finalizing again.

Youcan display source after doing above.

Regards, Peter

I have the source and the executable in the same directory. That is

/home/james/Desktop/WEGtest

Now that isalso where the symbol file is.

Also, I noticed that when I used the compiler option

gcc -g

that the resulting executable file was now much bigger. The executable must bundle with the symbol file.
When I am saying executable then I am also saying binary. I just put all of those in one directory and when
I am at the Analysis Type taband thenI click on the Project Properties, I reach a windows for Search directories and I put i it:

/home/james/Desktop/WEGtest

for each:
source
binary
symbol
and all.

This workson other tests programs. (It took some time to get it to do sothough). It does not work on my main many functi0on program.

Any help appreciated. Thanks in advance.

Newport_j

Interesting!

If this is your big executable specific issue, my opinion is to visit https://premier.intel.comto submit a ticket with VTune Amplifier XE results, binary, associate source (you want to display functions)

Regards, Peter

This is not an executable issue. The executable is fine. I just cannot associate the executable with my source code. It just does not work.

It does work with the VTUNE examples.

I just started a new thread on it. i need to fix it.

Newport_j

Leave a Comment

Please sign in to add a comment. Not a member? Join today