OMP: Error #15: Initializing libiomp5mt.lib, but found libiomp5mt.lib already initialized.

OMP: Error #15: Initializing libiomp5mt.lib, but found libiomp5mt.lib already initialized.

Dear Forum users,I'm using Pardiso from MKL on Windows. Since I updated to the most up to date version, I'm receiving the following error message.OMP: Error #15: Initializing libiomp5mt.lib, but found libiomp5mt.lib already initialized.OMP: Hint: This may cause performance degradation and correctness issues. Set environment variable KMP_DUPLICATE_LIB_OK=TRUE to ignore this ....My program terminates with this error message. Interestingly, it does not happen with every call to Pardiso. Sometimes it will just work.I thought this problem might be caused by static linking, so I switched to dynamic linking (DLLs), but this did not solve the problem.I would be grateful for any hint.Regards, Alex

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Alex, please see this article. Is that your case?

Dear Gennady,many thanks for your answer. This is not my case. My application links againstlibiomp5md.libmkl_intel_c_dll.libmkl_intel_thread_dll.libmkl_core_dll.libMy application containts two custom DLLs, one depending on another, which both link againstlibiomp5md.lib. Is this a problem?Alex

It's a problem if libiomp5mt.lib is also linked in, as your error message indicates. Nowhere should there be a reference to libiomp5mt (or openmplink:static), as presence of both creates the situation referred to in the message.

Leave a Comment

Please sign in to add a comment. Not a member? Join today