using VTUNE command line

using VTUNE command line

When i tried the command line ooption on the current version of the INTEL VTUNE AMPLIFIER, the output is now shown:

amplxe-cl -collect hotspots -follow-child -mrte-mode=auto -target-duration-type=short -no-allow-multiple-runs -no-analyze-system -data-limit=100 -slow-frames-threshold=40 -fast-frames-threshold=100 -- /home/james/Desktop/tachyon/tachyon_find_hotspots /home/james/Desktop/tachyon/dat/balls.dat

amplxe-cl: command not found

james@james-Precision-WorkStation-T7500:/opt/intel/vtune_amplifier_xe_2011/bin32$ ./amplxe-cl -collect hotspots -follow-child -mrte-mode=auto -target-duration-type=short -no-allow-multiple-runs -no-analyze-system -data-limit=100 -slow-frames-threshold=40 -fast-frames-threshold=100 -- /home/james/Desktop/tachyon/tachyon_find_hotspots /home/james/Desktop/tachyon/dat/balls.dat

Fatal error: Cannot start collection: failed to create result directory. : No permission

james@james-Precision-WorkStation-T7500:/opt/intel/vtune_amplifier_xe_2011/bin32$ sudo ./amplxe-cl -collect hotspots -follow-child -mrte-mode=auto -target-duration-type=short -no-allow-multiple-runs -no-analyze-system -data-limit=100 -slow-frames-threshold=40 -fast-frames-threshold=100 -- /home/james/Desktop/tachyon/tachyon_find_hotspots /home/james/Desktop/tachyon/dat/balls.dat

/home/james/Desktop/tachyon/tachyon_find_hotspots: error while loading shared libraries: libtbb.so.2: cannot open shared object file: No such file or directory

Using result path `/opt/intel/vtune_amplifier_xe_2011/bin32/r002hs'

Executing actions 50 % done

Error: Error 0x4000001d (Cannot find raw collector data) -- Cannot re-finalize the result: it has no raw collector data.

james@james-Precision-WorkStation-T7500:/opt/intel/vtune_amplifier_xe_2011/bin32$ $PATH

bash: home/james/Desktop/tachyon/tbbforexamples/2.2/ia32/cc4.1.0_libc2.4_kernel2.6.16.21/lib:/opt/pgi/linux86/11.7/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games: No such file or directory

james@james-Precision-WorkStation-T7500:/opt/intel/vtune_amplifier_xe_2011/bin32$

At first I had to help it find amplxe-cl by adding ./ in front of amplxe-cl. Then it saidI lacked permission so I used

sudo as my first command and added the password when it was asked for and I got thenext output.

I added a path to find

libtbb.so.2

There were several libtbb.so.2files, I used the latest version.

It still did not like it.

Whsat is wrong now. I thought that all it needed to do was find the file

libtbb.so.2

and everything would be okay. But it did not compile. It did compile using the GUI howver. As was shown in the tutorial.

What must I change to get it to compile?

Any help appreciated.

Newport_j

11 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Typically, the application install directory is not used as the current directory. The result files are written to the current directory (which is why it gave you the permission error).

Try running from a user-writable directory, and source the 'amplxe-var.sh' to get the appropriate path added so you can use amplxe-cl (or refer to it using the full path).

Alternately, there are a couple of other options for controlling where the results are written:
-r (-result-dir) - specifies where the results should be written
-user-data-dir - specifies a directory where results should be written
Use either option to point to a user-writable directory.

That makes sense (use the source command) except for the program still may not find the libary file

libtbb.so.2

I may have to help it find that file. Thequestion then is:

1. Which libtbb.so.2 file do I direct it to - there are several on the hardrive?

2. I should never have to mess with the LD_LIBARY_PATH since that is one parameter that I must
not alter. So I have been taught.It can be done, but in most cases (is this one?) that should not be required.

Any help appreciated. Thanks in advance.

Newport_j

I got the example tachyon to work on both the gui and the command line. Whenever, I tried to run my example of the amplxe-gui I got a collection failed error.

So I compared my command line source file on my program which does not work with the example which did work. I will show the command line source file for the tachyon example:

/opt/intel/vtune_amplifier_xe_2011/bin32/amplxe-cl -collect hotspots -follow-child -mrte-mode=auto -target-duration-type=short -no-allow-multiple-runs -no-analyze-system -data-limit=100 -slow-frames-threshold=40 -fast-frames-threshold=100 --
/home/james/Desktop/tachyon/tachyon_find_hotspots /home/james/Desktop/tachyon/dat/balls.dat

Now my command line source file had double quotes around the last line where the path and the name of the program something like

"home/james/Desktop/WEGtest/grab_cpu"

and the program crashed with an error:

Error: Binary file of the analysis target cannot be found. Please specify another path and try again.

Now when I take the quotes out the program ran perfectly from the command line giving me all the info that I needed.

The question Ineed answered is howdid my program and not the example get quotes there in the first place? It seems they are not needed and whatever software option put them there is not workng properly.

Please rember that the source file is generated from the guiwith the path to amplxe-guiadded and all is put into a file with the whole thing sourced.

Again, how did those quotes get there?

Any help appreciated. Thanks in advance.

Newport_j

I assume you mean the quotes are coming after clicking the "Comand Line" button in the GUI.

The quotes are generated in cases there are special characters found that need escaping from the shell (spaces, etc). Although I don't see any of them in the sample you gave, so I don't why the quotes are being put there.

I do not know how to post screenshots on this forum so I cannot show you want i am talking about. I will show you my command file from the clickng the command line button in the GUI.

Anyway here is trhe command line for my program thta I wish to analyze

amplxe-cl -collect hotspots -follow-child -mrte-mode=auto -target-duration-type=short -no-allow-multiple-runs -no-analyze-system -data-limit=100 -slow-frames-threshold=40 -fast-frames-threshold=100 -- "/home/james/Desktop/WEGtest/grab_cpu " /home/james/Desktop/WEGtest/0 4

Now of course to run this I have to put it in a file and add apath at the beggining. The program will crash saying it cannot find the binary executableplease check the path or adda new path. If the quotes or taken out from the last line from

"/home/james/Desktop/WEGtest/grab_cpu " /home/james/Desktop/WEGtest/0 4

to

/home/james/Desktop/WEGtest/grab_cpu /home/james/Desktop/WEGtest/0 4

The prgram runs!

Becuase of these quotesI believe that the program crashes. Now how did the quotes get there?

In the example that I did in the tutorial the quotes are not there. So what did I do to accidentally to put them there or how do I get them out when using the gui?

This limits my use of INTEL VTUNE to the command line and not the gui.

As you can see from my discusion, I can only run my analysis from the command line which I get wihile using the gui as you assumed. That does not have the covenience of using the gui with project files and all asI discuss in another post on this forum.

I believe that ifI can get the quotes out of thegui as shown abovethen I can run this as a project and not be restricted to using the command line only. It lacks the projects convenience.

Any help appreciated. Thanks in advance.

Newport_j

You probably have spaces after 'grab_cpu' in the GUI. Try removing them.

Hi,

When I am trying to run the VTune in cl mode I receive the following error. Do you know how I can fix it?

jalal@mona:/research/jalal/profiler/tachyon$ amplxe-cl -collect hotspots -result-dir outdir -- tachyon_find_hotspots dat/balls.dat
amplxe: Error: Binary `tachyon_find_hotspots' cannot be executed. Suggestion: Make sure the file exists, specified location is correct, and you have privileges to run the file.

P.S.: The binary exists in the same folder.

Thanks,

Mona Jalal.

Peter Wang (Intel)'s picture

Quote:

Mona J. wrote:

Hi,

When I am trying to run the VTune in cl mode I receive the following error. Do you know how I can fix it?

jalal@mona:/research/jalal/profiler/tachyon$ amplxe-cl -collect hotspots -result-dir outdir -- tachyon_find_hotspots dat/balls.dat
amplxe: Error: Binary `tachyon_find_hotspots' cannot be executed. Suggestion: Make sure the file exists, specified location is correct, and you have privileges to run the file.

P.S.: The binary exists in the same folder.

Thanks,

Mona Jalal.

You need to specify "./tachyon_find_hotspots" in command - if use same folder.

Hi Peter,

Unfortunately I lost my post and couldn't track it back. Anyway I ran it like you mentioned after setting to 0 but I have no idea where result is saved in tachyon_test result directory (also I am not sure if these warnings I am receiving are serious or not? )

jalal@mona:/research/jalal/profiler/tachyon$ cat /proc/sys/kernel/yama/ptrace_scope
1
jalal@mona:/research/jalal/profiler/tachyon$ echo 0|sudo tee /proc/sys/kernel/yama/ptrace_scope
[sudo] password for jalal:
0
jalal@mona:/research/jalal/profiler/tachyon$ cat /proc/sys/kernel/yama/ptrace_scope
0
jalal@mona:/research/jalal/profiler/tachyon$ /opt/intel/vtune_amplifier_xe_2013/bin64/amplxe-cl -collect hotspots -result-dir tachyon_out ./tachyon_find_hotspots dat/balls.dat
amplxe: Fatal error: The specified result directory already contains result data. Provide another result directory.
jalal@mona:/research/jalal/profiler/tachyon$ /opt/intel/vtune_amplifier_xe_2013/bin64/amplxe-cl -collect hotspots -result-dir tachyon_out ./tachyon_find_hotspots dat/balls.dat
amplxe: Fatal error: The specified result directory already contains result data. Provide another result directory.
jalal@mona:/research/jalal/profiler/tachyon$ /opt/intel/vtune_amplifier_xe_2013/bin64/amplxe-cl -collect hotspots -result-dir tachyon_test ./tachyon_find_hotspots dat/balls.dat
Note: using X11 shared memory with default visual for 24-bit color depth
Scene contains 7386 bounded objects.

CPU Time: 22.079 seconds.
amplxe: Using result path `/research/jalal/profiler/tachyon/tachyon_test'
amplxe: Executing actions 16 % Resolving information for `libX11.so.6.3.0'
amplxe: Warning: Cannot match file `/usr/lib/x86_64-linux-gnu/libX11.so.6.3.0': checksum mismatch.
amplxe: Warning: Cannot locate symbols for file `/usr/lib/x86_64-linux-gnu/libX11.so.6.3.0'.
amplxe: Executing actions 16 % Resolving information for `libc-2.17.so'
amplxe: Warning: Cannot match file `/lib/x86_64-linux-gnu/libc-2.17.so': checksum mismatch.
amplxe: Warning: Cannot locate symbols for file `/lib/x86_64-linux-gnu/libc-2.17.so'.
amplxe: Executing actions 17 % Resolving information for `libXext.so.6.4.0'
amplxe: Warning: Cannot match file `/usr/lib/x86_64-linux-gnu/libXext.so.6.4.0': checksum mismatch.
amplxe: Warning: Cannot locate symbols for file `/usr/lib/x86_64-linux-gnu/libXext.so.6.4.0'.
amplxe: Executing actions 17 % Resolving information for `libm-2.17.so'
amplxe: Warning: Cannot match file `/lib/x86_64-linux-gnu/libm-2.17.so': checksum mismatch.
amplxe: Warning: Cannot locate symbols for file `/lib/x86_64-linux-gnu/libm-2.17.so'.
amplxe: Executing actions 18 % Resolving information for `libxcb.so.1.1.0'
amplxe: Warning: Cannot locate symbols for file `/usr/lib/x86_64-linux-gnu/libxcb.so.1.1.0'.
amplxe: Executing actions 19 % Resolving information for `libpthread-2.17.so'
amplxe: Warning: Cannot match file `/lib/x86_64-linux-gnu/libpthread-2.17.so': checksum mismatch.
amplxe: Warning: Cannot locate symbols for file `/lib/x86_64-linux-gnu/libpthread-2.17.so'.
amplxe: Executing actions 19 % Resolving information for `libtpsstool.so'
amplxe: Warning: Cannot locate symbols for file `/opt/intel/vtune_amplifier_xe_2013/lib64/libtpsstool.so'.
amplxe: Executing actions 50 % Generating a report

Collection and Platform Info
----------------------------
Parameter tachyon_test
------------------------ --------------------------------------------------------------------------------------------------------------------------
Application Command Line ./tachyon_find_hotspots "dat/balls.dat"
Computer Name mona
Environment Variables
MPI Process Rank
Operating System 3.2.0-43-generic DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise

Basically I am not aware which of the followings are related to the results and shows which line of the code is a hotspot:

tachyon_test$ ls
archive config data.0 sqlite-db tachyon_test.amplxe

Peter Wang (Intel)'s picture

>> $ /opt/intel/vtune_amplifier_xe_2013/bin64/amplxe-cl -collect hotspots -result-dir tachyon_out ./tachyon_find_hotspots dat/balls.dat

Now you was running correct command line, and I believe that you tested "./tachyon_find_hotspots dat/balls.dat " without VTune first.

>>Fatal error: The specified result directory already contains result data. Provide another result directory.

It told you that you have to specify another result directory, for example tachyon_out_001. Or you delete prior one manually.

Login to leave a comment.