help to install TBB in visual studio 2010 with error

help to install TBB in visual studio 2010 with error

Hi All,

I am trying to run the example with tbb. I got an error :

error MSB3073: commandcopy "\\ia32\\vc8\\bin\\tbb_debug.dll" "Debug\\"

:VCEndexitedcode 1C:\\Program Files\\MSBuild\\Microsoft.Cpp\\v4.0\\Microsoft.CppCommon.targets1136 Quicksor.

In my mind ,it may be about that I can not use TBB because I am a newer of newer .
Can you show me hou to use it with my studio clearly?

Any help is highly appreciated.
Thanks.
Gao Cheng

10 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Vladimir Polin (Intel)'s picture

hello Gao Cheng,which version of tbb do you use?do you compile an example inside the package tree?Examples in latest version should work in above conditionsAlso you can try to setTBBROOT environment variable pointing to tbb installation folder.--Vladimir

>>...error MSB3073: command copy "\ia32\vc8\bin\tbb_debug.dll" "Debug" ..

VS's MsBuildattempted to execute an MS-DOS command 'copy' and itfailed because some problem:

- with the path to 'tbb_debug.dll', or
- with the path to 'Debug' folder, or
-with both.

>>...Can you show me how to use it with my studio clearly?..

Did you setup aTBB environment with VS 2010? Please take a look at "Getting Started" with TBB
pdf-document. It is enclosed.

Best regards,
Sergey

Attachments: 

AttachmentSize
Download Getting_Started.pdf95.67 KB

>>...error MSB3073: command copy "\ia32\vc8\bin\tbb_debug.dll" "Debug" ..

Hi Gao,

Finally I had some time tolook at the issue and I reproduced the sameerror with Visual Studio 2005.

It looks like you didn't compile TBB's'Debug' configurationDLL 'tbb_debug.dll'. In my environment
all paths are correct, but 'copy' command failed because it couldn't find 'tbb_debug.dll'. So, as soon as
I compiled theDLLMsBuild was able to build a TBB-based application.

Best regards,
Sergey

hello,Sergey
Thanks for your replay.
Yes , I setup a TBB environment with VS 2010,ok ,I will try ,
AndI want to ask you why whenI put my project in the 'my project',it has no error,but when I run it it say "the application failed to initialize properly oxc0150002"
Thanks for your help ,
Looking forard to your replay!

gaocheng

hello sergey
I am sorry to tell you I do not know about "compiled the DLL MsBuild was able to build a TBB-based application" and I must not do that ,I do not know how to do it , Can you tell me again?
Waiting for your replay!

gaocheng

Hi,

You need to compile TBB's mainDLLs for Debug and Release configurations. A project for Visual Studio 2005
is located at:

Note: I assume that you have version 4 of TBB

..\TBB40\Build\vsproject\tbb.vcproj

Open the project and compile Debug and Release configurations of TBB's main DLLs:

Debug : tbb_debug.dll
Release: tbb.dll

Best regards,
Sergey

>>...when I run it it say "the application failed to initialize properly oxc0150002"...

Hi Gao,

You've provided a very limited information and it is really hard to understand what is going on. It looks like the application simply can't load some DLL.

I even don't know what version of TBByou've installed. Please provide as more as possible technical details next time.

Best regards,
Sergey

Hi,I report the following error when I try to run a C++ program developed using OpenCV withMicrosoft Visual Studio 2005 Version 8.0.50727.867. How do I fix this error?The program cant start because tbb.dll is
missing from your computer. Try reinstalling the program to fix this problem.Thank you.Regards,Vishnu

Vishnu Vardhan Makkapati
Senior Scientist, Philips Research Asia - Bangalore

Philips Innovation Campus, Philips Electronics India Limited

Manyata Tech Park, Nagavara

Bangalore - 560 045, Karnataka, India
Phone: +91-80-41892241, Fax: +91-80-41892265

E-mail: vishnu.makkapati@philips.com

Intranet: pww.research.philips.com

Internet: www.research.philips.com

>>...How do I fix this error?>>The program cant start because tbb.dll is missing from your computer. Try reinstalling the program to
>>fix this problem...
Hi Vishnu,

Take a look at Post #7 for more technical details.Here is a quote:

...
You need to compile TBB's mainDLLs for Debug and Release configurations. A project for Visual
Studio 2005 is located at:

Note: I assume that you have version 4 of TBB

..\TBB40\Build\vsproject\tbb.vcproj

Open the project and compile Debug and Release configurations of TBB's main DLLs:

Debug : tbb_debug.dll
Release: tbb.dll
...

-You're trying to execute a Release version of your application andthe'tbb.dll' has to be in a
search path of the operating system ( environment variable PATH ), or put a copy to a '..\Release' folder;

- If you're trying to execute a Debug version of your application the'tbb_debug.dll' has to be in a
search path of the operating system ( environment variable PATH ), or put a copy to a '..\Debug' folder;

- Try to use MS Depends utility( enclosed ) to verifythat all dependent DLLs ( OpenCV, CRT DLLs,
etc )could be loaded, in another words, could be found by the operating system.

Best regards,
Sergey

Attachments: 

AttachmentSize
Download MsDepends.zip412.09 KB

Login to leave a comment.