"close all but this (file)" OUTSIDE an open/active project workspace

"close all but this (file)" OUTSIDE an open/active project workspace

this is a question about using the option "close all but this" OUTSIDE of a project workspace.

i have a collection of fortran 90/95 files (.f90). they are part of a project i'm working on (i.e. they are contained in a project workspace).

using Microsoft Visual Studio, there are two ways that i can edit/modify each .f90 file :-

1) INSIDE their project workspace (i.e. the project workspace is open/active)

2) OUTSIDE their project workspace (i.e. the project workspace is closed, and only the individual .f90 files are open)

consider option (2). without opening the project workspace, i can individually open up one or more of these files, and edit/modify them (using Microsoft Visual Studio). when this happens, there is a 'tab' at the top of each file -- it displays the name of each file. for example, file_1.f90, file_2.f90, file_3.f90, etc.

let's say i've got 5 such files open. when i've finished working on, say, file_4.f90, and i want to close only that file, i can do so by right-clicking the mouse on the 'tab', and selecting the option "close". the file does indeed close.

but, if instead of closing only that one file (file_4.f90), i want to instead close all but that one file. i again right-click the mouse on the 'tab', but this time i select the option "close all but this" (which appears to be available -- because, like the option "close", it isn't greyed out). but nothing happens -- all of the files still remain open.

this seems to happen only if i'm editing/modifying the files OUTSIDE of their project workspace. in other words, if i'm editing/modifying the files INSIDE their project workspace (i.e. while their project workspace is open/active), then the option "close all but this" DOES close all but that one file.

is that how it's supposed to happen ? it seems a bit strange that the option "close" DOES work (OUTSIDE of a project workspace), but the option "close all but this" DOESN'T work (OUTSIDE of a project workspace).

10 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

On the top tool bar (File, Edit, View, Tools, Window, ...) click on Window, then click on Windows. Then use:

Click (deselect all, select this)
Ctrl-Click (add toor remove from selection)
Ctrl-Shift-Click (add or remove list of files from last selection)

Jim Dempsey

www.quickthreadprogramming.com

THANKS -- your 'workaround' DOES work.

but, back to my original question :-

QUESTION 1

why is it that "close" DOES work (OUTSIDE of a project workspace), but "close all but this" DOESN'T work ?

also, another question to complement QUESTION 1.

note: in QUESTION 2 below, the term :-

a) "ISN'T greyed out" means that, when i right-click the mouse on the 'tab' at the top of each file, the desired option appears to be AVAILABLE

b) "IS greyed out" means that, when i right-click the mouse on the 'tab' at the top of each file, the desired option appears to be UNAVAILABLE

QUESTION 2

when editing/modifying files OUTSIDE of their project workspace (i.e. the project workspace is closed, and only the individual .f90 files are open) :-

1) when there is ONE OR MORE files open, then :-

a) "close" DOES work -- and "close" ISN'T greyed out

2) when there is ONLY ONE file open, then :-

a) "close" DOES work, but "close all but this" DOESN'T work -- and "close all but this" IS greyed out

3) when there is MORE THAN ONE file open, then :-

a) "close" DOES work, but "close all but this" DOESN'T work -- but "close all but this" ISN'T greyed out

My question is: in (3a),shouldn't "close all but this"be greyed out ?PS: sorry about any "mess" in the above formatting

in case it helps, here are two screenshots :-

SCREENSHOT 1 -- close all but this IS greyed out.jpg

SCREENSHOT 2 -- close all but this ISN'T greyed out.jpg

oh, and in case anyone is wondering, i've deliberately made the screen background colour GREEN -- because i was advised (years ago) that thatcolour reduces the amount of glare (and, hence, eye-strain) that can occur when the screen background colour is instead WHITE

those screenshots don't seem to have appeared. sorry -- i'm only a beginner at uploading/attaching files in this forum :(

i'll try again -- this time, by including the files as attachments

pls let me know if it works THIS time. thanks!

Attachments: 

i've followed the INSTRUCTIONS for "Attaching or Including Files in a Post". but, as you can see, i'm having difficulty including those screenshots (i said i'm only a beginner!) -- i can't see them, or download them.

so, before i AGAIN attempt to include them, could anyone answer the following questions about this :-

1) can the name of the file (or folder that contains it) contain spaces ? if not, then can it contain underscores ? the ones i tried to attach contained spaces

2) can the files be JPEG's (.jpg) ? if not, then what kind of file must they be ? the ones i tried to attach were JPEG's

3) in step 4 on the INSTRUCTIONS page, it says that, after uploading a file, "You will be shown a screen that contains a URL for the file - you can use this URL in a link in your text". Do i have to copy/paste that URL into my post myself ?

any help would be appreciated.

Spaces should work in file names, though I try to avoid them. I know spaces in folder names work. JPG files are fine. After you upload the file, you will see an "Add to editor" button at the lower left of the dialog. This is what you use to insert the image inline.

Steve - Intel Developer Support

hi steve

thanks for your reply.

about including pics in posts.

because of other commitments, i'm not doing my fortran programming (research) full-time -- it's more of a "part-time" thing. actually, sometimes i can be away from my computer for literally days at a time. because of this, i haven't had a good chance to sit down and work out why i can't include these pics in this post (either as attached files, or within the text itself).

anyway, until i CAN work out why it's not working (i.e. what i'm doing wrong), i was wondering if it would be possible for me to email YOU the 2 pics (2 JPEG's, no more than 188kb each), so that you could include the pics in this post "on my behalf"? i could give you MY email address (so you wouldn't have to display YOUR email address in this forum). maybe in a "private post". but, if you'd rather not do it that way, then that's ok.

My email address is steve.lionel at intel dot com.

Steve - Intel Developer Support

Just to close this out - the problem Bill reports can be seen in VS2008, but not VS2010. If you have open files that are not in a project, VS2008 (and probably VS2005 though I did not test that) will not give you the "Close all but this" option. If this option is important to you, then you may want to upgrade to VS2010. The problem is in Microsoft code.

Steve - Intel Developer Support

Leave a Comment

Please sign in to add a comment. Not a member? Join today