multi-file optimization compilation error

multi-file optimization compilation error

Hi,
I'm trying to build a solution with Intel Visual Fortran and I receive the following linking error:Link: error #10014: problem during multi-file optimization compilation (code -1073741819)I'm using a windows 7 64 bits machine, Intel processor.When I turn off the optimization process by typing /qnoipo in the command line of the linker I still have this error, and when I select 'no' in the interprocedural optimization there is also an error because it puts the /qnoipo command in the middle of the list of commands.Can you help me please?If you need more information let me know.Thanks,Pauline.

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

The ipo link time message usually is a consequence of an earlier error, so by itself this message is useless.

Do you mean option /Qipo- ? This option will turn off IPO when making .obj files, but the linker will still perform a search for IPO objects. There isn't a straightforward way to prevent that. If you do prevent the IPO linker from running, the link will fail if there were IPO objects.

Hi,

I have the same error message: "5>Link: error #10014: problem during multi-file optimization compilation (code 128)2

I am using Compiler XE : Intel(R) Visual Fortran Compiler XE on IA-32, version 12.1.2 Package ID: w_fcompxe_2011.8.278

Note that in Debug mode all work fine.

I tried all options in IPO...

Thanks,

Francis

 

TimP's response usually applies - look to see if there was an error from earlier build steps.  If you need further help, we'd need to see a ZIP of the project.

Steve - Intel Developer Support

Leave a Comment

Please sign in to add a comment. Not a member? Join today