error in running fortran in abaqus6.8

error in running fortran in abaqus6.8

Hi, experts.
I've installed IVFortran v9.1 and microsoft visual c++2005 and try to integrate with Abaqus v6.8-1.
I'm trying to run the command under abaqus jobs directory using
c:\\abaqus jobs>abaqus job=plate-vusdfld user=xx.VUSDFLD interactive
This command is to run the job with user subroutine.

But I got the error as follows:
"Begin Compiling Single Precision Abaqus/Explicit User Subroutines
ifort: error: could not find 'cl'
End Compiling Single Precision Abaqus/Explicit User Subroutines
Begin Linking Single Precision Abaqus/Explicit User Subroutines
ValueError: LINK.exe not found in PATH.
"
So what should I do next to fix it?
Could anyone help me out?
Thanks.

BTW, the operating system is windows xp 64 digit.

29 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Well, that is an old version of Fortran, but...

The "could not find cl" means that it was not able to locate Microsoft Visual C++ so that it knows which version to use. Have you established the Fortran build environment using the ifortvars.bat script? That it could also not find LINK implies to me that you have not done this.

Steve

Hi, Steve.
Thank you for your reply.
I just installed microsoft visual c++ 2005 into default directory.
Then I installed Intel visual fortran v9.1 also using the default directory.
Could you tell me hwo to establish the Fortran build environment using the ifortvars.bat script.
Thanks.

The easy way is to use the shortcut on the Start menu to open the ifort command prompt window. The shortcut sets up the ifort and cl environments for you. If you wish to do it in a window which you opened yourself, you can use the .bat file as the shortcut invokes it.

Hi TimP,
Could you show me how to do that in an easy way?
I'm new to Fortran use with micro visual studio. The following pic is my screenshot.
I don't know how to do that.
I'm searching this information on the web but cannot find the case like mine.

I found the following source on the web.
"Intel Visual Fortran Compiler 9.1 for Windows* Release Notes

If you want to reference an existing installed Platform SDK from within
Visual Studio 2005, you can do so in one of two ways:

  1. Open the appropriate build environment command window (Start.. All
    Programs.. Intel Software Development Tools.. Intel Fortran Compiler 9.1..Build
    Environment for ) and issue the commands:

    "C:\Program Files\Microsoft Platform SDK\SetEnv.bat"
    "C:\Program
    Files\Microsoft Visual Studio 8\Common7\IDE\devenv" /useenv

    The first command invokes the environment setup procedure for the Microsoft
    Platform SDK you are using, and the second starts the Visual Studio development
    environment using the established environment. Replace the file paths shown with
    the correct paths for your system.

  2. Manually change all pertinent pathnames in Visual Studio's
    Tools..Options..Projects..Directories to include the appropriate directories
    from your chosen Platform SDK.

"

But my product is not microsoft platform SDK. I only install micro visual studio c++2005.

Do I need to install microsoft platform SDK to use Fortran?
Thanks.

No, assuming you installed enough of Visual C++.

Steve

Hi, Steve.
I found the following source on the web.
But I cannot follow the first step because I cannot find "c:\program files\microsoft platform SDK\SetEnv.bat".
"
-->

If you want to reference an existing installed Platform SDK from within
Visual Studio 2005, you can do so in one of two ways:

  1. Open the appropriate build environment command window (Start.. All
    Programs.. Intel Software Development Tools.. Intel Fortran Compiler 9.1..Build
    Environment for ) and issue the commands:

    "C:\Program Files\Microsoft Platform SDK\SetEnv.bat"
    "C:\Program
    Files\Microsoft Visual Studio 8\Common7\IDE\devenv" /useenv

    The first command invokes the environment setup procedure for the Microsoft
    Platform SDK you are using, and the second starts the Visual Studio development
    environment using the established environment. Replace the file paths shown with
    the correct paths for your system.

  2. Manually change all pertinent pathnames in Visual Studio's
    Tools..Options..Projects..Directories to include the appropriate directories
    from your chosen Platform SDK.

"

But my product is not microsoft platform SDK. I only install micro visual studio c++2005.

All you need to do is open the "Fortran Build Environment" command window from the start menu. The other stuff is not necessary and would assume you've installed other things you don't need.

Steve

Hi, Steve
I don't know what's wrong with my"Intel Fortran Compiler 9.1.023 build environment for EM64T-based applications".
When I click that one it just pops up this command window. But the command is
C:\Documents and Settings\me277c>
If I input command "ifortvars.bat" in that directory, it says "The system cannot find the path specified."
How can I move forward?
Thanks.

The "build environment" window shortcut runs ifortvars.bat for you, but it should have set up PATH so that ifortvars.bat could be found (not that you should need it). Was there any other output when you first opened the command window? Are you trying to build a 64-bit application? (That's what the "EM64T" is for. Maybe you want IA-32 instead?)

That version is so old I don't have it installed anymore, so my memory may be a bit foggy, but it should display some information about the compiler and Visual Studio version when you use the Build Environment shortcut. Try the IA-32 one.

If you do want 64-bit builds, you will need to make sure that you have VS2005's 64-bit support installed. It is not the default. You may need to do a "Change" on VS2005 and add in the "x64 Compiler and tools" component.

I suggest starting with IA-32 and get that working.

Steve

There are too many uncertain factors here. Unless I missed noting it, it has not been stated whether the Abaqus is 32-bit or 64-bit. The version that you identified (6.8) came with both 32- and 64-bit editions. Most probably, you need to use a C-compiler and/or Fortran compiler of the same bit-size and an OS that supports those compilers. The Abaqus Web site states that their 6.8 goes with VC++ 2005 and Intel Fortran 9.1 to 10.1. That gives us eight possible combinations of Abaqus, Visual C++ and Intel Fortran. You want only one of those combinations (some of the other combinations may be useful for other things, so I am not suggesting that if they exist they need to be removed).

Specifically, identify which versions of Abaqus, Visual C++ and Intel Fortran you have. One place to look for this information is under the Programs and Features item of the Windows Control Panel

Once you identify the versions, we can take things up from there as to installing Intel Fortran.

Hi, Mecej4
All are 64-bit.
Thanks.

Good. From the same command window from which you tried to execute Abaqus, try running

cl

and

link

If these are not found, you need to fix that problem first. Otherwise, please not the version information output from each command and let us know.

Duplicate post. Please delete.

I just input the following commands but didn't work.
c:\abaqus jobs>cl
and
c:\abaqus jobs>link

It says 'cl' is not recognized as an internal or external command, operable program or batch file.

So how to run cl and link?
Are those commands correct? What are thy if not?
Thanks.

It means you have not established a command environment for Fortran or for Microsoft Visual C++. How did you start the command prompt session?

Steve

Do you mean the command prompt session for abaqus?
I have a shortcut for abaqus command right over the "start".

You need to open an Intel Visual Fortran Build Environment window and then invoke Abaqus from that.

Steve

But when I try "Intel Fortran Compiler 9.1023 build environment for EM64T-based applications",
It directed me to C:\Documents and Settings\me277c>
not abaqus jobs command.
Why is that?
How to fix it?

Right click on your shortcut for Abaqus and select Properties > Shortcut. What is the full text of what is in the Target field and the Start in field?

From any command prompt, please type:

set ifort

and tell me what it says.

Steve

Hi Steve,
My shortcut for Abaqus is gone I screwed it up.
But in start-> All Programs->Intel software development tools->Intel Fortran compiler 9.1->
I find c:\ abaqus command.
Check its property, it says
Target: C:\WINDOWS\SysWOW64\cmd.exe /K
Start in: c:\abaqusjobs

Best Reply

Ok, that's easy then. Drag a copy of the Intel Visual Fortran Build Environment for EM64T applications shortcut to your desk (be sure not to do a "Move".) Right click on it and select Properties. Change the Start In to be C:\Abaqusjobs Change the name of the shortcut to be Abaqus.

Steve

Thank you, Steve.
I've made the change but it still shows that
"ifort: error: could not find 'cl'
ValueError: Link.exe not found in PATH.
"

Well, it seems you don't have Visual Studio installed properly then. My guess is that you did not ask for the x64 support when you installed Visual Studio. Do this:

1. From Control Panel > Add or Remove Programs, select Microsoft Visual Studio 2005 > Change/Remove. The Visual Studio Maintenance Mode window will appear.
Click Next.
2. Click Add or Remove Features
3. Under Select features to install, expand Language Tools > Visual C++
4. If the box X64 Compiler and Tools is not checked, check it, then click Update. If the
box is already checked, click Cancel.

Now try it again.

Steve

Hi Steve,
I've done the maintenance of visual studio 2005 according to your saying.
Now I input a commond to verify the installation under the directory c:\abaqusjobs>:
c:\abaqusjobs>abaqus verify -user
It gave me the following message:
Pass- Found microsoft windows xp professional x64 edition SP2;
Pass- Found .NET Framework Version 2.0
Fail- Unable to locate or determine the version of a c++ compiler on this systerm. If microsoft visual c++8.0(.net 2005) is installed on this systerm, please load vcvarsamd64.bat file before running abaqus.
Pass-Found Intel Fortran Compiler 9.1.

If I run the abaqus inp file and user subroutine, it still gives me
ifort: error: could not find 'cl'
ValueError:LINK.exe not found in PATH

BTW: I have restarted PC after I finished maintenence of visual studio 2005.
Thanks.

Try an uninstall and reinstall of Fortran. If it still fails, show me what is displayed when you first open the Fortran Build Environment window.

I'm somewhat hampered by your using such an old compiler version...

Steve

Hi Steve,
Thank you so much!
Now my abaqus user subroutine can be run.
To use such an old compiler version is because my boss will not use high version abaqus such that I have to find old version fortran to be compatiable with that software.

Login to leave a comment.