Problem with MKL intel64

Problem with MKL intel64

Hi,
I download the mkl trial version for windows system using MIcrosoft Visual Studio 2008. I have tested it for IA-32 architecture, static linking with IA32 libraries and it works well.
The problem is when I try to test the same programs in a 64 bits arquitecture. I've got an intel core i7 CPU. I change the Additional Library Directories to intel64 instead of IA32, and I type the required libraries in Configuration Properties
>
Linker
>
Input.

When I compile it it compiles without errors, but appears this message:

(Spanish) LINK : no se encontr D:\\archivos_de_progrramas\\intel\\GSC\\x64\\Debug\\GSC.exe o no lo gener el ltimo vnculo incremental; ejecutando vnculo completo
(English Translation) LINK : not found
D:\\archivos_de_progrramas\\intel\\GSC\\x64\\Debug\\GSC.exe or no generation of the last incremental link; excecuting complet linking.

When I debugg apears a Microsoft Visual Studio window with the next error:

(Spanish)
No se puede iniciar el programa
'd:\\archivos_de_programas\\intel\\GSC\\x64\\Debug\\GSC.exe'
Error de inicio de la aplicacin porque la configuracin de la misma no es correcta. Revise el archivo de manifiesto para detectar posible errores. Si vuelve a instalar la aplicacin puede que se corrijan los problemas. Para obtener ms detalle, consulte el registro de eventos de la aplicacin.
(English Translation)
Application can not start
'd:\\archivos_de_programas\\intel\\GSC\\x64\\Debug\\GSC.exe'
Error starting the application because the configuration is not correct. Check the manifest file for possible errors. Reinstalling the application may correct problems. For more details, see the event log of the application.

Please help me!! :)

Thanks,
Jorge

12 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Jorge,Please check first what libraries did you link. You have to link the 64bit libraries from as an examples \MKL\10.2.7\em64t\lib\ directory which is Intel 64 Architecture Directory.--Gennady

Hi Gennady,

Thank you for replaying. I have linked the 64bit libraries like is explained in user's guide:

- linker> general>additional library dependencies --> \lib\intel64 and compiler\lib\intel64

- linker> input> additional dependencies --> mkl_intel_lp64.lib mkl_intel_thread.lib

mkl_core.lib libiomp5md.lib ...for static linking.

Is it correct? do I have to link other libraries?

Thanks,

Jorge

Yes, that's correct. These are all libraries you need to link. And you still cannot start the executable?What version of the MKL do you use? OS?
--Gennady

I use Intel Composer XE 2011 Update 1 for Windows (30 day trial version) ans windows 7 as OS.
The strange thing is that doing all necessary libraries changes, with 32 bits work, but with 64 bits I still have the above mentined error (i cannot start the executable).
Thanks!
jorge

Any idea of why is not working??
thanks! :)

If you have installed Windows 7 32-bit, you can build a 64-bit version of your application, but you can't run it.

I've got windows 7 64-bits installed.. :S

Same problem here!

Using Visual Studio 2005 (C++) and MKL (versions 10.2.4; 10.2.7)
AND WINDOWS 7 (64bit) or WINDOWS SERVER 2008.
Even the testexample: pardiso_sym_c.c doesn't start. (No compiler errors!)
Using WINDOWS XP (64bit) this is no problem.

Using Visual Studio 2005 (C++) and MKL (version 10.3.2)

AND WINDOWS 7 (64bit)
it seems to make a difference do compile in debug or release.
but on WINDOWS SERVER 2008 both doesn't work.

Any idea? Anybody?

I can compile and run the mentioned example (pardiso_sym_c.c) with no problems on Win7 Home Premium SP1 X64, with the current version of MKL (10.3.4).

(i) Using dynamic libraries:

S:\>cl /MD pardiso_sym_c.c mkl_intel_lp64_dll.lib mkl_intel_thread_dll.lib mkl_core_dll.lib libiomp5md.lib
Microsoft C/C++ Optimizing Compiler Version 16.00.30319.01 for x64

(ii) Using static libraries:

S:\>cl /MT pardiso_sym_c.c mkl_intel_lp64.lib mkl_intel_thread.lib mkl_core.lib libiomp5md.lib

Have you checked the settings in your IDE? Please display the link line and, if possible, attach a build log?

Thanks for the quick response!

using
- Windows 7 Professional SP1 x64
- MS Visual Studio 2005 Version 8.0.5... Professional Edition
- MKL (10.3.2)
and dynamic libraries (following intel link advisor)
I can compile and run with no problem for Win32.

I can also compile for x64 (also taking the additional compiler option /DMKL_ILP64 into account):
but couldn't run.

I found out (using dependency walker) that libiomp5md.dll couldn't be found.

adding C:\Program Files (x86)\Intel\ComposerXE-2011\redist\intel64\compiler; to the environment variable path solved this problem.

since i often switch between x86 and x64 this is not an efficient solution. Of cause it's also possible to open a shell, set the needed env-variable and start the executable in this environment,
but I asked myself if there's anoter possibility to tell the executable to set this env-variable accordingy, such that I can still execute it by pressing Strg+F5 in Visual (but maybe that's a too Visual-specific question). Thankful for any idea/help!

Frequentlly, I have two command windows open, one wih a 32-bit development environment and another for 64-bit. One click is all that it takes to switch from one to the other. Everything works well. I can even type devenv myexe and the IDE comes up with the environment inherited from the command window that I typed the command in.

I think that it is possible to set the run-time environment in the IDE/debugger properties, too, but I don't use that mode.

Login to leave a comment.