[solved] PARDISO doesn't recognize HTT threads

[solved] PARDISO doesn't recognize HTT threads

Sören Plönnigs's picture

Hi, I want to do some benchmarking on pardiso. I have the problem that pardiso doesn't recognize HTT Threads. I now that there won't be a performance gain, but I need this comparison for my bachelor thesis. Our System has 8 Cores and 16 Threads. Neither specifying iparm[2]=16 nor setting OMP_NUM_THREADS=16 does the job. HTT is enabled in BIOS as the following output shows: OMP: Info #171: KMP_AFFINITY: OS proc 0 maps to package 0 core 0 thread 0 OMP: Info #171: KMP_AFFINITY: OS proc 10 maps to package 0 core 0 thread 1 OMP: Info #171: KMP_AFFINITY: OS proc 6 maps to package 0 core 1 thread 0 OMP: Info #171: KMP_AFFINITY: OS proc 14 maps to package 0 core 1 thread 1 OMP: Info #171: KMP_AFFINITY: OS proc 7 maps to package 1 core 0 thread 0 OMP: Info #171: KMP_AFFINITY: OS proc 15 maps to package 1 core 0 thread 1 OMP: Info #171: KMP_AFFINITY: OS proc 3 maps to package 1 core 1 thread 0 OMP: Info #171: KMP_AFFINITY: OS proc 11 maps to package 1 core 1 thread 1 OMP: Info #171: KMP_AFFINITY: OS proc 1 maps to package 2 core 0 thread 0 OMP: Info #171: KMP_AFFINITY: OS proc 8 maps to package 2 core 0 thread 1 OMP: Info #171: KMP_AFFINITY: OS proc 4 maps to package 2 core 1 thread 0 OMP: Info #171: KMP_AFFINITY: OS proc 12 maps to package 2 core 1 thread 1 OMP: Info #171: KMP_AFFINITY: OS proc 5 maps to package 3 core 0 thread 0 OMP: Info #171: KMP_AFFINITY: OS proc 13 maps to package 3 core 0 thread 1 OMP: Info #171: KMP_AFFINITY: OS proc 2 maps to package 3 core 1 thread 0 OMP: Info #171: KMP_AFFINITY: OS proc 9 maps to package 3 core 1 thread 1

OMP: Info #171: KMP_AFFINITY: OS proc 0 maps to package 0 core 0 thread 0 The same problem applies to ISS and DSS. Does anybody know what's the problem? Regards, Soeren

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Konstantin Arturov (Intel)'s picture
Best Reply

Hi Soeren, MKL dynamically changes the number of threads to the most optimal value. To disable this, please usemkl_set_dynamic(0) call. With best regards, Konstantin

Gennady Fedorov (Intel)'s picture

Soeren, just two my cents -yes, thesame problem applies to ISS and DSS and to all others MKL domains. Using MKL_DYNAMIC Environment variable and/or mkl_set_dynamic() service function will enable MKL to dynamically change the number of threads. By the default,
MKL_DYNAMIC is TRUE and whenMKL tries to use what it considers the best number ofthreads, up to the maximum number you specify.
see more details into User's Guide. --Gennady


Login to leave a comment.